OS. Use Geometry Methods

  1. Type geometry = os.Geometry and then press Return.

    This defines the geometry variable as the Geometry group of methods in OpenSTAAD.

  2. Type geometry._FlagAsMethod("GetNodeCount") and then press Return.
    This is required to correctly identify the OpenSTAAD methods as such in Python.
  3. Type geometry._FlagAsMethod("GetMemberCount") and then press Return.
    This is required to correctly identify the OpenSTAAD methods as such in Python.
Your program at this point should look like:
from comtypes import automation
from comtypes import client
import ctypes
os = client.GetActiveObject("StaadPro.OpenSTAAD")
geometry = os.Geometry
geometry._FlagAsMethod("GetNodeCount")
geometry._FlagAsMethod("GetMemberCount")