OpenRoads Designer CONNECT Edition SDK Help

ProfileCircularArcConstructor Methods

Methods

CreateCircularArc Constructs a ProfileCircularArc by end points and radius.
CreateCircularArcByParameters Constructs a ProfileCircularArc by parameters.
CreateCircularArcByTangents Constructs a ProfileCircularArc by tangents.
CreateTangentCircularArc(ProfileElement, DPoint3d, DPoint3d) Constructs a ProfileCircularArc tangent to a profile element.
CreateTangentCircularArc(ProfileElement, DPoint3d, DPoint3d, Double) Constructs a ProfileCircularArc tangent to a profile element.
CreateTangentCircularArcTwoElementsByLength Constructs Vertical circle tangent to two elements and projected length.
CreateTangentCircularArcTwoElementsByPoint Constructs a ProfileCircularArc tangent to two profile elements and passing through a point.
CreateTangentCircularArcTwoElementsByRadius Constructs a ProfileCircularArc element tangent to two profile elements giving the radius value.
CreateTangentCircularArcTwoLinesByLength Constructs a Vertical circle element tangent to two profile lines elements.

See Also