OpenRoads Designer CONNECT Edition SDK Help

CreateTangentCircularArc(ProfileElement, DPoint3d, DPoint3d, Double) Method

Constructs a ProfileCircularArc tangent to a profile element.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileCircularArc[]CreateTangentCircularArc( ProfileElement elmt, DPoint3d thruPoint, DPoint3d limitPoint,double radius)

Parameters

SettingDescription
  ProfileElement The profile element which the created ProfileCircularArc is tangent to.
  DPoint3d The through passing point of the arc
  DPoint3d The limited point to project with normal projection on the arc to obtain the end point of the arc
   The radius of the arc

Return Value

ProfileCircularArc[] The ProfileCircularArc element

See Also