OpenRoads Designer CONNECT Edition SDK Help

CreateTangentCircularArcTwoElementsByPoint Method

Constructs a ProfileCircularArc tangent to two profile elements and passing through a point.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileCircularArc[]CreateTangentCircularArcTwoElementsByPoint( ProfileElement elmt1, ProfileElement elmt2, DPoint3d thruPoint)

Parameters

SettingDescription
  ProfileElement The first profile element which the created ProfileCircularArc is tangent to.
  ProfileElement The second profile element which the created ProfileCircularArc is tangent to.
  DPoint3d The through passing point of the arc

Return Value

ProfileCircularArc[] The tangent ProfileCircularArc element

See Also