ProjectWise Design Integration Readme

Release Notes

ProjectWise Explorer Installation Notes

  1. As a rule, ProjectWise does not support running ProjectWise applications from different versions on the same computer, and this release is no different. Specifically, please do not try to install ProjectWise Explorer CONNECT Edition Update 3.1 refresh on a computer where ProjectWise Administrator CONNECT Edition Update 3.1 or earlier is also installed. Running two different versions of these particular applications on the same computer can cause unexpected and potentially unwanted behaviors.
  2. The Modify feature of the ProjectWise Explorer installer has been fixed. This means that you no longer have to uninstall and reinstall to change what features are installed.
  3. If you need to install ProjectWise Explorer with AutoCAD 2016 integration, it is recommended that you launch the ProjectWise Explorer installation wizard by double-clicking the Setup_ProjectWisex64_10.00.03.16x.exe file, rather than launching it from a command prompt, which may cause the installation to fail.
  4. If you have ProjectWise Explorer CONNECT Edition Update 2 or later installed along with the standalone ProjectWise Integration Module for AutoCAD 2018 (10.00.02.526), make sure you manually uninstall this integration module first before you upgrade your ProjectWise Explorer installation to the current version (which also includes AutoCAD 2018 integration).
  5. If you have ProjectWise Explorer installed with Office 2013 integration and you want to upgrade your version of Office, it is recommended that you uninstall ProjectWise Explorer and Office 2013 integration first, then upgrade to Office 2016, then install the current ProjectWise Explorer with Office 2016 integration.
    Note: If you accidentally upgraded to Office 2016 before first uninstalling Office 2013 integration, your ProjectWise Explorer uninstallation will fail because the Office 2016 upgrade removed some files from the Office 2013 integration. As a workaround, you will need to repair the Office 2013 integration using the cached 'ProjectWise Integration for Microsoft Office 2013 and 365' installer, which can be done by running this command from a command prompt: msiexec.exe /f {69A6F7DC-EEBE-5420-9911-0EB2F54FC669}. After the Office 2013 integration has been repaired, you can go back and uninstall ProjectWise Explorer.

Compatibility with Previous Versions

Depending on the version you are upgrading from, you may still be able to use your older client with the new server, or your new client with an older server.

ProjectWise Design Integration Server CONNECT Edition Update 3.1 (10.00.03.140) supports connections from:

  • ProjectWise Administrator CONNECT Edition Update 3.1 (10.00.03.140)
  • ProjectWise Explorer CONNECT Edition Update 3.1 refresh (10.00.03.16x)
  • ProjectWise Explorer CONNECT Edition Update 3.1 (10.00.03.140)
  • ProjectWise Explorer CONNECT Edition Update 3 (10.00.03.49)
  • ProjectWise Explorer CONNECT Edition Update 2.3 (10.00.02.320)
  • ProjectWise Explorer CONNECT Edition Update 2.2 (10.00.02.265)
  • ProjectWise Explorer CONNECT Edition Update 2.1 (10.00.02.203)
  • ProjectWise Explorer CONNECT Edition Update 2 (10.00.02.96)
  • ProjectWise Explorer CONNECT Edition Update 1.2 (10.00.01.71)
  • ProjectWise Explorer CONNECT Edition Update 1.1 (10.00.01.67)
  • ProjectWise Explorer CONNECT Edition Update 1 (10.00.01.25)
  • ProjectWise Explorer CONNECT Edition (10.00.00.20)
  • ProjectWise Explorer V8i (SELECTseries 4) (08.11.11.590)
  • ProjectWise Explorer V8i (SELECTseries 3) (08.11.09.122)
  • ProjectWise Explorer V8i (SELECTseries 2) (08.11.07.443)
  • ProjectWise Explorer V8i (SELECTseries 1) (08.11.07.133)
  • ProjectWise Explorer V8i (08.11.05.63)
  • ProjectWise Caching Server CONNECT Edition Update 3.1 (10.00.03.140)
  • ProjectWise Caching Server CONNECT Edition Update 3 (10.00.03.49)
  • ProjectWise Caching Server CONNECT Edition Update 2.2 (10.00.02.265)
  • ProjectWise Caching Server CONNECT Edition Update 2 (10.00.02.96)
  • ProjectWise Caching Server CONNECT Edition Update 1.1 (10.00.01.67)
  • ProjectWise Caching Server CONNECT Edition Update 1 (10.00.01.25)
  • ProjectWise Caching Server V8i (SELECTseries 4) (08.11.11.590)
  • ProjectWise Web Server V8i (SELECTseries 4) (08.11.11.590 or later)

ProjectWise Explorer CONNECT Edition Update 3.1 refresh (10.00.03.16x) can connect to:

  • ProjectWise Design Integration Server CONNECT Edition Update 3.1 (10.00.03.140)
  • ProjectWise Design Integration Server CONNECT Edition Update 3 (10.00.03.49)
  • ProjectWise Design Integration Server CONNECT Edition Update 2.2 (10.00.02.265)
  • ProjectWise Design Integration Server CONNECT Edition Update 2 (10.00.02.96)
  • ProjectWise Design Integration Server CONNECT Edition Update 1.1 (10.00.01.67)
  • ProjectWise Design Integration Server CONNECT Edition Update 1 (10.00.01.25)
  • ProjectWise Integration Server V8i (SELECTseries 4) (08.11.11.590)
Important: The version of ProjectWise Administrator you use must always be the same version as the ProjectWise Design Integration Server.

All ProjectWise applications on a single computer must be of the same release version. For example, you cannot have applications from both ProjectWise CONNECT Edition Update 3.1 and Update 3 installed on the same computer.

Silent Installation from a Command Prompt

You can install ProjectWise Explorer silently (without using the wizard) from a command prompt.

To find out which features you can include or exclude from your install, open a command prompt with elevated privileges (run as administrator) and then enter the following command:

"path_to_PWEinstaller\Setup_ProjectWisex64_10.00.03.xx.exe" ExportCliArgs=path_to_output\FeatureIDTree.txt

For example:

"C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe" ExportCliArgs=C:\PWinstalls\FeatureIDTree.txt

This creates a file called FeatureIDTree.txt which contains a list of all the features that can potentially be installed through the ProjectWise Explorer installer. Open this file in a text editor and review which features you want to include in your installation command. Items with an asterisk * next to them (for example, ProjectWiseExplorerPackage*) are required features that will always be installed and therefore do not need to be specified in the command.

Features that are normally turned on by default in the wizard do not need to be specified in the installation command unless you want them not to be installed. Likewise, features that are normally turned off by default in the wizard do not need to be specified unless you want them to be installed. If the installer delivers integration for an application you have installed, integration will be turned on for that application by default unless you specify to not install it. Use the ADDLOCAL property in your command to install a feature that is not normally installed by default, or if modifying the installation, to install a feature that was previously not installed. Use the REMOVE property in your command to turn off a feature that is normally installed by default, or if modifying the installation, to uninstall a feature. If you need to install more than one feature, or turn off more than one feature, separate those features in the command with a comma. The feature names are case sensitive and should be typed exactly as they appear in the FeatureIDTree.txt and without the leading dashes (for example, type Office2016 instead of ---Office2016).

Example: Install ProjectWise Explorer silently, with all default features and integration for installed applications:

“C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe” -silent

Example: Install ProjectWise Explorer silently, and do not install the Document Creation Wizard (which is normally installed by default):

“C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe” REMOVE=ProjectWiseExplorerPackage_DocumentCreationWizard -silent

Example: Install ProjectWise Explorer silently and do not install Office 2016 integration (assuming Office 2016 is installed), or modify the installation and turn off Office 2016 integration (if it was installed and now you want to turn it off):

“C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe” REMOVE=Office2016 -silent

Example: Modify the ProjectWise Explorer installation, and turn on Office 2016 integration (if it was not installed and now you want it installed):

“C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe” ADDLOCAL=Office2016 -silent

Example: Install ProjectWise Explorer silently, with the Bentley DGN Navigator Control and the ProjectWise Deliverables Management connector for ProjectWise Explorer (which are both normally turned off by default):

“C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe” ADDLOCAL=DgnNavigatorControlAx,PWDeliverablesMGTClient -silent

By default, the installation log file is saved to C:\Users\<user.name>\AppData\Local\Temp\ProjectWise_Explorer_CONNECT_Edition_<datetime>.log. You can change where the log file gets saved adding the -log argument to your command.

Example: Install ProjectWise Explorer silently, and send the log file to a different folder:

“C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe” -log="C:\PW_installs" -silent

Example: Uninstall ProjectWise Explorer silently:

“C:\PW_installs\Setup_ProjectWisex64_10.00.03.24.exe” -uninstall -silent
Tip: Always test your installation configuration by running your command without the -silent argument. This will open the installation wizard and show which features your command has turned on or off, on the Select feature to install page. If this page shows what you are expecting, then you can assume that running the same command silently will install everything you instructed it to install.

Directory Structure

Most ProjectWise applications are 64-bit, but some are still 32-bit.

The default installation location for 64-bit ProjectWise applications on a 64-bit operating system is:

  • C:\Program Files\Bentley\ProjectWise

The default installation location for 32-bit ProjectWise applications on a 64-bit operating system is:

  • C:\Program Files (x86)\Bentley\ProjectWise

ProjectWise Orchestration Framework Service is a 64-bit application whose default installation location is:

  • C:\Program Files\Bentley\OrchestrationFramework

ProjectWise Explorer delivers both 64-bit and 32-bit components:

  • The 64-bit components of the application are installed to C:\Program Files\Bentley\ProjectWise by default
  • The 32-bit components of the application are installed to C:\Program Files (x86)\Bentley\ProjectWise by default
Important: DO NOT install 64-bit and 32-bit items to the same location, as this will cause problems.

Use the Latest CONNECTION Client

The CONNECTION Client checks the Bentley Software Fulfillment Center to see if there are any updates available for the Bentley applications that you currently have installed (including the CONNECTION Client itself), and then lets you decide which applications to update, and when you want to update them.

ProjectWise also relies on the CONNECTION Client for several workflows, including logging in to datasources with your Bentley IMS account, associating work areas to ProjectWise cloud projects, and publishing to ProjectWise Share from Revit.

Bentley updates the CONNECTION Client frequently, and it is recommended that you update to the latest version of the CONNECTION Client whenever possible. Recent older versions of the CONNECTION Client should be OK to use in most cases, however it could cause problems in some workflows. For example, publishing to ProjectWise Share from Revit requires the latest version of the CONNECTION Client.

Standalone ProjectWise Indexing Service

The standalone ProjectWise Indexing Service is no longer delivered with ProjectWise Server Setups. If you are currently using a standalone ProjectWise Indexing Service from a previous CONNECT Edition release, you can continue to use it with this release. Otherwise, if you want to perform text extractions and host the catalog on a computer other than the main ProjectWise Design Integration Server, install a copy of ProjectWise Design Integration Server on another computer and set up a head / tail server configuration. See the ProjectWise Implementation Guide for details.

ProjectWise Web Server

ProjectWise Web Server is no longer delivered. If you need this feature, use ProjectWise Web Server V8i (SELECTseries 4). Also, if you need to use ProjectWise Publishing Gateway Service with your ProjectWise Web Server, then use ProjectWise Publishing Gateway Service V8i (SELECTseries 4) and NOT the ProjectWise Publishing Gateway Service from this release.

Using ProjectWise Deliverables Management and Bentley Transmittal Services in the Same Project

ProjectWise Deliverables Management is the replacement product for Bentley Transmittal Services. While you cannot upgrade a Transmittals Management project to a Deliverables Management project, you can enable and use Deliverables Management in a ProjectWise project where Transmittals Management is already enabled and in use.

MicroStation Integration

Support for MicroStation CONNECT Edition does not currently include support for scalable reality mesh files (*.3sm).

AutoCAD Integration

  • AutoCAD integration also includes advanced ProjectWise integration support for AutoCAD Civil 3D.
  • When installing this integration module, you may get a warning that the installer cannot update certain files in use, because it cannot close the Windows Explorer process. It is safe to ignore this warning and restart your computer when installation is complete. These files will be updated when the computer is restarted.
  • Due to a limitation of the AutoCAD API, when selecting a ProjectWise document from Recent Documents in AutoCAD, the document that was last opened from ProjectWise Explorer opens, rather than the selected document.
  • For AutoCAD Civil 3D, HOOKLESSREPATH mode is now always enabled, and cannot be disabled.

Microsoft Office Integration

  • If using Microsoft Office 365, you must install Office 365 using Click-to-Run. No other installation methods are supported.
  • To avoid any integration complications, it is recommended that you only have one version of Microsoft Office installed.
  • Captive environment is not supported with this integration.
  • In integrated Office applications, the File > Export > Change File Type command (File > Export > Save Project As File in Microsoft Project) is not integrated. (Outlook does not have this command.)
  • In integrated Outlook, the following integrated commands are not working correctly and should be avoided:
    • Send To > Mail Recipient
    • Send To > Mail Recipient As Link
  • In integrated Excel, using the Insert > Object command on the ProjectWise tab may cause Excel to freeze or crash. Uninstalling or disabling Excel's Solver add-in will reduce the occurrence of this issue but may not prevent it in all cases.
  • In integrated PowerPoint and Project, exiting the application when a new document needs to be created will require you to manually close the application after the new document is created.

Adobe InDesign Integration

  • When integration is installed and you want to open an Adobe InDesign document that is stored in ProjectWise, but you want to open it in non-integrated mode, do not use Document > Open With in ProjectWise Explorer. Instead, you must first disable integration from inside Adobe InDesign. When you have checked in the document and you want to go back to working in integrated mode, enable integration again from inside Adobe InDesign.
  • In integrated Adobe InDesign, use Export instead of Save As if you want to save the document to IDML format.
  • " Document modified outside of book " - Various events, including reordering documents in a book, will cause this warning. If you see this warning in a book, it usually just means that the modification time ProjectWise recorded for the document is different than the modification time recorded in the book (and also in the file itself). To resolve this, simply open the file from the book, close it without making changes, and check it in when prompted.

ProjectWise Dependency Service

Dependency Viewer is an option of the ProjectWise Explorer installer. Installing this feature adds a Dependency Viewer tab to the Preview Pane in ProjectWise Explorer, which is used to show relationships or "dependencies" between documents in the datasource. Dependency Service Administrator and Dependency Service authoring capabilities are not available in this release. This means you cannot create custom dependency maps in ProjectWise Explorer. Also, if you have any custom dependency maps created from a previous release, you will not be able to view them.

AutoPLANT Projects

To enable support in ProjectWise for existing AutoPLANT V8i and AutoPLANT XM Edition projects, you must add the variable, LoginTokenUseLegacyCrypto=1, to the ProjectWise Design Integration Server's DMSKRNL.CFG file under the [TeamMate] section.

Logging

To configure logging for edit this file which outputs to
ProjectWise Design Integration Server, ProjectWise Caching Server, or ProjectWise Gateway Service C:\Program Files\Bentley\ProjectWise\bin\dmskrnl.log.xml C:\Users\All Users\AppData\Local\Bentley\Logs\dmskrnl.log
ProjectWise User Synchronization Service C:\Program Files\Bentley\ProjectWise\bin\usersync.log.xml C:\Users\user.name\AppData\Local\Bentley\Logs\usersync.log
ProjectWise Administrator C:\Program Files\Bentley\ProjectWise\bin\pwadmin.log.xml C:\Users\user.name\AppData\Local\Bentley\Logs\pwadmin.log
ProjectWise Explorer C:\Program Files\Bentley\ProjectWise\bin\pwc.log.xml C:\Users\user.name\AppData\Local\Bentley\Logs\pwc.log
integrated MicroStation C:\Program Files\Bentley\ProjectWise\bin\mcm.log.xml C:\Users\user.name\AppData\Local\Bentley\Logs\mcm.log
integrated AutoCAD, integrated Office C:\Program Files\Bentley\ProjectWise\bin\odma.log.xml C:\Users\user.name\AppData\Local\Bentley\Logs\odma.log
ProjectWise Orchestration Framework Service, Bentley i-model Composition Server for PDF, or ProjectWise Design Integration Server's document processors C:\Program Files (x86)\Bentley\OrchestrationFramework\OrchFwrkLogging.config C:\ProgramData\Bentley\Logs\LoggingService.log

Notes:

  • Logging in integrated MicroStation is enabled by default, and is controlled by the configuration variable PW_BSILOG_ENABLE in the MCM.CFG file, which is located in the C:\Program Files\Bentley\ProjectWise\Bin folder.
  • If you need to add appenders for ProjectWise Orchestration Framework Service logging, edit this file: C:\Program Files (x86)\Bentley\LoggingServer\BentleyLoggingServer.exe.config

ProjectWise QuickView

ProjectWise QuickView is no longer delivered with ProjectWise Explorer. You can still use the Document > View option in ProjectWise Explorer, if you have a suitable viewer installed for the selected document. Users who are currently using ProjectWise QuickView from an earlier version of ProjectWise Explorer can continue to use it, but be aware that ProjectWise QuickView has been removed from all versions of ProjectWise Explorer that are available for download on the Bentley Software Fulfillment Center. We apologize for any inconvenience, however we do not expect this to be a major impact on your day-to-day operations in ProjectWise Explorer, as there are many free file viewer applications available for download from the Internet. For your convenience, we have provided a page on Bentley Communities that has links to some common file viewers:

Delivered Product Documentation (Help)

This help file is delivered when you install and contains help about
PWAdministrator.chm ProjectWise Administrator
  • using ProjectWise Administrator
  • using ProjectWise Design Integration Server
  • using ProjectWise Caching Server
  • using ProjectWise Gateway Service
  • using ProjectWise User Synchronization Service
PWExplorer.chm ProjectWise Explorer
  • using ProjectWise Explorer
  • using Spatial tools
  • using Dependency Viewer
  • working in integrated applications
BentleyimodelCompositionServer.chm Bentley i-model Composition Server Administrator (an option of the Bentley i-model Composition Server for PDF installer)
  • using Bentley i-model Composition Server for PDF
  • using Bentley i-model Composition Server Administrator
  • configuring Bentley i-model Composition Server for PDF jobs
PWClassEditor.chm

ProjectWise Class Editor (an option of the ProjectWise Administrator installer)

  • using ProjectWise Class Editor
OFAdministrator.chm

Bentley i-model Composition Server Administrator, ProjectWise Orchestration Framework SDK

  • using ProjectWise Orchestration Framework Service
  • using Orchestration Framework Administrator

Help can be opened:

  • from inside the application (Help > Contents)
  • from the Start page on Windows 8 / Windows Server 2012 or later operating systems (Start > Apps > Bentley > ProjectWise Help)
  • from the Start menu on Windows 7 / Windows Server 2008 (Start > All Programs > Bentley > ProjectWise <version> > Documentation > ProjectWise Help)
Note: In ProjectWise Explorer, selecting Help > Contents now opens the online help on docs.bentley.com. If there is no internet access, the delivered local help (CHM) will open instead.

ProjectWise SDK

ProjectWise Software Development Kit (SDK) is available as a separate download from the Software Fulfillment Center and can be found under " ProjectWise Design Integration ".

Support and Services

TechNotes, FAQs and additional product information can be found in the ProjectWise community on Bentley Communities: https://communities.bentley.com/products/projectwise

Log issues that you encounter with Bentley products using the Service Request Manager: http://apps.bentley.com/srmanager/MySRs