OpenSite Designer

Scalable Terrain Model Manager dialog

Used to handle all operations relating to the STM objects. The STM Manager attaches and detaches STM files as well as creating and managing those files. Additional operations include display features and coordinate system selection.



Opens when you select Scalable Terrain Model from the MicroStation File menu, or from the Raster Manager Utilities menu.

KEY-IN: STMMANAGERDLG DIALOG OPEN
KEY-IN: STMMANAGERDLG DIALOG CLOSE
KEY-IN: STMMANAGERDLG DIALOG TOGGLE
SettingDescription
File > New

Opens the Create New dialog to create a new STM file.

KEY-IN: STM STMMANAGERDLG NEWSTM
File > Modify

Opens the STM Elevation Source Editor dialog to modify the STM file's parameters.

KEY-IN: STM STMMANAGERDLG MODIFYSTM
File > Attach

Opens the Attach File dialog, which allows you to attach a STM. <Ctrl+click> to attach multiple files simultaneously.

KEY-IN: STM STMMANAGERDLG ATTACH < FILENAME >
File > Detach

Detaches the STM file.

KEY-IN: STM STMMANAGERDLG DETACH
File > Save As

Opens the Create New dialog to save a copy of the STM file with a new name.

KEY-IN: STM STMMANAGERDLG SAVEAS
File > Export STM to TM

Use to export a STM to the MicroStation native Terrain model.

KEY-IN: STM STMMANAGERDLG EXPORTSTMTOTM
Edit > Check if up-to-date

The STM system keeps a record of the files used to create each STM. The Check if Up to Date tool can be used to determine if any of the files used to create the STM are newer than the STM itself. In that way, the user can decide if the STM should be regenerated to become current.

Use to verify if any changes were made to the source files.

KEY-IN: STM STMMANAGERDLG CHECKUPTODATE
Edit > Generate

Use to generate the STM.

KEY-IN: STM STMMANAGERDLG GENERATE
Edit > Extract a TM Element

Use to extract a native MicroStation terrain model TM from a selected area of the STM.

KEY-IN: STM STMMANAGERDLG EXTRACTDTM < BLOCK > < ORIBLOCK > < ELEMENT > < SHAPE > < VIEW > < FENCE >
Edit > Extract Raster Grid

Extracts a portion of the STM to a raster grid format.

KEY-IN: STM STMMANAGERDLG EXTRACTRASTERGRID
Edit > Extract Contours

Saves a selected area of the STM contours to DGN elements.

KEY-IN: STM STMMANAGERDLG VIEWSHEDANALYSIS
Edit > Viewshed

Use to open the Viewshed Analysis dialog.

KEY-IN: STM STMMANAGERDLG VIEWSHEDANALYSIS
Edit > Set Draping

Use to assign rasters to be draped the STM.

KEY-IN: STM STMMANAGERDLG SETDRAPING
Edit > Clip

Use to clip parts of the STM. The Clip tool settings allow you to choose the clip method and mode.

KEY-IN: STM STMMANAGERDLG CLIP < BLOCK > < ORIBLOCK > < ELEMENT > < SHAPE > < VIEW > < FENCE > < BOUNDARYMODE > < MASKMODE >
Edit > Unclip

Deletes a clip from a STM.

KEY-IN: STM STMMANAGERDLG UNCLIP
Edit > Modify Clip

Use to modify the clipping polygon for a clipped STM.

KEY-IN: STM STMMANAGERDLG MODIFYCLIP
Edit > Drape Element

Drapes linear elements on the terrain.

KEY-IN: STM STMMANAGERDLG DRAPELINE
View > Auto Arrange Icons

If on, icons in the dialog's tool bar wrap when the dialog is resized.

View > Show Hierarchy

When on, displays a tree that shows the active file and references that are directly attached to it. When the tree is turned off, you can use the arrow button next to the Show Hierarchy icon to list the active file and any references that are directly attached to it.

View > Flat Mode

When Flat Mode is on and an active design is selected in the Hierarchy pane, all references attached to the active design and its nested references are listed in the right pane. When Flat Mode is on and a referenced DGN is selected in the Hierarchy pane, all references attached to that DGN and its nested references are listed in the right pane.

Display > Fit to View

Fit the selected STM(s), or all STMs, to a view.

KEY-IN: STM STMMANAGERDLG FITTOVIEW
Display > Fit All to View

Fit all attached STMs to the selected view.

KEY-IN: STM STMMANAGERDLG FITALLTOVIEW
Utilities > GeoCS > Select

Use to select a GeoCS from the library.

KEY-IN: STM STMMANAGERDLG COORDSYS SELECT
Utilities > GeoCS > Delete

Use to delete a GeoCS.

KEY-IN: STM STMMANAGERDLG COORDSYS DELETE
Utilities > File Name

Use to select a new STM file.

KEY-IN: STM STMMANAGERDLG FILENAME
Show Reference Hierarchy


Same as selecting the the View > Show Hierarchy menu item.

Flat Mode


Same as selecting the View > Flat Mode menu item.

Attach

Same as selecting the File > Attach menu item.

Detach

Same as selecting the File > Detach menu item.

New

Same as selecting the File > New menu item.

Modify

Same as selecting the File > Modify menu item.

Check if Up-to-date


Same as selecting the Edit > Check if up-to-date menu item.

Generate


Same as selecting the Edit > Generate menu item.

Clip

Same as selecting the Edit > Clip menu item.

Modify Clip

Same as selecting the Edit > Modify Clip menu item.

Unclip

Same as selecting the Edit > Unclip menu item.

Set Draping

Same as selecting the Edit > Set Draping menu item.

Fit to View

Same as selecting the Display > Fit to View menu item.

File Name

Displays the file name. Double-clicking the file name opens the Element Information dialog.

Note: See the MicroStation documentation for information concerning the Element Information dialog.
Description

Displays a description of the STM.

Read-Only
Displays the read-only status of the STM. If on, the file is opened in a read-only mode and a check mark will appear in the Read-Only column.
Snap


If on, you can snap to elements in the STM. A check mark in the column indicates that Snap is on.

Locate


If on, you can select elements in a STM for construction purposes. A check mark in the column indicates that Locate is on.

Clip
Allows you to turn on or off the Clip functionality.
Display Draped Rasters

If on, draped rasters will be displayed. A check mark in the column indicates that Display Draped Rasters is on.

View buttons

Numbered push buttons let you define in which view(s) to display the point cloud(s).

Read-Only

Allows you to turn on or off the Read-Only functionality. If the icon is pressed, the setting is on.

Snap


Allows you to turn on or off the Snap functionality. If the icon is pressed, the setting is on.

Locate


Allows you to turn on or off the Locate functionality. If the icon is pressed, the setting is on.

Clip

Allows you to turn on or off the Clip functionality. If the icon is pressed, the setting is on.

Display Triangles

Allows you to turn on or off the Display Triangles functionality. If the icon is pressed, the setting is on.

KEY-IN: STM STMMANAGERDLG DISPLAY TRIANGLES
Display Contours

Allows you to turn on or off the Display Contours functionality. If the icon is pressed, the setting is on.

KEY-IN: STM STMMANAGERDLG DISPLAY CONTOURS
Display Draped Rasters

Allows you to turn on or off the Display Draped Rasters functionality. If the icon is pressed, the setting is on.

KEY-IN: STM STMMANAGERDLG DISPLAY DRAPING

Right-Click Menu

A right-click menu offers options for the following operations related to the STM.

  • Set Draping — Use to select the raster attachment for draping.
  • Check if up-to-date — Use to verify if the STM is up-to-date.
  • Generate — Use to generate a STM.
  • Save As — Use to create a new STM
  • Export STM to TM — Use to export a STM to the MicroStation native Terrain model.
  • Fit to View — Use to fit the STM to the current view.
  • Clip — Use to clip parts of the STM.
  • Unclip — Use to unclip the STM.
  • Modify Clip — Use to modify the clip polygon.