OpenSite Designer

Create Template

Creates, edits, manages, and previews roadway templates.

You can access this tool from the following:

  • Ribbon: Corridors > Create > Template split button

Use this dialog to create, edit, manage, and preview roadway templates. For more details on working with templates, see the Create Template Overview topic.

Template Library

shows the tree view that lists all available templates in the active template library (*.itl). This view also includes additional template-level commands such as: set active, cut, copy, paste, rename, Template Documentation Link and Display. To access these commands, right click on a template in the view. The view also displays the default point name list, which allows you to add or modify names and styles of points in the template. To edit the point name list, right click or double click on the Point Name List item in the tree view. For more details on this option, see the Point Name List topic.

Template Library (Tabs)

allows you to select between the standard template library tree view and the active template tree view.

Library

displays the standard template library tree view.

Active Template

displays the tree view for the active template. This view also lists the properties of a selected (active/highlighted) component, point, or display rule in the template. You can access (double click) and edit the properties of objects, or delete objects from the list view.

When you select the Points folder, a list of all points is displayed below the folder/tree view. Multiple points can be selected using shift and control key functions. A right-click menu is available to edit or delete the points, change style and display status, and set the Feature Name Override.

Drag a component on top of another component to make it a child of that component, or drag it on to the Component folder to remove its parent.

File Menu

New

New > Folder

Creates a new folder in the library at the current position of the template library.

New > Template

Creates a new template at the current position of the template library.

New > Template Library

Allows you to create a new template library and open that library.

Open

displays the Open dialog.

Save

saves the current template library.

Save As

allows you to save the template library with a different name. On the Save As dialog, the Options button allows you to select the units in which the file is saved.

Import Template

allows you to import a template from graphics previously identified in a selection set. For more details, see the Import Template from Graphics topic.

Close

closes the Create Template dialog. If the template library has been modified, you're prompted to save before exiting.

Edit Menu

All these commands apply to the active or currently selected template or folder.

Undo

undoes the last edit of the current template.

Redo

redoes the last Undo

Cut

deletes the selected template or folder from the template library and places it in the paste buffer.

Copy

copies the selected template or folder to the paste buffer.

Paste

pastes whatever is in the paste buffer to the current location in the template library

Delete

deletes the selected template or folder from the template library.

Rename

allows you to rename the selected template or folder.

Clear

erases all the points and components from the current template.

Add Menu

Simple

adds a special component type to the current template. For more details simple components, see the Create Template Overview topic.

Constrained

adds a component where all but the first point are fully constrained to the previous point. For more details on constrained components, see the Create Template Overview topic.

Unconstrained

adds a component with all free points. For more details on unconstrained components, see the Create Template Overview topic.

Null Point

adds a null point not related to any particular component. For more details on null points, see the Create Template Overview topic.

End Condition

adds an end condition to the current template. Points that are on End Condition components have these additional properties:

  • Check For Interception - If this is turned on, then the preceding segment will be checked for interception of the target when the end-conditions are solved. If it is turned off, then the segment will be ignored when checking for interceptions.

  • Place Point at Interception - If this is turned on and an interception is found along the preceding line segment, the line segment will be drawn to the interception. Otherwise, if the interception is found, the line segment will be drawn to its maximum width.

  • End Condition is Infinite - This flag is only applicable to the last point on the end condition. If it is set, then the last segment will be considered to be of infinite length when attempting to intercept the target.

  • Do Not Construct - If this flag is turned on, then the point will be solved like all other points in the end-condition, but the point will be skipped when drawing the component segments.

Current Component Name

allows you to review/edit the name of the current component. Applicable only while adding a component.

Current Component Feature Style

allows you to review/edit the style of the current component. Applicable only while adding a component.

Current Component Additional Fields

When placing a Simple component or placing an End Condition component, additional fields are displayed in the Current Component area. See the sections on Adding a Simple component and Adding an End Condition component for more details.

Overlay/Stripping

adds an overlay/stripping component to the current template. An overlay/stripping component is placed the same way as other components, by defining the component by selecting/creating points.

In the case of a stripping component, the points of the component define the top of the component only. The component is then drawn according to the top and bottom options.

The process calculates values for the top and bottom of the component by looking at all surface points in between the start and end component points, as well as all the component points and all intersections where the component segments and surface cross.

For more details about adding an overlay/stripping component, refer to Add New Overlay/Stripping Component.

Tools Menu

Template Library Organizer

displays the Template Library Organizer dialog.

Apply Feature Name Override

displays the Apply Feature Name Override dialog.

Apply Component Name Override

displays the Apply Component Name Override dialog.

Options

displays the Template Options dialog which allows you to specify naming and step options for the current template. Use the Dynamic dialog to toggle these settings on/off.

Dynamic Settings

displays the Dynamic Settings dialog which allows you to specify precision input.

Template Library Report (itl File)

displays the Bentley Civil Report Browser, which allows you to view the available template library reports.

Current Template

Name

shows the name of the current template.

Description

allows you to review/edit the current template description.

Display

Components/Constraints

determines the display mode of the template. If the display components field is set, then the components is displayed. If the display constraints field is set, then the point constraints is displayed. Points are always displayed.

Display Point Names

specifies point names are displayed (in white), when this option is checked. If the point has a Feature Name Override (applied on the Point Properties dialog), it is displayed in red.

Display All Components

specifies all components that are hidden because of their display rules are displayed with dashed lines, when this option is checked. For more specific details on defining display rules, see the Display Rule help topic.

Template Preview Window

shows a preview of the template highlighted in the library explorer. The light blue box indicates the drag point of the template. You can change the drag point by left-clicking over the desired drag point in the preview window. You can also drag the template directly from the preview window onto the current template.

Test

displays the Test End Conditions dialog.

Mirror/Reflect

shows the status of the Mirror and Reflect settings. The label is black if the setting is on. The label is grayed out if the setting is off.