OpenRoads Designer CONNECT Edition SDK Help

ExtendOrTrimBeginByPointByVerticalProjection(DPoint3d, Double) Method

Extend or trim a parabola by its start point to the vertical projected point of a given point.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearElement ExtendOrTrimBeginByPointByVerticalProjection( DPoint3d extPoint,double ptToPtTolerance)

Parameters

SettingDescription
  DPoint3d The point that the element will extend to
   Tolerance used to perform the operation.

Return Value

LinearElement Extended or trimmed element

See Also