OpenRoads Designer CONNECT Edition SDK Help

CreateByStartPointEndPointThruPoint Method

Constructs a circular arc element

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc CreateByStartPointEndPointThruPoint( DPoint3d startPoint, DPoint3d endPoint, DPoint3d thruPoint)

Parameters

SettingDescription
  DPoint3d Start point of the arc
  DPoint3d End point of the arc
  DPoint3d Thru point of the arc

Return Value

CircularArc A circular arc element

See Also