OpenRoads Designer CONNECT Edition SDK Help

CreateByCenterStartPointEndPointRotationDirection(DPoint3d, DPoint3d, DPoint3d, Hand) Method

Constructs a circular arc element

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc CreateByCenterStartPointEndPointRotationDirection( DPoint3d center, DPoint3d startPoint, DPoint3d endPoint, Hand hand)

Parameters

SettingDescription
  DPoint3d Center of the circle
  DPoint3d Start point of the arc
  DPoint3d End point of the arc
  Hand Hand of the circle

Return Value

CircularArc A circular arc element

See Also