OpenRoads Designer CONNECT Edition SDK Help

ComparisonHelpers Class

Class that contains a set of utilities for Model.Surface classes

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public class ComparisonHelpers
Inheritance → ComparisonHelpers

Constructors

ComparisonHelpers Initializes a new instance of the ComparisonHelpers class

Methods

DirectionNearEqual(Double, Double) Determine if 2 directions are equal wihtin the tolerances
DirectionNearEqual(Double, Double, Double)  
DistancesNearEqual determine of 2 distances are equal within a tolerance
GetDistanceTolerance Gets the distance tolerance
NormalizedDirectionsNearEqual Determine if 2 normalized directions are equal wihtin the tolerances
PointsNearEqual determine of 2 points are equal within a tolerance
SlopesNearEqual(Double, Double) Determine if 2 slope are equal wihtin the tolerances
SlopesNearEqual(Double, Double, Double)  
StationsNearEqual Determine if 2 stations are equal wihtin the tolerances

See Also