OpenRoads Designer CONNECT Edition SDK Help

CreateByStartPointEndPointStartDirectionRotationDirection(DPoint3d, DPoint3d, Double, Hand, Double) Method

Constructs a circular arc element

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc CreateByStartPointEndPointStartDirectionRotationDirection( DPoint3d startPoint, DPoint3d endPoint,double startDirection, Hand hand,double tol)

Parameters

SettingDescription
  DPoint3d Start point of the arc
  DPoint3d End point of the arc
   Start direction of the arc
  Hand  
   tol for arc creation

Return Value

CircularArc A circular arc element

See Also