OpenRoads Designer CONNECT Edition SDK Help

ProjectPointOnPerpendicularAll(DPoint3d, Double) Method

Projects a point onto an element perpendicularly. Gets all the projections.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPointCollection ProjectPointOnPerpendicularAll( DPoint3d point,double ptToPtTolerance)

Parameters

SettingDescription
  DPoint3d Point to drop perpendicular
   Tolerance used to calculate the point.

Return Value

LinearPointCollection All the Points projected on element

Remarks

To obtain the point to point tolerance that is passed as parameter calculation will be performed with a precision equal to ptToPtTolerance/100

See Also