OpenRoads Designer CONNECT Edition SDK Help

GeometricModel Class

Definition

Namespace: Bentley.CifNET.GeometryModel.SDK Assembly: Bentley.CifNET.GeometryModel.SDK.4.0 (in Bentley.CifNET.GeometryModel.SDK.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public abstractclass GeometricModel : ModelEntity
Inheritance → ConsensusItem → ModelEntity → GeometricModel

Constructors

GeometricModel Initializes a new instance of the GeometricModel class

Properties

ActiveSurface  
Alignments  
AllImportedEntities  
AnnotationDefinitions  
AnnotationGroups  
Cants  
CivilCells  
ConicSlopes  
Corridors  
CorridorSurfaces  
FeatureDefinitions  
FlowModelComponents  
LinearEntities3d  
NamedAlignments  
PointEntities2d  
ScalableMeshSurfaces  
SightVisibilitySections  
SuperElevationSections  
TerrainSurfaces  

Methods

_CreateAlignmentByAlignments  
_CreateAlignmentByCurveVector  
_CreateAlignmentByLinearElement  
_CreateAlignmentByLinearElements  
_CreateByPIs  
_CreateCivilCellElement(CivilCellInfo, IEnumerable(Alignment))  
_CreateCivilCellElement(CivilCellInfo, IEnumerable(KeyValuePair(Alignment, Boolean)))  
_CreateCivilCellElement(CivilCellInfo, IEnumerable(KeyValuePair(Alignment, Boolean)), IEnumerable(Alignment), IEnumerable(Corridor))  
_CreateCorridorSurface  
_CreateLinearEntity2dInSection  
_CreateLinearEntity3dByLinearElement  
_CreatePointEntity2dByDPoint3d  
_CreatePointEntity2dInPlanByDPoint3d  
_CreateProfileByProfileElement  
_CreateSingleSuperElevationSection  
_CreateSuperElevation  
_CreateSuperElevationSection  
_CreateSuperElevationSections  
_CreateSuperElevationTransition  
_CreateTerrainSurface  
CreateAlignmentByAlignments  
CreateAlignmentByCurveVector  
CreateAlignmentByLinearElement  
CreateAlignmentByLinearElements  
CreateByPIs  
CreateCivilCellElement(CivilCellInfo, IEnumerable(Alignment))  
CreateCivilCellElement(CivilCellInfo, IEnumerable(KeyValuePair(Alignment, Boolean)))  
CreateCivilCellElement(CivilCellInfo, IEnumerable(KeyValuePair(Alignment, Boolean)), IEnumerable(Alignment), IEnumerable(Corridor))  
CreateCorridorSurface  
CreateLinearEntity2dInSection  
CreateLinearEntity3dByLinearElement  
CreatePointEntity2dByDPoint3d  
CreatePointEntity2dInPlanByDPoint3d  
CreateProfileByProfileElement  
CreateSingleSuperElevationSection  
CreateSuperElevation  
CreateSuperElevationSection  
CreateSuperElevationSections  
CreateSuperElevationTransition  
CreateTerrainSurface  
GetAlignmentByName  
GetAnnotationDefinitionByName  
GetNativeP  
GetPlanModelFromDgnModel  

Fields


See Also