OpenRoads Designer CONNECT Edition SDK Help

CreateByStartPointRadiusStartDirectionSweepAngleRotationDirection Method

Constructs a circular arc element

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc CreateByStartPointRadiusStartDirectionSweepAngleRotationDirection( DPoint3d startPoint,double radius,double startDirection,double sweepAngle, Hand hand)

Parameters

SettingDescription
  DPoint3d Start point of the circle
   Radius of the circle
   Start direction of the arc
   Sweep angle of the arc
  Hand Hand of the circle

Return Value

CircularArc A circular arc element

See Also