OpenRoads Designer CONNECT Edition SDK Help

ProfileCircularArc(DPoint3d, DPoint3d, Double, Double) Constructor

Initializes a new instance of the ProfileCircularArc class

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public ProfileCircularArc( DPoint3d startPoint, DPoint3d endPoint,double radius,double sweepAngle)

Parameters

SettingDescription
  DPoint3d Start point of the arc
  DPoint3d End point of the arc
   Radius of the circle
   Sweep angle of the arc

Return Value

A profile circular arc element

See Also