OpenRoads Designer CONNECT Edition SDK Help

CircularArc(DPoint3d, Double, Double, Double, Double) Constructor

Initializes a new instance of the CircularArc class

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public CircularArc( DPoint3d center,double degreeOfCurv,double chordRefLength,double startDirection,double sweepAngle)

Parameters

SettingDescription
  DPoint3d Center of the circle
   degreeOfCurv of the circle
   chordRefLength of the circle
   Start direction of the arc
   Sweep angle of the arc

See Also