OpenRoads Designer CONNECT Edition SDK Help

CreateTangentToTwoCirclesThruPoint Method

Creates Tangent Line when given Spiral, Thrupoint, and Radius

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc[]CreateTangentToTwoCirclesThruPoint( CircularArc backElement, CircularArc aheadElement, DPoint3d thruPoint,double tolerance)

Parameters

SettingDescription
  CircularArc First circle used as reference
  CircularArc Second second used as reference
  DPoint3d Thru point of the arc
   tolerance of the mathematics

Return Value

CircularArc[]

See Also