OpenRoads Designer CONNECT Edition SDK Help

CreateParabolaByEndPtsAndRadius Method

Constructs a profile parabola giving the end points and the radius.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileParabola CreateParabolaByEndPtsAndRadius( DPoint3d startPoint, DPoint3d endPoint,double radius)

Parameters

SettingDescription
  DPoint3d Start point of the parabola
  DPoint3d End point of the parabola
   The radius of the parabola

Return Value

ProfileParabola The profile parabola element

See Also