OpenRoads Designer CONNECT Edition SDK Help

StrokeByDistances(Double[], LinearPointCollection) Method

Strokes the linear element by distance.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPointCollection StrokeByDistances(double[] distances, LinearPointCollection linearPoints)

Parameters

SettingDescription
  [] Array of distances along the element
  LinearPointCollection Initial linear point collection.

Return Value

LinearPointCollection Collection of stroked points.

Remarks

The points are added to the initial point collection. This method allows creating a collection of points along a curve with different criteria and apply them consecutively. The order in which the stroking is applied determines the priority of one of the criteria.

See Also