OpenRoads Designer CONNECT Edition SDK Help

CircularArc(DPoint3d, Double, Double, Double, Boolean) Constructor

Initializes a new instance of the CircularArc class

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public CircularArc( DPoint3d center,double radius,double startDirection,double sweepAngle,bool isChordDefined)

Parameters

SettingDescription
  DPoint3d Center of the circle
   Radius of the circle
   Start direction of the arc
   Sweep angle of the arc
   flag indicating a chord defined arc

See Also