OpenRoads Designer CONNECT Edition SDK Help

PointControl Class

Definition

Namespace: Bentley.CifNET.GeometryModel.SDK Assembly: Bentley.CifNET.GeometryModel.SDK.4.0 (in Bentley.CifNET.GeometryModel.SDK.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public abstractclass PointControl : NamedModelEntity
Inheritance → ConsensusItem → ModelEntityNamedModelEntity → PointControl

Constructors

PointControl Initializes a new instance of the PointControl class

Properties

CenterCantName  
ChangedToDisabled  
ControlType  
Description  
Elevation  
Enabled  
FeatureDefinitionRange  
Grade  
HorizontalStartOffset  
HorizontalStopOffset  
LeftCantName  
Mode  
PlanAlignment  
PointName  
Priority  
ProfileEntity  
RightCantName  
SuperelevationReferencePoint  
UseAsSecondaryAlignment  
VerticalStartOffset  
VerticalStopOffset  

Methods

_SetDistanceDefine  
CreateFromElement  
GetNativeP  
SetDistanceDefine  

Fields


See Also