OpenRoads Designer CONNECT Edition SDK Help

CreateByStartPointEndPointRadiusSweepAngle Method

Constructs a circular arc element

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc CreateByStartPointEndPointRadiusSweepAngle( DPoint3d startPoint, DPoint3d endPoint,double radius,double sweepAngle)

Parameters

SettingDescription
  DPoint3d Start point of the arc
  DPoint3d End point of the arc
   Radius of the circle
   Sweep angle of the arc

Return Value

CircularArc A circular arc element

See Also