OpenRoads Designer CONNECT Edition SDK Help

CreateTangentParabolaTwoElementsByLength Method

Constructs Vertical parabola tangent to two elements and projected length.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileParabola CreateTangentParabolaTwoElementsByLength( ProfileElement elmt1, ProfileElement elmt2,double projectLength, BulgeOrientation bulge)

Parameters

SettingDescription
  ProfileElement Element parabola is tangent to
  ProfileElement Element parabola is tangent to
   Projected length
  BulgeOrientation Bulge orientation

Return Value

ProfileParabola Solution (if exist)

See Also