OpenRoads Designer CONNECT Edition SDK Help

CreateTangentToSpiralTwoThruPoints Method

Creates Tangent Line when given Spiral, Thrupoint, and Radius

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  CircularArc[]CreateTangentToSpiralTwoThruPoints( Spiral backSpiral, DPoint3d thruPoint, DPoint3d endPoint,double tolerance)

Parameters

SettingDescription
  Spiral Spiral used as reference
  DPoint3d Thru point of the arc
  DPoint3d End point of the arc
   tolerance of the mathematics

Return Value

CircularArc[]

See Also