OpenRoads Designer CONNECT Edition SDK Help

ProjectPointOnSkew(DPoint3d, Double, Double) Method

Projects a point onto an element with a skewed angle. Gets the closest projection only.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPoint ProjectPointOnSkew( DPoint3d point,double skewAngle,double offset)

Parameters

SettingDescription
  DPoint3d Point to project.
   Angle to project at.
    

Return Value

LinearPoint Point projected onto element.

See Also