OpenRoads Designer CONNECT Edition SDK Help

CalculateIntrinsicPoint Method

Computes intrinsinc point of the clothoid

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  DPoint3d CalculateIntrinsicPoint(int  spiralType, DPoint3d startPoint,int  clothType,double parameter,double startAbsc,double direction)

Parameters

SettingDescription
   Type of spiral
  DPoint3d Start point of the clothoid
   Type of clothoid
   Parameter
   Start abscissa
   Direction

Return Value

DPoint3d Intrinsic point

See Also