OpenRoads Designer CONNECT Edition SDK Help

ComplexComponentInfo Class

Holds information about a complex component

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public class ComplexComponentInfo : IDisposable
Inheritance → ComplexComponentInfo
Implements

Properties

Geometry Gets the geomtry of the component.
Index Gets the index of the component.
IsReversed Gets whether the component is reversed.

Methods

Dispose() Releases all resources used by the ComplexComponentInfo
Dispose(Boolean) Releases the unmanaged resources used by the ComplexComponentInfo and optionally releases the managed resources
Finalize (Overrides )

See Also