OpenRoads Designer CONNECT Edition SDK Help

GeometricType Enumeration

Indicates geometric type of linear or profile element

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public enum GeometricType

Members

Undefined 1  
LinearSpriral 2  
LinearClothoid 3  
LinearCircularArc 4  
LinearLine 5  
LinearLineString 6  
LinearClosedLineSttring 7  
ProfileParabola 8  
ProfileLine 9  
ProfileLineString 10  
LinearComplex 11  
ClosedLinearComplex 12  
ProfileComplex 13  
LinearLineString3d 14  
LinearLine3d 15  
CompoundElment 16  

See Also