OpenRail Designer CONNECT Edition

Version Checker

Version Checker is a GUI alternative to the command line version of version checker for upgrades.

Prerequisite: SS4 project.

A SS3 project needs upgrading to SS4 first.

Version Checker dialog

Setting

Description

File > Open

Opens a DGN or folder.

File > Open > File

Opens a DGN.

File > Open > Folder

Browse For Folder box displays to locate a folder.

Clicking on the top level folder lists each DGN in the folder on the Schema Details tab.

Expanding the folder lists the DGN along with the logo of currently aligned product.

Clicking on one DGN lists the details of the schema on the Schema Details tab.

A "question mark" as a logo indicates the version checker cannot find the schema and association.

Output tab

Displays notifications if the version checker cannot find a schema in one or more DGNs in the selected folder.

View > Clear Output

Clears the output tab of data.

Align, upgrade, and view the contents of the file.

Setting

Description

View File Summary

Contents

Contents is a dump to screen.

Select File > Save Output.

Align

Aligns a single file with product.

View > Upgrade List

Sorts files together for upgrade.

Upgrade all or as an individual group. Groups are determined by files with interdependencies.

File > Open > For Schema Deletion

Select DGN. Details display in Schema Details tab.

Setting

Description

Action > Delete Schema Content

Warning displays to verify the action.

Selecting Yes will remove all civil data and leave only the graphics.

View > Schema Details

Schema Details tab

Message indicates the DGN cleaned of all civil data.

Setting

Description

Help > About

Specifies the version of the version checker and context.

Workflow

  1. Select VersionChecker.exe located where the product is installed. Example, \Program Files\Bentley\OpenRoads Designer CONNECT Edition\OpenRoadsDesigner.
  2. Click on File > Open > Folder and browse to locate the desired folder. Example, \Program Files\Bentley\OpenRoads Designer CONNECT Edition\OpenRoadsDesigner.
  3. Select OK and the list side gives an overview of folder contents. The tree side displays logo of product currently aligned.
  4. Select Action >Align All.

    The Output tab displays the status.*.bak is created when product alignment completes.

  5. Select 1 or more files to upgrade.
  6. Select Action > Upgrade All.

    The Output tab displays the status.

  7. Select View > Contents.
  8. Select View > Upgrade List.

    The Upgrade Group plus numeric character displays.

  9. Select View >Schema Details to review details.
  10. Select View > Clear Output.