To Sign Multiple Files via Batch Command
-
Select
File > Tools > Batch Process
.
The Batch Process dialog opens.
-
Click the Create a new command file icon.
The Create Command File dialog opens.
- Enter the name of the Batch Process Command file you want to create.
-
Navigate to the path where you want the Batch Process Command file to reside and press OK.
Notepad opens your Batch Process Command file.
-
Enter the following key-in: SIGNATURE ADD FILESIGNATURE ?certificate common name? and save the file.
The ?certificate common name? is the name associated with the digital signature to be used for the signings.
-
Do one of the following:
- From the Batch Process dialog Edit menu, select Add Files?
- Click the Add Files or Directories to Process icon.
The Select Files and Directories to process dialog opens.
-
Do one of the following:
- Select the file or files to be included in the batch and click the Add button.
- Double-click on each file to be included in the batch.
The selected files appear in the Selected Files dialog section.
-
Click the Done button.
The selected files appear in the Process Tasks dialog section of the Batch Process dialog.
-
Do one of the following:
- From the Batch Process dialog File menu, select Process?
- Click the Process Batch Process icon.
The Files to Process dialog opens.
-
Click the Process button.
All of the selected files are signed via the batch process.
Note: You can remove file signatures via the same batch process as described above by simply using the SIGNATURE REMOVE FILESIGNATURE ?signer? key-in where ?signer? is what displays in the Signer column of the Digital Signatures dialog.