OpenCities Map Readme

Installation and Requirements

Installation Requirements:

A CD drive or access to the Internet is required for product installation. The minimum system configuration for installation is:

Supported Operating Systems

  • Windows 10 (64-bit) - Home, Pro, Enterprise, and Education
  • Windows 8.1 (64-bit) - Standard, Pro, and Enterprise
  • Windows Server 2019 (64bit)
  • Windows Server 2016 (64bit)
  • Windows Server 2012 (64bit)

Note: You must have the following Microsoft updates installed on your machine:
  • KB2999226 - For Windows 8.1 and Windows Server 2012
  • KB2919355 - For Windows 8.1 and Windows Server 2012

Bentley does not support its software running on Microsoft operating systems versions that Microsoft has "retired". For more information on Microsoft's application retirement policy, click here. For similar information on Bentley products, refer to the Bentley Product Support article.

Internet

Internet connectivity is required to install the product. Installer will attempt to automatically detect your computer's proxy settings from the Internet Explorer. If required, the installer will show a dialog for entering user name and password. In the absence of an internet connection, you can create a Deployment Image of the product and install it.

Communications Protocols

  • Internet Protocol version 4 (IPv4)
  • Internet Protocol version 6 (IPv6)

Virtualized Environments

Citrix XenApp 7.13 64-bit on Windows Server 2012 R2

Software Prerequisites

The Prerequisites for Bentley Desktop Applications are automatically downloaded and installed to your workstation while you install OpenCities Map. The contents of the Prerequisites for Bentley Desktop Applications include:

  • Microsoft .NET Framework 4.6.2
  • Microsoft Visual Basic for Applications core
  • Microsoft Visual Basic for Applications localized

Microsoft Internet Explorer, minimum v11.0, with 128-bit cipher strength. Microsoft no longer supports any versions prior to v11.0. Internet Explorer is not installed as part of the product prerequisites.

Copyrights in all components are owned by Microsoft Corporation or one of its affiliates, subsidiaries, or licensors.

Supported Databases

The database versions supported by OpenCities Map are subject to updating after the product release. You can refer to the MicroStation database support in Bentley Communities for the latest information.

The minimum recommended workstation profile for running OpenCities Map CONNECT Edition is:

Processor Intel® or AMD® processor 1.0GHz or greater. OpenCities Map is not supported on a CPU that does not support SSE2.
Memory 4 GB minimum, 16GB recommended. More memory almost always improves performance, particularly when working with larger models.
Hard Disk 12 GB minimum, 12-22 GB depending additional installations such as Companion Feature and Companion Product. 
Video See the graphics card manufacturer for latest information on DirectX drivers. 512 MB of video RAM or higher is recommended. If insufficient video RAM or no graphics card supported by Direct X can be found, OpenCities Map attempts to use software emulation. For optimal performance, graphics display color depth should be set to 24-bit or higher. When using a color depth setting of 16-bit, some inconsistencies will be noted. For more information on recommended workstation profiles for OpenCities Map, see MicroStation System Requirements and Hardware Recommendations.
Screen Resolution 1024 x 768 or higher.