MicroStation CONNECT Edition Help

アニメーションプロデューサダイアログ

アニメーション設定値を設定して、アニメーションを作成するために使用します。

このダイアログボックスには、次からアクセスすることができます。
  • リボン:「ビジュアリゼーション」 > 「アニメーション」 > 「スクリプト」 > 「アニメーションプロデューサ」
  • ツールボックス:アニメーション設定値


「アニメーションプロデューサダイアログ」の「メニューを表示」には、詳細なセクションで表示するための3つのオプションがあります。「タイムライン」ビューと「速度グラフ」ビューを使用すると、アニメーションの設定とスクリプトエントリに簡単にアクセスし、グラフィカルインターフェイスを使用して変更できます。「タイムライン」ビューが表示されると、スクリプトエントリが図示されます。エントリをタイムラインにドラッグすることで、図を直接編集できます。「速度グラフ」ビューが表示されているときは、グラフィカルインターフェイスを使用して速度曲線を簡単に編集できます。どちらのユーティリティも、何らかの変更があればスクリプトエントリに反映されます。同様に、スクリプトエントリの変更も、「タイムライン」ビューと「速度グラフ」ビューに反映されます。

キー入力: DIALOG ANIMATOR
設定説明
アニメーション機能のツリーのビュー 「ストーリーボードパネル」に対するフィルタとして機能します。最上位のエントリ(ルート)を選択すると、「ストーリーボードパネル」のすべての項目が表示されます。ルートの下位のエントリ(子ノード)を選択すると、「ストーリーボードパネル」はフィルタされ、選択した子ノードに関連するスクリプトエントリのみが表示されます。

「アニメーション」一覧は、次の項目から構成されます。

  • 最初の項目(ルート) - 現在のアニメーションモデルの名前。
  • ビュー - 個々のカメラと保存ビューの一覧。
  • アクター - すべてのアクターの一覧(スクリプトおよび非スクリプトを含む)。アクターをドラッグして、階層構造を作成したり分解したりできます。
  • キーフレーム - すべてのキーフレームの一覧(スクリプトおよび非スクリプトを含む)。
  • 光源 - グローバルおよびソースの光源に関するエントリ。それぞれに、各光源とそのアニメーション設定値を表す子ノードがあります。
  • 材質 - デザインで使用されるすべての材質の一覧。設定値は子ノードで表示されます。
  • 設定値 - 全般的なアニメーション設定値。
「ストーリーボードパネル」リストボックス 「アニメーション」リストボックスの選択とフィルタ行に基づいてフィルタされた項目を表示する、展開/折りたたみ可能なセクションです。「ストーリーボードパネル」というタイトルの左側にある「ストーリーボードを表示/非表示」アイコンを使用して、リストボックスを展開したり、折りたたんだりできます。リストボックスの列は、必要に応じて、サイズを変更したり、表示または非表示にできます。列の表示/非表示を切り替えるには、列のタイトルバーを右クリックし、目的の列のチェックボックスをオンまたはオフにします。

次の列を表示できます。

  • タイプ - スクリプトエントリ(パス、キーフレーム、または方向)のタイプ。エントリをダブルクリックして編集することができます。
  • 名前 - エントリの名前。クリックして編集することができます。また、メニューを右クリックして、選択内容の切り取り、コピー、貼り付け、削除、クリアを実行できます。
  • 時間 - キーフレームの特定の時間、またはパスの開始/終了時間。エントリをクリックして編集できます。
  • 値 - 被写体をアクティブまたは非アクティブにする、ソースの光源セルの設定を変更するなどスクリプト化されているさまざまな設定値を変更できるオプションメニュー。
  • オン - 選択したエントリを有効または無効にするためのチェックボックス。
  • 注記 - フィールドをクリックすると表示される、各エントリの注記(オプション)。
「ファイル」 > 「新規スクリプト」 「新規スクリプト」ダイアログボックスが開きます。このダイアログボックスは、アクティブなDGNファイルに新しいアニメーションスクリプトを作成するために使用します。
「ファイル」 > 「スクリプトを開く」 「スクリプトを開く」ダイアログボックスが開きます。このダイアログボックスは、アクティブなDGNファイルにあるアニメーションスクリプトを開くために使用します。
「ファイル」 > 「スクリプトを拡大/縮小」 スクリプトを拡大/縮小するための「スクリプトを拡大/縮小」ダイアログボックスが開きます。各スクリプトエントリを編集しなくてもアニメーションの長さを増減できるので便利です。
「ファイル」 > 「スクリプトをコピー」 「スクリプトをコピー」ダイアログボックスが開きます。このダイアログボックスで、コピーするスクリプトの名前と注記を入力します。「OK」をクリックすると、新しくコピーされたスクリプトが開きます。
「ファイル」 > 「スクリプトを含める」 「スクリプトを含める」ダイアログボックスが開きます。このダイアログボックスで、アクティブなDGNファイルまたは参照ファイルにある別のスクリプトを取り込みます。
「ファイル」 > 「.MSAファイルをインポート」 前のバージョンのMicroStationからアニメーションスクリプトファイルをインポートするために使用します。現在のファイル名でアニメーションスクリプトが作成されます。
「ファイル」 > 「スクリプトを消去」 現在のスクリプトからすべての入力を消去します。警告ボックスが表示され、エントリを削除する前に警告が出されます。
「ファイル」 > 「スクリプトを削除」 「スクリプトを削除」ダイアログボックスが開きます。このダイアログボックスは、アクティブなDGNファイルからスクリプトを削除するために使用します。
「ファイル」 > 「スクリプトを記録」 「スクリプトを記録」ダイアログボックスが開きます。このダイアログボックスで、シェーディングモードやファイルフォーマットなどの設定値を調整してからアクティブなスクリプトを記録します。
「ファイル」 > 「記録したシーケンスを続行」 「ファイルを選択」ダイアログボックスが開きます。このダイアログボックスで、アニメータ設定値ファイル(.asf)を選択して以前に中断された記録を続行したり、複数のコンピュータを使用してアニメーションシーケンスをレンダリングしたりします。

中断されたシーケンスの続行中は、まだ存在していないフレームしか記録されません。

複数のシステムを使用してアニメーションをレンダリングするには、作成済みのアニメーションフレームの保存先となる共通(ネットワーク)ドライブに、それらのどのシステムからもアクセスできるようにする必要があります。複数のシステム上でアニメーションを開始し、「Continue Existing Sequence」をオンにすることで、レンダリングの所要時間が大幅に短縮されます。

「ファイル」 > 「トーンマッピングBIMGファイル」 「トーンマッピングアニメーションフレーム」ダイアログボックスが開きます。これは、トーンマッピングを適用し、必要な出力フォーマットのアニメーションフレームを作成するために使用します。

フレーム間のトーンマッピングの差によるアニメーションのちらつきを抑えるには、アニメーションが完成した時点で、シーケンス全体の平均輝度に基づいて、最適な値を決定します。平均化が完了したら、これらのBIMGファイルから24ビット色シーケンシャルフレーム画像が作成されます。元の設定値を調整すると、その情報はアニメーション設定値ファイル(.ASF)に保存され、フレームが表示されるフォルダに作成されます。

「ファイル」 > 「終了」 「アニメーションプロデューサ」ダイアログボックスが閉じます。
「設定値」 > 「全般」 「アニメーション設定値」ダイアログボックスが開きます。このダイアログボックスで、アニメーションシーケンスをプレビューするための設定値などのアニメーション設定値を調整します。
「ツール」 > 「プレビュー」 「アニメータプレビュー」ツールが起動します。このツールには、アニメーションシーケンスをプレビューしたり、キーフレームを作成またはスクリプト化するためのコントロールが含まれています。
「ツール」 > 「名前付きキーフレーム」 「アニメーションのキーフレーム」ダイアログボックスが開きます。このダイアログボックスで、キーフレームを作成、スクリプト化、削除します。また、幾何図形を、選択したキーフレームで所定の位置にフリーズすることもできます。
DIALOG ANIMATOR KEYFRAME
「ツール」 > 「パラメータ」 「アニメーションパラメータ」ダイアログボックスが開きます。このダイアログボックスで、アニメーションパラメータを作成、編集、および削除します。
DIALOG ANIMATOR PARAMETER
「ツール」 > 「保存ビュー」 「保存ビューをスクリプト」ダイアログボックスが開きます。このダイアログボックスで、保存済みのビューをスクリプト化します。
ANIMATOR SCRIPT VIEW
「ビュー」 > 「タイムライン」 「アニメーションプロデューサ」ダイアログボックスの詳細セクションに、タイムラインのグラフを表示します。
「表示」 > 「速度グラフ」 「アニメーションプロデューサ」ダイアログボックスの詳細セクションに、速度グラフを表示します。
「新規スクリプト」アイコン


「ファイル」 > 「新規スクリプト」を選択した場合と同じ機能が実行されます。
「スクリプトを開く」アイコン


「ファイル」 > 「スクリプトを開く」を選択した場合と同じ機能が実行されます。
「削除」アイコン


ハイライト表示されているアイテムを削除します。
「ハイライト」アイコン


有効の場合、選択したアクターが、表示されているビューでハイライト表示されます。
「ズーム」アイコン


有効の場合、選択したアクターがアクティブなビューでズームインされます。
「分離」アイコン


オンの場合、選択したアクターのみがアクティブなビューに表示されます。
右クリックメニュー ツリービューの項目を右クリックすると、選択した項目に使用できるオプションがコンテキストメニューに表示されます。次のオプションがあります。
  • 名前を変更 - エントリの名前を変更できます。
  • 削除 - エントリを削除します。
  • スクリプト - 関連するスクリプトダイアログボックスが開きます。既定では、現在の時間が開始時間として入力されます。このエントリは編集できます。