MicroStation CONNECT Edition Help

「名前付き式」ダイアログボックス

名前付き演算式を定義および管理するために使用します。

このダイアログボックスには、次からアクセスすることができます。
  • リボン:「作図」 > 「ユーティリティ」 > 「ユーティリティ」
  • リボン:「モデリング」 > 「ユーティリティ」 > 「ユーティリティ」
  • リボン:「管理」 > 「ホーム」 > 「環境」
  • 「カスタマイズ」ダイアログボックス:「ユーティリティ」 > 「名前付き演算式」


キー入力: MDL KEYIN EVALUATOR NAMEDEXPRESSION EDIT
ヒント: このダイアログボックスのテキストフィールドでは、ポップアップ(右クリック)メニューを使用できます。このトピックで説明している場合を除き、「元に戻す」「コピー」「すべてを選択」などのメニュー項目の効果は、通常の場合と同じです。
設定説明
一覧フィルタ(ドロップダウンメニュー) 下に一覧表示されている名前付き式をフィルタするためのアプリケーションキーワードを選択します。選択しないと、アクティブなファイルのすべての名前付き式が一覧表示されます。
新規 新しい名前付き式の一覧エントリを作成します。


コピー 選択した名前付き式をコピーして名前付き式を作成します。


削除 選択した名前付き式を削除します。


保存 選択した名前付き式を保存します。


再ロード クリックすると、選択された式のプロパティに行われた変更がすべて削除され、プロパティがファイルに保存されたものでリフレッシュされます。


リスト(ボックス) アクティブなファイル内にある名前付き式の一覧を表示します。以前定義された名前付き式を編集するには、まず名前付き式を選択します。変更内容が保存されていない名前付き式は、青で表示されます。

リストの上にあるドロップダウンメニューの選択に従って、リストはフィルタされます。

内部名 選択した名前付き式の名前を設定します。
外部名 選択した名前付き式の評価に適用されるテストの説明テキストラベルを設定します。この説明がユーザーインターフェイスに表示されます。
説明 選択された名前付き式の注記を設定します。注記は必須ではありません。
キーワード チェックボックスをオンにしたアプリケーションキーワードが、選択した名前付き式に適用可能です。たとえば、ユーザーインターフェイスを選択すると、名前付き式を使用して、カスタムタスク、ツール、メニュー項目を表示/非表示する場合や、メニュー項目をユーザーインターフェイスで有効/無効にする場合の条件を定義することができます。キーワードを追加または削除するには、「編集」 > 「キーワード」を選択します。キーワードの選択によって、隣接するリストボックスに表示される名前付き式をフィルタすることもできます。

次のキーワードは既定で定義されています。

  • 注釈
  • 要素
  • ファイル
  • マークアップ
  • モデル
  • 印刷セット
  • タスク
  • ツール
  • ユーザーインターフェイス
必要なシンボルセット(リストボックス) 選択した名前付き式の定義に必要なシンボルが含まれるシンボルセットを一覧表示します。
シンボルセットの選択(ドロップダウンメニュー) 選択した名前付き式に必要なシンボルセットのリストに追加するシンボルセットを選択します。
追加 選択した名前付き式に必要なシンボルセットのリストに上のドロップダウンメニューで選択したシンボルセットを追加します。
削除 選択した名前付き式に必要なシンボルセットのリストから上のドロップダウンメニューで選択したシンボルセットを削除します。
演算式 この複数行のフィールドで、選択した名前付き式を定義します。演算子、数字(整数または倍精度実数)、文字列を挿入するには、キー入力します。記号を入力するには、フィールドを右クリックして記号を選択します。ポップアップメニューには、必要な各シンボルセットの記号のサブメニューが表示されます。

「値」フィールドをクリアするには、右クリックして「クリア」を選択します。

テスト 選択した名前付き式をテスト用に評価します。テスト結果は、隣接するフィールドに表示されます。
「ファイル」>「XMLをインポート」 「名前付き式のインポート」ダイアログボックスを開きます。このダイアログボックスは、その他のファイルで定義され、XML形式にエクスポートされたアクティブなファイルの名前付き式をインポートするために使用します。
「ファイル」>「XMLをエクスポート」 「名前付き式のエクスポート」ダイアログボックスを開きます。このダイアログボックスは、アクティブなファイルの名前付き式を他のファイルにインポートするために、またはバックアップするために、XML形式にエクスポートするときに使用します。
「編集」>「キーワード」 「名前付き演算式のキーワード」ダイアログボックスが開きます。このダイアログボックスは、「キーワード」セクションでフィルタリング用キーワードの選択を管理するために使用します。
「ユーティリティ」>「演算式をレポート」 「使用可能な式のシンボルをレポート」ダイアログボックスを開きます。このダイアログボックスは、アクティブなファイルに定義されている名前付き式がドキュメント化されたHTMLドキュメントを保存するために使用します。
「ユーティリティ」>「シンボルをレポート」 Webブラウザを開いて、使用可能なシンボルセットの説明を表示します。