MicroStation CONNECT Edition Help

「ペンテーブルを修正」ダイアログボックス

ペンテーブルを定義または修正して、印刷出力の再記号化や要素の印刷順序の制御、および文字列の置換を実行します。

このダイアログボックスには、次からアクセスすることができます。
  • 「印刷」ダイアログボックス:「再記号化」 > 「ペンテーブルを編集」
  • 「印刷」ダイアログボックス:「ペンテーブルファイルを作成」ダイアログボックスで、「再記号化」 > 「新規ペンテーブル」を選択し、新しいペンテーブルの名前を入力して「OK」をクリック


設定説明
要素セクションの処理順 断面の処理の順序を定義する断面名の一覧を表示します。新規のペンテーブルを編集する場合は、「新規」と呼ばれる1つのセクションが挿入されます。「編集」メニューを使って、このセクションの名前を変更したり、複数のセクションを削除または挿入できます。
下へ リストボックスの一番下の名前を選択した場合を除き、「要素セクションの処理順」リストボックスで選択した名前をそのすぐ下の名前と入れ替えます。
上へ リストボックスの一番上の名前を選択した場合を除き、「要素セクションの処理順」リストボックスで選択した名前をそのすぐ上の名前と入れ替えます。
文字置換 「文字置換」ダイアログボックスを開きます。このダイアログボックスは、置換する文字列の組を生成するために使用します。それぞれの組は「実際」文字列および「置換」文字列で構成されます。


ペンの色を抽出 「ペンテーブル - デザイン色を出力ペン線属性にマップ」ダイアログボックスが開きます。このダイアログボックスは、構成要素の色に基づいて、複数の出力色と幅線属性を同じ要素の異なる部分に適用するために使用します。
ペンの線幅を抽出 「ペンテーブル - デザイン線幅を出力線幅にマップ」ダイアログボックスが開きます。このダイアログボックスは、32の各線幅値に印刷出力線幅を指定するために使用します。
ペンテーブルオプション 「ペンテーブルオプション」ダイアログボックスが開きます。このダイアログボックスは、グローバルなペンテーブルオプションを制御するために使用します。
「要素の選択基準」タブ 要素を評価するための、それぞれのセクションに固有の選択基準を指定するために使用するコントロールが含まれています。
「要素の出力条件」タブ 評価対象の要素がセクションの要素選択基準を満たしている場合は、「要素の出力条件」タブ上のコントロールを使って指定された動作が実行されます。
「ファイル」>「新規」 「ペンテーブルファイルを作成」ダイアログボックスが開きます。これは、新規(空の)ペンテーブルファイルに名前を付けるために使用される、標準の新規ファイルのためのダイアログボックスです。「ペンテーブルファイルを作成」ダイアログボックスで「保存」をクリックすると、「要素セクションの処理順」リストボックスに「新規」というエントリのみが表示されます。他のエントリがある場合、それらは削除されます。
「ファイル」>「開く」 「ペンテーブルファイルを選択」ダイアログボックスが開きます。これは、既存のペンテーブルファイルを開くために使用される、標準のファイルを開くためのダイアログボックスです。
「ファイル」>「保存」 アクティブなペンテーブルファイルを保存します。
「ファイル」>「名前を付けて保存」 「ペンテーブルファイルを作成」ダイアログボックスが開きます。これは、アクティブなペンテーブルファイルを新規のファイルに保存するために使用される、標準のファイルを保存するためのダイアログボックスです。
「ファイル」>「CTBファイルをエクスポート」 CTBファイルをエクスポートすることができます。詳細については「ペンマップ」を参照してください。
「ファイル」>「終了およびアンロード」 アクティブなペンテーブルファイルを含むペンテーブルアプリケーション全体をアンロードし、「ペンテーブルを修正」ダイアログボックスを閉じます(ペンテーブルアプリケーションをアンロードしないで「ペンテーブルを修正」ダイアログボックスを閉じるには、ダイアログボックスの「閉じる」ボタンをクリックします)。
「編集」>「上に新規セクションを挿入」 新規のセクションに名前を付けるのに使用される「セクションを挿入」ダイアログボックスが開きます。「OK」ボタンを押すと、「要素セクションの処理順」リストボックスでハイライト表示されたセクションの上に、新規セクション名が挿入されます。
「編集」>「下に新規セクションを挿入」 新規のセクションに名前を付けるのに使用される「セクションを挿入」ダイアログボックスが開きます。「OK」ボタンを押すと、「要素セクションの処理順」リストボックスでハイライト表示されたセクションの下に、新規セクション名が挿入されます。
「編集」>「セクションの名前を変更」 「セクションの名前を変更」ダイアログボックスが開きます。このダイアログボックスは、「要素セクションの処理順」リストボックスでハイライト表示されたセクションの名前を変更するために使用します。
「編集」>「セクションを削除」 「要素セクションの処理順」リストボックスでハイライト表示されたセクションを削除します。少なくとも1つのセクションは存在している必要があるので、セクションが1つのみの場合は削除されません。
「編集」>「タイプをクリア」 「要素の選択基準」コントロールの「タイプ」リストボックスで選択したすべての要素タイプの選択を解除します。
「編集」>「クラスをクリア」 「要素の選択基準」コントロールの「作図」リストボックスで選択したすべての作図要素の選択を解除します。
「編集」>「すべてのタイプを設定」 「要素の選択基準」コントロールの「タイプ」リストボックスに一覧表示されているすべての要素タイプを選択します。
「編集」>「すべてのクラスを設定」 「要素の選択基準」コントロールの「作図」リストボックスに一覧表示されているすべての作図要素を選択します。