MicroStation CONNECT Edition Help

「式による曲線」ダイアログボックス

数式に基づいて、想定可能なすべての曲線をB-スプラインまたは連続線分として配置するために使用します。

このダイアログボックスには、次からアクセスすることができます。
  • リボン:「作図」 > 「ホーム」 > 「配置」 > 「曲線を作成」分割ボタン
  • リボン:「モデリング」 > 「曲線」 > 「曲線ユーティリティ」
  • ツールボックス:曲線ユーティリティ


曲線の定義式は、曲線名の下のリストボックスに直接入力して編集することができます。数式の最後は、セミコロン";"で終わる必要があります。

ある配置ツールが選択されている場合、動的表示には、曲線を定義している変数と値の対になされたあらゆる変更が反映されます。

設定説明
名前 現在ロードされている曲線の名前を表示します。下のリストボックスには、表示されている曲線に関連付けられた式が表示されます。
リストボックス 選択された曲線に関連付けられた式を表示します。リストボックスで直接、この式を編集したり、新しい式を追加することができます。数式の最後は、セミコロン";"で終わる必要があります。
許容差 許容差を設定します。
CURVCALC DIALOG
ACTIVE TOLERANCE [ ]
モード 曲線の作成方法を設定します。
  • 式 - 曲線が、リストボックス内に定義された式から直接作成されます。
  • 式とルール曲線 - 曲線が、式とルール曲線から作成されます。
角度 角度の入力方法を設定します。
  • ラジアン - 値をラジアン単位で指定します。
  • 角度 - 値を度単位で指定します。
タイプ 作成される曲線のタイプを設定します。
  • B-スプライン - 曲線が、B-スプライン(NURB)要素として作成されます。
  • 連続線分 - 曲線が、連続線分要素として作成されます。
配置 曲線を構築して、モデルに配置可能なポインタにアタッチします。
「ファイル」 > 「ファイルを開く」 (リソースファイルを)「開く」ダイアログボックスが開きます。このダイアログボックスで、定義済みの曲線のライブラリを開きます。
CURVCALC DIALOG
MENU OPENFILE <filename>
注記: 既定では、MS_DATA構成変数によって指定されているディレクトリ内で、".rsc"ファイルを検索します。
「ファイル」 > 「曲線を追加」 「曲線リソースを開く」ダイアログボックスが開きます。このダイアログボックスでは、開いている曲線リソースファイルまたは新しい曲線リソースファイルと曲線から新しい曲線を選択することができます。
CURVCALC DIALOG
MENU OPENCURVE <CURVE NUMBER>
「ファイル」 > 「新規曲線」 新しい曲線定義を作成することができます。
CURVCALC DIALOG
MENU NEWCURVE
「ファイル」 > 「保存」 曲線ライブラリファイルを保存します。
MDL LOAD CURVCALC
MENU SAVE
「ファイル」 > 「名前を付けて保存」 「新しいリソースファイルに保存」ダイアログボックスが開きます。このダイアログボックスで、新しい曲線ライブラリファイルを作成します。
CURVCALC DIALOG
MENU SAVETO
「挿入」メニュー 曲線の式に挿入するために選択可能な定数と関数の選択肢を列挙します。次のオプションがあります。
  • 定数:pi、e
  • 関数sin、cos、tan、asin、acos、atan、atan2、sinh、cosh、tanh、asinh、exp、ldexp、log、log 10、pow、sqrt