MicroStation CONNECT Edition Help

「光源マネージャ」ダイアログボックス

光源の設定と、環境光と光源の両方の設定を制御するために使用します。各種オプションでは、光源セルを配置または削除したり、モデルの北の方向を定義したりできます。「照明の名称」一覧で光源をハイライト表示すると、その設定が表示され、必要に応じて編集できます。

このダイアログボックスには、次からアクセスすることができます。
  • リボン:「ビジュアリゼーション」 > 「ホーム」 > 「照明」ダイアログボックス起動ツール
  • リボン:「ビジュアリゼーション」 > 「ホーム」 > 「照明」 > 「管理」
  • 「Luxologyレンダリング」ダイアログボックス:「光源の設定」アイコン
  • ツールボックス:光源

一部の光源では、「詳細」、「太陽光の位置」(太陽光が選択されている場合のみ)、立体効果(太陽光、方向指示灯、点、スポットの光源のみ)、および「エキスパート」など、設定が異なるタブに提供されます。



太陽光、方向指示灯、スポット、エリアなどの一部の光源設定は、「光のプレビュー」で表示できます。このプレビューでは光の色をすばやく表示できるので、立体効果を調整する場合に特に便利です。「光のプレビュー」は、「光源マネージャ」ダイアログボックスの一番下に表示され、ダブルクリックすると拡大されます。

選択した光源の種類に応じて、異なる光のウィジェットを選択できます。これらの光のウィジェットは、Bentley_LightWidgets.dgnlibに保管されているモデルです。このファイルはMicroStationのプログラムディレクトリ内の ..\Default\Materials\ フォルダにあります。別のDGNLibファイルに光のプレビューウィジェットを追加することができます。DGNLibファイルの場所はMS_MATERIAL構成変数に追記します。このDGNLibファイルの名前には、「_LightWidget」を含める必要があります。各プレビューは、オブジェクトを識別する固有の接頭語、$$の区切り文字、光の種類を示す接尾語による名前で、保存ビューを作成する必要があります。接尾語は、solarlgt、directlgt、spotlgt、pointlgt、およびarealgtです。次に例を示します。Room$$directlgt、Lamp$$pointlgt、Window$$directlgt、Office$$arealgt

光のウィジェットを作成する場合、各モデルに「Preview」という名前の光源の設定が必要です。これは、この設定が「光のプレビュー」ウィジェットとして使用されることを示すためです。

設定説明
光源の設定一覧


光源の設定一覧の表示のオン/オフを切り替えます。光源の設定一覧では、保存されている光源の設定を選択できます。一覧が表示されていない場合は、下矢印をクリックして保存されている光源の設定から選択できるオプションメニューを開きます。
新規設定


新しい光源の設定を作成して「光源の設定」一覧に追加します。既定の名前は「タイトルなし-x」(xは数字の拡張子)です。この既定の名前は、必要に応じて編集できます。
設定をコピー


選択した光源の設定をコピーし、そのコピーを一覧に追加します。既定のコピー名は、元の設定名に数字が付加されたものです。
設定を削除


選択した光源の設定を削除します。
光源を配置 アイコン表示のオプションメニューで、光源セルを配置したり、既存の要素からエリア光源を作成したりできます。アイコンの既定は前回選択された光源タイプで、使用可能な他のオプションはオプションメニューに表示されます。
  • 点光源を配置 - 「光源を配置」ツールが、「点光源」が選択された状態で開きます。


  • スポット光を配置 - 「光源を配置」ツールが、「スポット光」が選択された状態で開きます。


  • エリア光源を配置 - 「光源を配置」ツールが、「エリア光源」が選択された状態で開きます。


  • 方向指示灯を配置 - 「光源を配置」ツールが、「方向指示灯」が選択された状態で開きます。


  • 天空光を配置 - 「光源を配置」ツールが、「天空光 - 屋内」が選択された状態で開きます。


太陽の軌道を編集


ビュー内の太陽の位置をグラフィカルに操作するために使用されます。このアイコンをクリックすると「太陽光の位置」タブが自動的に開き、設定を選択できます。
北を定義


モデルの北を定義します。定義するには、参照点、北の方向の順に、データ点を2つ入力します。
選択した光源を選択


光源マネージャ(ツリービュー表示)で、ビューで現在選択されている光源を選択します。
ハイライト表示


オンの場合、光源マネージャ(ツリービュー)で光源名を選択する場合と同様の方法で、ビューで光源を選択します。
中心


光源マネージャで選択された光源が1つの場合は選択されている光源の原点をビューの中心とし、光源が複数の場合は各光源の原点の平均を中心とします。
IES詳細テキストを表示


IES光源でこの項目がオンの場合、テキストウィンドウが開き、IES光源の「光度計データファイル情報」が表示されます。
IES Webを表示


IES光源でこの項目がオンの場合、IES光源の光度計の特性がグラフィカルに表示されます。
「ファイル」>「新規設定」 「新規設定」アイコンと同じ機能を実行します。
「ファイル」>「設定をコピー」 「設定をコピー」アイコンと同じ機能を実行します。
「ファイル」>「設定の名前を変更」 選択した光源の設定の名前を変更します。
「ファイル」>「設定を削除」 「設定を削除」アイコンと同じ機能を実行します。
「光源」>「オン」 選択した光源をオンにします。
「光源」>「オフ」 選択した光源をオフにします。
「光源」>「反転」 選択したすべての光源のオン/オフ状態を切り替えます。
「編集」>「すべてを選択」 「照明の名称」一覧ですべての照明を選択します。
「編集」>「選択なし」 「照明の名称」一覧で照明の選択を解除します。
「編集」>「選択を反転」 「照明の名称」一覧で現在選択されている照明を選択解除し、現在選択されていない照明を選択します。
「編集」>「光源を削除」 (光源のみ)選択した光源を削除します。
「編集」>「名前を変更」 (光源のみ)選択した光源の名前を変更できます。一度に複数の光源の名前を変更するには、名前を変更する光源を選択してから、選択した一番上か一番下の光源を右クリックします。光源の名前がハイライト表示されます。光源の名前を変更して<Enter>キーを押します。選択したすべての光源の名前が変更されます。たとえば、ある光源を"Text"という名前に変更すると、残りの光源の名前は"Test (1)""Test (2)""Test (3)"のようになります。
光源の設定 光源の設定一覧を表示します。光源の設定一覧から保存されている光源の設定を選択できます。
照明の名称 明るさ、環境光のオプションと、モデルに追加されている光源を一覧表示します。
プロパティ 選択された明るさのプロパティを表示します。有効になっているプロパティは編集できます。使用可能なオプションによって、プロパティは次のように異なります。
キー入力: DIALOG LIGHTMANAGER