MicroStation CONNECT Edition Help

「画層マネージャ」ダイアログボックス

開いているDGN/DWGファイルとアタッチされた参照の画層の表示と画層ごとの線属性を制御するために使用します。

このダイアログボックスには、次からアクセスすることができます。
  • リボン:「作図」 > 「ホーム」 > 「本図」
  • リボン:「モデリング」 > 「ホーム」 > 「本図」
  • リボン:「管理」 > 「ホーム」 > 「本図」
  • リボン:「ビジュアリゼーション」 > 「ホーム」 > 「本図」
  • ツールボックス:本図ツール
  • ステータスバー:「アクティブ画層」フィールド
  • 既定のファンクションキーメニュー:<Ctrl+F6>キー

「画層マネージャ」ダイアログボックスは、アプリケーションウィンドウの上端または下端に収納できます。



既定では、「画層マネージャ」ダイアログボックスには、モデル、画層およびフィルタの一覧が左側に、詳細セクションが右側に表示されます。

マウスの左ボタンを押したままカーソルを対象のファイル上をドラッグすると、ツリーから複数のデザインファイルと参照ファイルを選択することができます。選択したすべてのファイルの画層が、画層一覧に表示されます。

設定説明
モデル、画層、およびフィルタ一覧 ファイルのモデル、画層、およびフィルタが表示されます。


「画層マネージャ」のモデル、画層、およびフィルタ

  • 現在のモデルが表示されます。展開するか(+)折りたたんで(-)、参照ファイルを表示または非表示にすることができます。モデルまたは選択した参照の画層が、右側の詳細セクションに表示されます。
  • 「全画層」には、開いているDGNファイルにあるすべてのモデル内の画層情報が表示されます。
  • 「フィルタ」一覧も展開(+)するか折りたたんで(-)、名前付きフィルタを表示または非表示にすることができます。これらのフィルタは、ユーザー定義の検索基準に基づいて画層表示をカスタマイズします。「フィルタ」を選択すると、詳細セクションにすべてのフィルタの一覧とその検索基準が表示されます。名前付きフィルタを選択すると、検索基準がモデルの画層に適用されます。

    名前付きフィルタを選択して右クリックすると、次のオプションが表示されます。

    • 新規 - 新規フィルタを作成します。
    • 画層グループ - 「画層グループ」ダイアログボックスが開きます。このダイアログボックスでは、フィルタの画層一覧を選択することができます。
    • フィルタグループ - 「フィルタグループ」ダイアログボックスが開きます。このダイアログボックスでは、既存のフィルタを設定操作とともに使用して、新しいフィルタを定義することができます。
    • 切り取り - 別の場所に配置するフィルタをフィルタ一覧の現在の場所から切り取ります。フィルタを別のフィルタの下に移動すると、上位レベルのフィルタ設定を継承します。
    • コピー - フィルタをフィルタ一覧の現在の場所から異なる場所にコピーします。フィルタを別のフィルタの下に移動すると、上位レベルのフィルタ設定を継承します。
    • 貼り付け - フィルタ一覧で選択した場所にフィルタを配置します。フィルタを別のフィルタの下に移動すると、上位レベルのフィルタ設定を継承します。
    • 移動 - フィルタをフィルタ一覧の現在の場所から異なる場所に移動します。フィルタを別のフィルタの下に移動すると、上位レベルのフィルタ設定を継承します。
    • 削除 - フィルタ一覧からフィルタを削除します。
    • 名前を変更 - フィルタの新しい名前を付けることができます。
    • プロパティ - 「画層のプロパティ」ダイアログボックスが開きます。このダイアログボックスで、フィルタの選択事項を設定します。
画層の一覧 選択したファイルまたは参照の個々の画層の属性とプロパティが表示されます。ダイアログボックスの「フィルタ」オプションを使用して、この一覧をフィルタできます。アクティブな画層の一覧エントリは、シアン(青緑)色で表示されます。

画層の属性およびプロパティを修正するには、一覧で画層を選択して列の中をクリックします。



画層マネージャの画層の一覧

画層の一覧のエントリには次の項目が表示されます。

  • 修正あり - 画層の属性またはプロパティの1つ以上がソースと異なる場合に、このフィールドに印が付きます。ソースは、ライブラリ画層または参照画層のどちらかです。参照画層の場合、それがライブラリ画層を兼ねるかどうかにかかわらず、「修正あり」の設定は常に参照ソースのコンテキストで判断されます。

    カーソルを「修正あり」アイコンの上に置くと、同期していない属性またはプロパティの一覧を含むツールチップが表示されます。

  • 名前 - 画層の名前が表示されます。
  • ライブラリ - 画層がライブラリからインポートされたものかを示します。
  • 番号 - 画層番号を表示します。既定では、画層番号は常に自動(システム)生成されます。ただし、手動で画層番号を変更できます。このエディションでは、番号が自動(システム)生成された画層、およびユーザーによって割り当てられた画層が、画層システムによって記録されます。自動(システム)で生成された番号は、(既定では)「画層マネージャ」では表示されません。自動(システム)で生成された画層番号は、必要に応じてシステムで再割り当てできます。
  • 説明
  • ファイル(画層が含まれるファイル)
  • 論理名 - 「マスター」(開いているDGNファイルの場合)または参照の論理名が表示されます。
  • 線種
  • 線幅
  • 材質 - 材質仕様の全体的な制御を追加で行えます。
  • 全体表示 - 画層の要素が表示されているかを示します。「全体表示」列をクリックして、開いたDGNファイルにあるすべてのモデルのすべてのビューについて画層の表示設定値を変更できます。
  • グローバルフリーズ - 画層がフリーズされているかを示します。フリーズされている場合、その画層上の要素は表示されず、印刷できません。画層がフリーズしていると、その画層上に配置されている共有セルインスタンスまたは参照に含まれるすべての構成要素が表示されません。

    「グローバルフリーズ」列をクリックして、開いたDGNファイルにあるすべてのモデルのすべてのビューについて画層のグローバルフリーズ設定値を変更できます。

  • ロック - 画層がロックされているかを示します。ロックされている場合、既存の要素を操作または修正することはできません。ただし、ロックされている画層上の要素のコピーはできます。「ロック」列をクリックして、画層のロック設定値を変更することができます。
  • プロット - 画層の要素が印刷可能かを示します。
  • 使用済 - 画層が参照で使用されているかを示します。
  • 要素 - 画層の要素数が表示されます。
  • 優先度 - (2次元のみ)画層表示の優先度の値を示します。優先度の値が最も高い画層が前面に表示され、最も低い画層が背後に表示されます。参照および要素の優先度の値も表示に影響します。
  • 透過 - 画層の透過値を示します。値が0%の場合は透過性がまったく設定されない状態を表し、100%の場合はほぼ完全に透明であることを表します。

    要素、参照、および画層に異なる透過値が割り当てられている場合、これらの要素、参照、および画層に有効な透過値が適用されます。

  • すべてを表示
  • 一覧 - 「ツールを表示/非表示」オプションボックスが開き、表示オプションのオン/オフを切り替えることができます。

1つ以上の画層を選択して右クリックすると、画層を管理するためのオプションを含むポップアップメニューが表示されます。これらのオプションは、「画層」メニュー、「フィルタ」メニュー、「編集」メニュー、およびツールバーでも使用できます。このポップアップメニューでは、さらに次のオプションを選択できます。

  • アクティブな画層に移動 - アクティブな画層に移動します。アクティブな画層を探すために画層の一覧をスクロールする必要がないため、多数の画層を操作する際には特に便利です。
  • 要素を再マップ - 「要素を画層に再マップ」ダイアログボックスが開きます。
注記: モデル、セル定義、または寸法スタイルで使用される画層は、太字で表示されます。画層がネストされている場合、通常は淡色表示されます。MS_LEVEL_EDIT_NESTED_ATTACHMENT_LEVELS構成変数を使用してそれを編集することができます。
フィルタ一覧 アクティブな画層フィルタ(モデルの画層一覧)を設定したり、フィルタを管理したりすることができます。


フィルタ一覧

「画層」>「新規」 アクティブなモデルに新規画層を作成します。
LEVELMANAGER LEVEL NEW
「画層」>「アクティブに設定」 選択(強調表示)した画層がアクティブなモデルでアクティブ画層になるように設定できます。
LEVELMANAGER LEVEL ACTIVE
「画層」>「ライブラリ」>「アタッチ」 画層ライブラリをアクティブなモデルにアタッチするための「画層ライブラリをアタッチ」ダイアログボックスが開きます。
LEVELMANAGER LIBRARY ATTACH
「画層」>「ライブラリ」>「デタッチ」 選択したモデルから画層ライブラリをデタッチします。画層ライブラリがアタッチされている場合のみ有効です。
LEVELMANAGER LIBRARY DETACH
「画層」>「インポート」 選択したモデルに画層ライブラリをインポートするために使用するための「画層をインポート」ダイアログボックスが開きます。
LEVELMANAGER LIBRARY IMPORT
LEVEL FILTER IMPORT
「画層」>「エクスポート」

選択したモデルから別のDGNファイルに画層ライブラリをエクスポートするための「画層をエクスポート」ダイアログボックスが開きます。

LEVELMANAGER LIBRARY EXPORT
「画層」>「プロパティ」 「画層のプロパティ」ダイアログボックスが開きます。このダイアログボックスで、画層の線属性やカスタム線種など、画層のプロパティを修正します。
LEVELMANAGER LEVEL PROPERTIES
「フィルタ」>「新規」 新規フィルタを作成します。この選択は「フィルタ」カテゴリにおいてのみ有効です。
「フィルタ」>「名前を付けて保存」 フィルタを保存するための「フィルタを保存」ダイアログボックスが開きます。この選択は「フィルタ」カテゴリにおいてのみ有効です。
「フィルタ」>「インポート」 「画層をインポート」ダイアログボックスが開きます。このダイアログボックスからDGNを開き、「画層/フィルタのインポート」ダイアログボックスを使用してインポートするフィルタを選択および制御できます。
「編集」>「すべてを選択」 ダイアログボックスに一覧表示されたすべての画層を選択します。
LEVELMANAGER LEVEL SELECTALL
LEVEL ELEMENT SELECT [file:file-spec] level-spec
「編集」>「選択なし」 ダイアログボックスに一覧表示されたすべての画層を選択解除します。
LEVELMANAGER LEVEL CLEARALL
「編集」>「選択を反転」 ダイアログボックスで選択されていない画層をすべて選択し、選択されている画層をすべて選択解除します。
LEVELMANAGER LEVEL INVERTSELECTION
「編集」>「切り取り」 選択した(ハイライト表示された)画層をモデルから削除し、クリップボードにコピーします。

「編集」 > 「貼り付け」の順に選択して、画層とその属性を別のモデルに貼り付けます。

LEVELMANAGER LEVEL CUT
LEVEL ELEMENT MOVE [dest:level-spec2] level-spec1
「編集」>「コピー」 選択した(ハイライト表示された)画層をクリップボードにコピーします。

「編集」 > 「貼り付け」の順に選択して、画層とその属性を別のモデルに貼り付けます。

LEVELMANAGER LEVEL COPY
LEVEL ELEMENT COPY [dest:level-spec2] level-spec1
「編集」>「貼り付け」 クリップボードの画層をアクティブなモデルに貼り付けます。
LEVELMANAGER LEVEL PASTE
「編集」>「削除」 選択(強調表示)した画層をモデルから削除します。要素が画層上にある場合、画層は削除されません。
LEVELMANAGER LEVEL DELETE LIST
LEVEL ELEMENT DELETE level-spec
LEVEL PURGE dest:[level-spec2] [ LEVEL–SPEC1 ]
注記: 前述したキー入力コマンドにより、指定された"画層指定1"が削除されます。画層に要素が存在する場合は、指定された"画層指定2"にすべての要素が移動されます。移動先の画層の指定は任意です。指定しない場合は、消去する画層上の要素はすべて"既定"の画層に移動します。
「編集」>「名前を変更」 選択した画層の名前を変更するために使用します。
LEVELMANAGER LEVEL RENAME LIST
新規画層 DGN/DWGファイルに新しい画層を作成します。このアイコンの動作は、「画層」 > 「新規」の場合と同じです。「マスターファイル」カテゴリを選択すると、このアイコンが表示されます。
LEVELMANAGER LEVEL NEW
画層を削除 選択した(ハイライト表示された)画層をファイルから削除します。このアイコンの動作は、「画層」 > 「削除」の場合と同じです。「マスターファイル」カテゴリを選択すると、このアイコンが表示されます。
LEVELMANAGER DELETE LIST
新規フィルタ モデルに新規フィルタを作成します。このアイコンの動作は、「フィルタ」 > 「新規」の場合と同じです。「フィルタ」カテゴリを選択すると、このアイコンが表示されます。
LEVELMANAGER FILTER NEW LIST
フィルタを削除 選択(強調表示)したフィルタをモデルから削除します。このアイコンの動作は、「編集」 > 「削除」の場合と同じです。「フィルタ」カテゴリを選択すると、このアイコンが表示されます。
LEVELMANAGER FILTER DELETE LIST
画層を更新 左側のパネルで開いたDGNファイルを選択している場合、「ライブラリから画層を更新」をクリックすると、開いたDGNファイルおよび参照先モデルを含むDGNファイルの画層のプロパティが、アタッチされた画層ライブラリの対応するソース画層のプロパティと同期されます。

左側のパネルで参照を選択している場合、「ライブラリから画層を更新」をクリックすると、選択した参照とその添付ファイルの画層のプロパティが、添付ファイルのソースファイルの画層のプロパティと同期されます。参照画層がライブラリ画層の場合、そのプロパティは、ソース画層ライブラリの同じ名前の画層のプロパティとも同期されます。

管理者は、MS_LEVEL_EDIT_ATTRIBUTE_LIST を設定して、同期の影響を特定の画層プロパティに制限することができます。

DGNLIB UPDATE LEVELS < ALL | BYLEVELSYMBOLOGY | CUSTOM | OVERRIDESYMBOLOGY >
REFERENCE SYNCHRONIZE LEVELS < ALL | BYLEVELSYMBOLOGY | CUSTOM | DISPLAY | OVERRIDESYMBOLOGY > [ 参照ファイル ]
注記: ネスト参照画層の同期はセッション固有です。
注記: MS_LEVEL_ALLOW_LIBRARY_LEVEL_EDITが設定されている場合、画層の属性を変更すると、ライブラリ画層がアクティブなファイルにコピーされます。これにより、ライブラリ画層の属性に対する変更内容をアクティブなファイルに保存できます。
DGNLIB UPDATE LEVELSDGNLIB UPDATE LEVELS CUSTOMの短縮形)をキー入力した場合、その効果は、開いているDGNファイルで(つまり左側のパネルでファイルを選択して)「ライブラリから画層を更新」をクリックする操作と同じです。

REFERENCE SYNCHRONIZE LEVELS <参照ファイル>REFERENCE SYNCHRONIZE LEVELS CUSTOM <参照ファイル>の短縮形)をキー入力した場合、その効果は、左側のパネルで参照を選択して「ライブラリから画層を更新」をクリックする操作と同じです。

  • 後記号ALLDGNLIB UPDATE LEVELSまたはREFERENCE SYNCHRONIZE LEVELSに追加すると、構成変数MS_LEVEL_SYNC_ATTRIBUTE_LISTの定義で指定されたプロパティに関係なく、すべての画層のプロパティが更新されます。
  • 後記号BYLEVELSYMBOLOGYを追加すると、色、線種、線幅のByLevelプロパティのみが更新されます。
  • 後記号OVERRIDESSYMBOLOGYを追加すると、線属性優先プロパティのみが更新されます。
線属性 値が同じである要素を表示します。
  • ByLevel - オンの場合、ByLevel属性を持つすべての要素を同一の要素線属性とともに表示します。
  • 優先 - オンの場合、特定の画層のすべての要素を既定とは異なる要素線属性のセットとともに表示するビュー設定値です。優先線属性を表示するには、「ビュー属性」ダイアログボックスで「画層優先」をオンにする必要があります。
注記: DWG作業モードでは、線属性の優先は無効になっています。すべての要素がByLevel要素の線属性で表示されます。
画層フィルタ アクティブな画層フィルタを選択できます。このフィルタは、画層リストボックスおよび「属性」ツールボックスのアクティブな画層一覧の画層表示を制限するために使用されます。

フィルタを使用しない場合は<なし>を、すべてのモデルのすべての画層を表示する場合は「全画層」を選択します。または、フィルタ名を選択します。

ダイアログ設定値(アイコン) 「画層マネージャの設定値」ダイアログボックスがポップアップ表示されます。このダイアログボックスで、「画層マネージャ」ダイアログボックスの設定値を設定します。
キー入力: LEVELMANAGER DIALOG OPEN