MicroStation CONNECT Edition Help

ユーザーインターフェイスと基本概念

ここでは、ユーザーインターフェイスおよびその他の基本概念について説明します。それぞれのトピックでは、AutoCAD®の概念またはコマンドを示してから、それに近いMicroStationのコマンドまたは概念について説明します。

色と色パレット

AutoCADの色

すべてのファイルで固定されているのとは対照的に、MicroStationでは、色パレットは安定していながら変更することができます。後で使用するためにカスタム色テーブルを作成および保存するには、「色パレット」ダイアログボックス(「ファイル」 > 「設定」 > 「ファイル」 > 「色テーブル」)を使用します。既定の色テーブル(*.tbl)は、MicroStationのプログラムディレクトリの..\Default\Data\フォルダに格納されています。

コマンドラインとキー入力ウィンドウ

AutoCADの"Command:"プロンプト

MicroStationでは、「キー入力」ウィンドウを使用して手動でコマンドを入力します。コマンドを入力することも、フルサイズの「キー入力」ウィンドウからコマンドを選択することもできます。左側のリストからコマンドを選択すると、該当するオプションが隣接する列に表示されます。コマンドを実行するには、右上隅の「キー入力を実行」アイコンをクリックするか、<<Enter>>キーを押します。

コマンドオプションは「キー入力」ウィンドウには表示されませんので、「ツール設定値」ダイアログボックスで入力してください。

MicroStationには一連のキー入力コマンドが用意されています。これらのコマンドでは、AutoCADコマンドシンタックスを使用してシステム変数を設定したりコマンドを起動したりすることができます。これらのキー入力コマンドを使用する場合は、AutoCADシンタックスとMicroStationシンタックスのどちらを使用するかを選択することができます。

MicroStationでAutoCADコマンドおよびシステム変数を入力するには、以下の3つの方法があります。

  • DWGの前記号を入力してから、AutoCADコマンドを入力する。たとえば、円を配置するには、「DWG CIRCLE」と入力します。
  • 構成変数MS_DWG_COMMANDPREFIXで定義されたコマンド前記号を入力してから、AutoCADコマンドを入力する。既定の前記号は円記号(\)です。たとえば、円を配置するには、「\CIRCLE」と入力します。DGNファイルでコマンドの前記号を使用するには、MDLアプリケーションのdwgsettings.maをMS_DGNAPPS構成変数に追加します。
  • コマンド前記号を入力してから、PGPファイルで定義されたコマンドエイリアスを入力する。たとえば、円を配置するには、「\C」(PGPエイリアス:C, *CIRCLEを使用)と入力します。

コマンドシーケンス

AutoCADコマンドを1度だけ実行する

MicroStationでは、「ツール設定値」ウィンドウを閉じずにアクティブなツールを何度も実行することができます。ツールを選択したら、ツール設定値を入力し、作図領域でデータ点を選択してコマンドを完成します。同じコマンドを再度使用する場合は、目的の回数だけ設定値とデータ点を入力し直すだけで実行できます。コマンドを呼び出し続ける必要はありません。

製図設定値

AutoCADのスナップ、グリッド、直交、Oスナップ、および線幅のステータスバーの切り替え

MicroStationでは、「ビュー属性」ダイアログボックスを使用して、オプションのデザイン補助ツール、要素(オブジェクト)のプロパティ、およびの一部のエンティティクラス(寸法など)の表示/非表示を切り替えます。設定値は、「ビュー番号」リストで選択したウィンドウに適用されます。

「ビュー属性」ダイアログボックスには多数のオン/オフの切り替えがありますが、「直交」と「アキュスナップ」はその中に入っていません。

  • 「軸ロック」設定値がオンの状態は、直交モードに類似しています。
  • アキュスナップをオン/オフにするには、「作図」 > 「作図補助」 > 「スナップ(S)」の順に選択します。

AutoCADの画層と画層

AutoCADの画層

MicroStationでは、AutoCADの画層は画層と呼ばれます。「画層マネージャ」ダイアログボックスを使用して、さまざまな画層の属性を作成および定義します。画層にはDGNファイルの名前と番号が付きますが、名前が付くのはDWG作業モードの場合のみです。「画層マネージャ」の色、線種、線幅、表示オン/オフ、フリーズ、およびロックの設定値は、ファイル内のすべてのモデルとビューにグローバルに影響します。MicroStationでは線属性の上書きも可能なため、要素(オブジェクト)の配置先の画層の「ByLevel」状態と異なる線属性を要素に適用することができます。「優先」モードを使用して「画層マネージャ」でこの代替線属性を設定し、「ビュー属性」ダイアログボックスで「画層上書き」をオンにします。

DGN作業モードで要素の表示のオン/オフを切り替える方法として、「画層の表示」ダイアログボックスに3種類の方法が用意されています。ビュー表示オプションは、ビュー1~8の画層をオン/オフにする場合に使用します。「全体表示」オプションは、すべてのビューとすべてのモデルで画層をオフにします。「グローバルフリーズ」オプションもすべてのビューとすべてのモデルで画層をオフにします。DWG作業モードでは、「ビューポートフリーズ」オプションを使用して、レイアウトまたはモデルの画層をオフにすることができます。

AutoCADの線種と線種

AutoCADの線種オブジェクトプロパティ

MicroStationでは、1つの線種がエンティティの属性として割り当てられます。線種1~7が標準のMicroStation線種ですが、MicroStationのプログラムディレクトリ内の ..\Default\Symb\ フォルダにあるリソースファイルのlstyle.rscとacadlstyle.rscから追加の線種を使用することができます。

使用可能な線種のリストを表示したり線種のリストを変更したりするには、「要素属性を変更」ツールまたは「プロパティ」ダイアログボックスを使用します。新しい線種以外に既存の線種のカスタム修正も作成するには、「線種」ダイアログボックス(「作図」 > 「ホーム」 > 「属性」 > 「線種」 > 「設定値」)を使用して、リソースファイルに線種を保存します。

標準線種の尺度は、図面単位ではなく画面単位を基にしているため、ズームファクタに関係なく正しい尺度が保持されます。ファイルをDWGフォーマットに保存するには、尺度を適用して図面単位に変換する必要があります。これを行う「線種尺度」設定値は、「DWG/DXFとして保存オプション」ダイアログボックスにあります。

MicroStationでグローバルな線種尺度を設定するには、ACTIVE LINESTYLESCALEキー入力コマンド、または「線種」ダイアログボックスの「尺度」フィールドを使用します。

MicroStation線種定義は、線種ライブラリに保存されます。線種ライブラリは、必要に応じてアクティブなモデルにアタッチすることができます。

線幅

AutoCADの線幅(ミリメートル単位で定義)

MicroStationでは、線幅はピクセル単位で定義されます。DGNファイルをDWGに変換するときは、線幅の表示が両方のフォーマットの間で一貫したものになるように、「DWG/DXFとして保存オプション」ダイアログボックスの「線幅尺度」設定値で尺度が処理されます。

線幅の表示を制御するには、「ビュー属性」ダイアログボックスを使用します。要素ごとに線幅を割り当てるには、「要素属性を変更」ツールまたは「プロパティ」ダイアログボックスを使用します。画層ごとに線幅を割り当てるには、「画層マネージャ」ダイアログボックスを使用します。

モデル空間とペーパー空間

AutoCAD TILEMODE 0および1

DGNファイルはモデルで構成されます。MicroStationでは、幾何形状とドキュメントに対して、デザインモデル、図面モデル、およびシートモデルを使用します。DGNファイルフォーマットでは、データをセル(ブロック)、参照、または元の幾何形状や注釈として挿入可能なデザインモデル、デザイン(サブ)モデル、およびシートモデルの数は制限されていません。新しいモデルもセルとして指定可能なので、必要に応じて他の図面やモデルに挿入することができます。モデルの間を移動するには、アプリケーションウィンドウの左下隅に固定されている「ビューグループ」ウィンドウを使用します。新しいモデルそれぞれに新しいビューグループが既定で作成されます。

マウスの機能

AutoCAD右クリック(コンテキストメニュー)

MicroStationでは、マウスのボタンはグラフィック情報の入力に使用します。

  • 要素やコマンドを選択するには、マウスの左ボタン(データボタン)を使用します。左ボタンをクリックすることを、"データ点を入力する"といいます。
  • 操作をキャンセルまたは完了するには、マウスの右ボタン(リセットボタン)を使用します。作図領域や要素ハンドルに関連する右クリックメニューはありません。ツールボックスで右クリックすると、ツールリストが開き、ツールの表示と非表示を切り替えることができます。
  • スナップ点をプレビューするには、3ボタンマウスの中央ボタン(スナップボタン)を使用するか、2ボタンマウスの右ボタンと左ボタンを同時にクリックします。

ユーザーオプションとユーザー選択事項

AutoCADユーザーオプション

MicroStationでは、ユーザー選択事項は、%LOCALAPPDATA%\Bentley\<product_name>\<product_version>\prefs\フォルダにあるユーザー選択事項ファイル*.upfに保存されます。この設定値は異なるセッションの間でも保持されます。このオプションを変更するには、「選択事項」ダイアログボックスを使用します。現在のデザインファイルのみに適用されるオプションを設定するには、「デザインファイルの設定値」ダイアログボックスを使用します。

システム変数

AutoCADシステム変数

MicroStationでシステム変数とユーザー変数を設定するには、「構成変数」ダイアログボックスを使用します。変数のカテゴリが左、個々の変数が右に一覧表示されます。変数をハイライト表示すると、ダイアログボックスの最下部に説明が表示されます。

注記: 開いているファイルがDWGファイルの場合は、AutoCADのシステム変数とその値がファイル閲覧モードの「プロパティ」ダイアログボックスに列挙されます。これらの変数はDWG特有であり、DGNフォーマットには適用されません。
注記: DWGファイルをDGNフォーマットで保存した場合は、フィールドに挿入したAutoCADのシステム変数の値にアクセスすることができません。そのため、DGNフォーマットで保存予定のDWGファイル内のフィールドには、AutoCADのシステム変数の値を挿入しないことをお勧めします。

テンプレートファイルとシードファイル

AutoCADの*.dwtファイル

MicroStationでは、シードファイルを使用して標準のファイル設定値を設定します。これを行わないと、ファイル設定値を繰り返し入力しなければならなくなります。ファイル拡張子は*.dgnのままで、シードファイルは、通常、MicroStationのプログラムディレクトリの..\Default\Seed\フォルダ、またはコンフィギュレーションディレクトリの..\Organization\Seed\フォルダに保存されます。新しいMicroStationファイルを作成するときは、「新規」ダイアログボックスでシードファイルを選択します。選択したシードファイルによって、特にファイルが2次元であるか3次元であるかが判断されます。

MicroStationでは、DWGシードを使用してDWGファイルを作成するか、DGNシードを使用してDGNファイルを作成することができます。結果の新しいファイルはシードを基にして作成されます。これは、リボンから「ファイル」 > 「新規」の順に選択して新しいファイルを作成する場合に限られます。リボンから「ファイル」 > 「名前を付けて保存」の順に選択した場合も新しいファイルが作成されますが、シードやテンプレートではなく、保存するファイルを基にして新しいファイルが作成されます。

あるフォーマットから別のフォーマットに保存(変換)する場合も、リボンから「ファイル」 > 「名前を付けて保存」の順に選択します。新しいファイルの内容は、保存されるファイルの内容と同じです。

単位設定値

AutoCADのDDUNITS(「形式」>「単位管理」)コマンド

MicroStationで現在のファイルの図面単位を設定するには、「デザインファイルの設定値」ダイアログボックスの「作業単位」カテゴリを使用します。単位設定値は、測定、セル、参照、および寸法に適用されます。

MicroStationでDWGファイルを開くとき、「DWGオープンオプション」ダイアログボックスに、DWGファイルフォーマットで使用する単位のオプションが表示されます。既存のDWGファイルから単位を取得する場合に最も信頼性が高いのは、単位のオプションの「デザインセンターの単位」設定値を使用する方法です。

ビュー制御

AutoCADのZoom、Pan、Orbitコマンド

MicroStationには、各ビューウィンドウの上部にビュー制御バーがあります。これらのツールでは、更新(再描画)、ズーム、フィット(オブジェクト範囲ズーム)、回転、パン、および表示スタイル(ワイヤフレームや外形線など)を制御します。ビュー制御は、1つのビューウィンドウにもすべてのビューウィンドウにも適用することができます。3次元ファイルが開いている場合は追加の3次元表示制御が使用可能なため、ソリッドや曲面をさまざまな方法でレンダリングすることができます。

MicroStationの「ビューを最大化」ツールの結果が、AutoCADの「オブジェクト範囲ズーム」の結果と異なる場合があります。MicroStationの「ビューを最大化」ツールでは表示可能なジオメトリのみ表示されますが、AutoCADの「オブジェクト範囲ズーム」領域には表示がオフになっている画層が含まれます。

ビューポートとビューウィンドウ

AutoCADのVPORTSコマンドまたは「表示」メニュー>「ビューポート」

MicroStationでは、「ビュー」タブの「ビューグループ」を使用して、デザインモデル、デザイン(サブ)モデル、およびシートモデルごとに最大8つのビューウィンドウを開いたり閉じたりすることができます。または、作図領域の下に固定されている「ビューグループ」ツールバーを使用して、番号の付いたビューウィンドウのオン/オフを切り替えることができます。「ウィンドウ」グループのコマンドを使用すると、ビューの分割、ずらし重ねまたは並べ替えを行うことができます。

MicroStationでビューの属性やビジュアリゼーションのコマンドを使用するときは、コマンドを適用するビューを選択する必要があります。

後で使用するためにビューの属性に名前を付けて保存するには、「保存ビュー」を使用します。