MicroStation CONNECT Edition Help

ダイナミックビューの図形の抽出

ダイナミックビューには、MicroStationのグラフィック機能が含まれているため、断面グラフィックの作成、外形線表示、カスタム表示スタイルの適用が可能です。"断面図形"という言葉は、曲面、ソリッド、またはメッシュに切り取り領域を作成したときにビューに表示される線分、円弧、および曲線を意味します。表示される曲線は、切り取り領域の表面と元からあった要素が重なる場所にできます。断面グラフィックは表示時に動的に作成されるものであり、実際の要素としては保存されません。

以前のバージョンのMicroStationにはダイナミックビュー機能が含まれていないため、ダイナミックビューの出力は表示されません。以前のバージョンのMicroStationとAutoCADとの下位互換性を維持するためには、このバージョンの「外形線を統合」の設定値を使用して、ダイナミックビューを実際の要素に変換することをお勧めします。

ダイナミックビューの抽出処理

ダイナミックビューの図形を抽出する方法は2つあります。

  1. 「参照」ダイアログボックス(「作図」 > 「アタッチ」 > 「参照」ダイアログボックス起動ツール)で、「ツール」 > 「マスターに統合」の順に選択します。「参照点を統合する」設定ウィンドウで、「3Dアタッチの外形線を統合」をオンにします。


  2. 「V8として保存オプション」ダイアログボックス(「ファイル」 > 「名前を付けて保存」 > 「オプション」)の「参照」タブで、「3Dアタッチの外形線を統合」をオンにします。「V8として保存オプション」ダイアログボックスは、「ファイル」 > 「エクスポート」 > 「共通ファイルタイプ」 > 「V8フォーマットデザイン(*.dgn)」の順に選択し、「ファイルをエクスポート」ダイアログボックスの「オプション」をクリックして開くこともできます。


図形の抽出に付随する問題

図形を抽出することは、図面を作成する方法としてはお勧めできません。この方法を採用すると、次のような問題が発生するからです。

  • 静的な画像が生成されるため、その画像が古くなってもわからなくなる可能性がある。これは、生成される要素が、その図形の元になった断面吹き出し、詳細吹き出し、および立面吹き出しのいずれにも関連付けられなくなるためです。
  • 元のモデルにあった図形以外のエンジニアリングデータが保存されない。
  • 抽出した結果の要素を変更した場合、その変更内容をデザインモデルに反映させる手段がまったくない。
  • ダイナミックビューで適用可能な高度な表示効果のうち、一部しか適用できなくなる。
  • デザインモデルの編集では参照のアクティブ化は使用できません。