MicroStation CONNECT Edition Help

ファイルの圧縮

DGNファイルを圧縮すると、ファイルのサイズが縮小し、アンドゥバッファがクリアされます。

COMPRESS DESIGNキー入力コマンドを使用して、ファイルを圧縮します。このキー入力コマンドは、画層名ディレクトリ(ネスト参照を含むマスターファイルの参照で使用されるすべての画像の一覧)にある画像数を最小化します。また、参照ファイル、ビューグループ、および保存ビュー要素のサイズをトリムできます。

COMPRESS OPTIONS <ON、OFF、RUN、TOGGLE>キー入力コマンド使用して、「オプションを圧縮」ダイアログボックスを開きます。

DGNファイルのパフォーマンスを改善する必要がある場合、COMPRESS DESIGN INCLUDEREFSキー入力コマンドを使用します。このキー入力コマンドは、マスターファイルのすべてのモデルから到達可能なすべての参照とネストされた参照を検索し、これらのファイルを圧縮します。

DGNファイルを開くと、ファイルと参照の画層名辞書のサイズを確認します。画層名辞書のエントリの数がファイルの画層数より2,000以上多くなると、メッセージセンターに警告が表示されます。大きい画層名辞書を含むDGNファイルと圧縮の使用の推奨メッセージが警告に表示されます。「ファイル」 > 「ツール」 > 「圧縮オプション」の順に選択し、「圧縮オプション」ダイアログボックスで「参照を含む」チェックボックスをオンにして、「OK」をクリックするか、COMPRESS DESIGN INCLUDEREFSキー入力コマンドを実行して、ファイルを圧縮してパフォーマンスを改善できます。差が10,000を超えると、同じ警告メッセージのバルーンテキストが表示されます。

注記: 画層名辞書には、マスターファイルのすべての画層名と、ファイル内のモデルにこれまでアタッチされた各参照ファイルのすべての画層名が保存されます。画層名辞書は内部実装であり、ユーザーはアクセスできません。
注意: 開いているDGNファイルのデザイン履歴を記録していない場合は、ファイルを圧縮するとこれまでの変更を元に戻すことができなくなります。
ヒント: 開いているDGNファイルを閉じたときにファイルが自動的に圧縮されるようにするには、「選択事項」ダイアログボックスの「操作」セクション(「ファイル」 > 「設定」 > 「ユーザー」 > 「選択事項」)で「終了時にファイルを圧縮」をオンにします。
注記: 圧縮では、未使用のデータリソースがDGNLibファイルから消去されません。代わりに、DELETE UNUSED(キー入力コマンド)を使用します。