MicroStation CONNECT Edition Help

ツールにツール設定値を追加するには

ツール設定値をカスタムツールに追加する前に、どのツール設定値が使用可能かを調べる必要があります。この操作は、「キー入力」ウィンドウを通して行います。使用可能なツール設定値があれば、それらをカスタムツールに追加することができます。

  1. 展開されたキー入力ウィンドウ(「作図」 > 「ホーム」 > 「本図」 > 「キー入力」)で、ツールをアクティブにするキー入力コマンドを入力します。たとえば、「PLACE LINE CONSTRAINED」と入力します。
  2. SET ITEM TOOLSETTINGS」と入力して、<Enter>キーは押しません。

    4番目の列に有効な設定値が表示されます。上の例の場合は、angle、angletoggle、length、lengthtoggle、solutionchoice、solutiontoggleが表示されます。カスタムツールに設定する設定値を書き留めてください。

  3. 「カスタマイズ」ダイアログボックス「ファイル」 > 「設定」 > 「構成」 > 「カスタマイズ」で、「ツール」タブをクリックします。
  4. 「ユーザーツール」セクションを展開して、開いているDGNファイルを展開します。

  5. 設定値を追加するツールを含むツールボックスを展開します。

  6. 設定値を追加するツールを選択します。

    ツールのキー入力コマンドのプロパティが「プロパティ」ペインに表示されない場合は、「コマンドデータ」タブの右側にある矢印をクリックします。

  7. 「キー入力コマンド」フィールドにキー入力コマンドを入力します。たとえば、「PLACE LINE CONSTRAINED」と入力します。
  8. 次の1つを行います。

    設定値を追加するツールを右クリックして、ポップアップメニューから「追加」を選択します。

    または

    ツールの既存のプロパティの下で右クリックして、ポップアップメニューから「追加」を選択します。

    プロパティカテゴリのカスケードしたリストが表示されます。

  9. 「ダイアログアイテムの設定」をクリックします。

    ダイアログアイテムの設定のプロパティが、「アイテムの設定」タブの「プロパティ」ペインに表示されます。ツールのダイアログアイテムの設定のプロパティが「プロパティ」ペインに表示されない場合は、「アイテムの設定」タブの右側にある矢印をクリックします。

  10. (オプション) このツールに複数の設定値を追加するには、「アイテムの設定」タブを右クリックして、ポップアップメニューから「ダイアログアイテムの設定」を選択します。

    「ダイアログアイテムの設定(0)」、「ダイアログアイテムの設定(1)」などが「プロパティ」ペインに表示されます。

  11. 「ダイアログアイテムの設定(0)」を展開します。「ダイアログアイテム名」フィールドで、「ToolSettings.ItemName」を最初の設定の名前に置き換えます。たとえば、「ToolSettings.lengthtoggle」と入力します。このツール設定によって、「長さ」チェックボックスがオンになります。
    注記: どのツールが選択されている場合でも、ダイアログアイテム名の最初の部分は必ず"ToolSettings"になります。ダイアログアイテム名の2番目の部分は、手順2で確認した設定値になります。ダイアログ名とアイテム名は大文字と小文字が区別されます。
  12. 「タイプ」フィールドで、「リテラル」、「距離」、「領域」、または「3次元領域」を選択します。たとえば、次の手順でチェックボックスをオンにするために、「リテラル」を選択します。
  13. 「値」フィールドに、設定値を入力します。たとえば、「1」と入力して、「長さ」チェックボックスをオンにします。
  14. 「ダイアログアイテムの設定(1)」を展開します。「ダイアログアイテム名」フィールドで、「ToolSettings.ItemName」を2番目の設定の名前に置き換えます。たとえば、「ToolSettings.length」と入力します。このツール設定によって、「長さ」フィールドに長さが設定されます。
  15. 「タイプ」フィールドで、「リテラル」、「距離」、「領域」、または「3次元領域」を選択します。たとえば、次の手順で距離値を指定するために、「距離」を選択します。
  16. 「値」フィールドに、距離を入力します。たとえば、「20」と入力して、「長さ」フィールドに20を設定します。

    ツールボックスを開いてツールをクリックすると、「線分を配置」ツールがアクティブになります。「長さ」チェックボックスがオンにされ、配置する直線が20作業単位の長さになります。