MicroStation CONNECT Edition Help

「カスタマイズ」ダイアログボックス

カスタムのツールボックスツールタスク、およびメインタスクの追加と管理に使用します。また、コンテキストメニューアイコンのカスタマイズに使用します。

このダイアログボックスには、次からアクセスすることができます。
  • リボン:「ファイル」 > 「設定」 > 「構成」 > 「カスタマイズ」


注記: キー入力コマンド「CUSTOMIZE DELETEALLDATA」を使用すると、すべてのテンプレートデータ、カスタムのツールボックス、ツール、タスク、およびメニューデータをDGNファイルから削除できます。削除するテンプレートに関連付けられているすべての要素の関連付けが解除されます。
キー入力: CUSTOMIZE DELETEALLDATA
注記: キー入力コマンド「CUSTOMIZE RELOAD」を使用すると、すべてのテンプレートデータ、カスタムのツールボックス、ツール、タスク、およびメニューデータをDGNファイルに再ロードできます。DGNライブラリが更新された場合、このキー入力コマンドを使用して更新データを再ロードし、使用することができます。これは、DGNファイルを閉じて再度開くことと同じです。
キー入力: CUSTOMIZE RELOAD
注記: キー入力コマンド「CUSTOMIZE EXPORT ICONS <path\directory\>」を使用すると、開いているDGNライブラリからディレクトリにアイコンをエクスポートすることができます。アイコンをエクスポートしてから編集することもできます。
キー入力: CUSTOMIZE EXPORT ICONS [ path\directory\ ]
注記: キー入力コマンド「CUSTOMIZE IMPORT ICONS <パス\*.ico>」を使用すると、開いているDGNライブラリにアイコンをインポートすることができます。アイコンを1つだけインポートするには、CUSTOMIZE IMPORT ICONS <パス\ファイル名.ico>のように指定します。
キー入力: CUSTOMIZE IMPORT ICONS [ path\*.ico ]
注記: キー入力コマンド「CUSTOMIZE OPEN TOOLBOXASMENU」を使用すると、ポインタ位置にあるカスタムのツールボックス、タスク、またはメインタスクを開くことができます。カスタムのツールボックス、タスク、またはメインタスクの名前を指定する必要があります。タスク名の前には円記号が1つ(\)、メインタスク名の前には円記号が2つ(\\)必要です。カスタムツールボックス名の前には特殊文字は不要です。
キー入力: CUSTOMIZE OPEN TOOLBOXASMENU [ name of custom toolbox, \task, or \\main task ]
キー入力: CUSTOMIZE DIALOG
注記: キー入力コマンド「CUSTOMIZE ACTIVATE TOOL<toolpath>」を使用すると、カスタムのタスクとツールボックスに追加されているツールをアクティブにすることができます。カスタムの各アイテムの「<toolpath>」のシンタックスは次のとおりです。
  • ツールボックスの場合 - ツールボックス名\ツール名
  • タスクの場合 - \タスク名\ツール名
  • メインタスクの場合 - \\メインタスク名\ツール名
キー入力: CUSTOMIZE ACTIVATE TOOL [ toolpath ]
設定説明
「ファイル」 > 「インポート」 > 「XMLファイルから」 XMLファイルからデータをインポート して、テンプレート、カスタムツールボックス、カスタムツール、タスク、およびカスタムメニューを作成します。データを複数のファイルからインポートできます。 「ファイルからXMLデータをインポート」ダイアログボックス が開きます。
CUSTOMIZE IMPORT XML [ path\XML_filename ]
「ファイル」 > 「エクスポート」 > 「XML」 DGNライブラリからXMLファイルにテンプレート、カスタムツールボックス、カスタムツール、タスク、カスタムメニューデータを エクスポート します。「XMLデータをエクスポート」ダイアログボックスが開きます。
CUSTOMIZE EXPORT XML [ path\XML_filename ]
「ファイル」 > 「<構成されたDGNライブラリ>」 MS_DGNLIBLIST構成変数が定義されている場合は、構成されたDGNライブラリのファイルを一覧表示します。いずれかのファイルを選択すると、開いていたDGNファイルが閉じ、選択したファイルが開きます。

MS_GUIDGNLIBLIST構成変数の設定がMS_DGNLIBLIST構成変数と異なる場合、これらのファイルは同様に一覧表示されます。個人用のDGNライブラリを作成している場合は、そのファイルも一覧表示されます。

「ユーティリティ」 > 「HTMLレポートを生成」 開いているDGNライブラリファイル内のすべてのテンプレート、カスタムツールボックス、カスタムツール、タスク、カスタムメニューデータに関する HTMLレポートを生成します 「HTMLレポートを生成」ダイアログボックスが開きます。
CUSTOMIZE GENERATEHTMLREPORT
「ユーティリティ」 > 「名前付き演算式」 「名前付き式」ダイアログボックスが開きます。
「ユーティリティ」 > 「要素テンプレート」 「要素テンプレート」ダイアログボックスが開きます。
「ツール」タブの「ツール」パネル カスタムのツールボックスとツールの追加と管理 に使用します。
「ツール」タブの「タスク」タブ カスタムのタスクの追加と管理 に使用します。
「ツール」タブの「メインタスク」タブ 「メインタスク」のカスタマイズ に使用します。
「ツール」タブの「コンテキストメニュー」タブ コンテキスト(右クリック)メニューのカスタマイズ に使用します。
「アイコン」タブ アイコンのインポートと管理 に使用します。