MicroStation CONNECT Edition Help

「色パレット」ダイアログボックス



アクティブな色テーブル"コピー"を参照したり、テーブルを修正するために使用します。色テーブルは、DGNファイルに現在アタッチされているものか、またはアタッチされていない場合には既定(内部)の色テーブルです。必要な変更をした後、この"コピー"をアクティブなDGNファイルにアタッチすることも、後でアタッチするときのために別なファイルとして保存することもできます。

このダイアログボックスには、次からアクセスすることができます。
  • リボン:「ファイル」 > 「設定」 > 「ファイル」 > 「色テーブル」

デザインモデルファイルの背景色は、現在の色テーブルの背景色の値によって定義されます。この設定は「色テーブル」ダイアログボックスで行います。シートモデルの背景色は、互いに排他的な類似の値によって定義されます。既定では、シートモデルの背景色は白(RGB 255,255,255)です。構成変数MS_DEFAULTSHEETRGBによって、最初のシートモデルを作成したときに使用される別の背景色を指定できます。この変数は、カンマで区切られたRGBの3つ組です(たとえば、255,0,0は赤の背景を生成します)。最初に作成されたシートモデルの背景色が、それ以降に作成されるシートモデルの背景色になります。

キー入力: DIALOG COLOR
注記: この構成変数を変更しても、既存のシートモデルやそれ以降に作成されるシートモデルの背景色は変わりません。構成変数は、最初のシートモデル作成時にのみ使用されます。シートモデルの背景色を変更するには、任意のシートモデルで「色テーブル」ダイアログボックスを開きます。1つのシートモデルで背景色を変更すると、その色が他のすべてのシートモデルに適用されます。
設定説明
色テーブル 色パレットの各タイルは、アクティブな色テーブル内の色を表します。色を変更するには、まずその色を選択する必要があります。選択した色タイルが拡大され、その中にインデックス番号(0~254)が表示されます。ビューの背景色は、ツールボックスの右下角に表示され、その上に"B"表示されます。

タイルをダブルクリックすると、「色を修正」ダイアログボックス が開きます。このダイアログボックスで、色を修正します。

アタッチ クリックすると、色パレットに示されている色を含んだ色テーブルが開いているDGNファイルにアタッチされます。DGNファイルを再び開くと、この色テーブルが自動的にアタッチされます。
ATTACH COLORTABLE [ テーブル ]
CT= [ テーブル ]
注記:ATTACH COLORTABLE <スペース>」(または「CT=<スペース>」)とキー入力すると、別の色テーブルをアタッチせずにアタッチされている色テーブルをデタッチ(アタッチ解除)します。
変更 「色を修正」ダイアログボックス が開きます。このダイアログボックスで、選択した色を修正します。
キャンセル 色テーブルのコピーを破棄して、「色パレット」ダイアログボックスを閉じます。
「ファイル」メニュー>「開く」 「色テーブルを開く」ダイアログボックスが開きます。このダイアログボックスで、色タイルに新規の色テーブルをロードします。色テーブルは、開いているDGNファイルにアタッチすることができます。
「ファイル」メニュー>「名前を付けて保存」 「色テーブルを保存」ダイアログボックスが開きます。このダイアログボックスで、色テーブルを色テーブルファイルとして保存します。
「ファイル」メニュー>「既定」 既定(内部)色テーブルと同じ設定値になるように、色テーブルのコピーを変更します。既定色テーブルは、開いているDGNファイルに色テーブルがアタッチされていない場合に既定でアクティブになる色テーブルです。既定の色テーブルと同じ設定値を持つ色テーブルを、開いているDGNファイルにアタッチするには、「既定」をクリックしてから「アタッチ」をクリックします。
COLORTABLE DEFAULT
注記: 色テーブルはカスタマイズすることができ 、後で使用できるように色テーブルファイルに保存できます。
「ファイル」メニュー>「元に戻す」 「色テーブル」ダイアログボックスを閉じずに、色テーブルをアクティブな色テーブルの設定値にリセットします。

既定では、正確な色の定義は色テーブルの初めから取り出されます。

「ファイル」メニュー>「情報」 「色テーブル情報」ダイアログボックスが開きます。このダイアログボックスは、色テーブルがアタッチされている場合の設定状況を示します。
「編集」メニュー>「色を補間」 「補間による色の定義」ダイアログボックスが開きます。このダイアログボックスで、アクティブな色テーブルの色を補間(色のペアの間に濃淡を指定)します。


「編集」メニュー>「色をコピー」 色パレットで選択した色をクリップボードにコピーし、色パレットの別の位置に貼り付けられるようにします。
「編集」メニュー>「色を貼り付け」 クリップボードから色パレットの選択した位置に色をコピーします。