MicroStation CONNECT Edition Help

Light Manager Dialog

Used to control light setups and the settings for both global and source lighting. Other options let you place or delete source lighting cells and to define the direction of North in the model. When you highlight a light source in the Light Name list, its settings are displayed for editing as required.

You can access this dialog from the following:
  • Ribbon: Visualization > Home > Lighting dialog launcher
  • Ribbon: Visualization > Home > Lighting > Manage
  • Luxology Render dialog: Light Setup icon
  • Toolbox: Lights

For some of the lights, the settings are provided in different tabs such as Details, Solar Position (only when solar light is selected), Volume Effects (only for Solar, Directional, Point and Spot Lights) and Expert.



For some light source settings such as Solar, Directional, Spot, and Area Lights, you can view the Light Preview. The preview is intended to give you a quick view of the light’s color and is especially useful for adjusting volumetric effect. The Light Preview is displayed at the bottom of the Light Manager dialog can be enlarged by double-clicking on it.

Depending on the type of light selected, you can choose from different light widgets. These light widgets are models that are stored in the Bentley_LightWidgets.dgnlib, which is located in ..\Default\Materials\ folder in MicroStation's program directory. You can create additional light preview widgets in another DGNLib file and add the location of that DGNLib file to the MS_MATERIAL configuration variable. The name of this DGNLib file must contain _LightWidget. A saved view must be created for each preview with a unique prefix name that identifies the object, separated with $$ and then a suffix that describes the light type. The suffix names are solarlgt, directlgt, spotlgt, pointlgt, and arealgt. For example: Room$$directlgt, Lamp$$pointlgt, Window$$directlgt, Office$$arealgt.

When creating light widgets each model should have a light setup with the name ‘Preview’ to indicate that this setup is to be used as a Light Preview widget.

SettingDescription
Light Setups List


Turns on or off the display of light setups list, from which you can select a saved lighting setup. When the list is not displayed, you can click the Down arrow to open an option menu that lets you select from saved lighting setups.
New Setup


Creates a new lighting setup in the Light Setups list, having a default name “Untitled-x” (where x is a numeric extension). The default name may be edited as required.
Copy Setup


Copies the selected light setup and adds the copy to the list. By default the copy is given the same name as the original with a number appended.
Delete Setup


Deletes the selected light setup.
Place Light Option menu, with icon, that lets you place a light source cell, or create an area light source from an existing element. The icon defaults to the previously selected light source type, with the option menu displaying the remaining options available.
  • Place Point Light — Opens the Place Light tool with Point Light selected.


  • Place Spot Light — Opens the Place Light tool with Spot Light selected.


  • Place Area Light — Opens the Place Light tool with Area Light selected.


  • Place Directional Light — Opens the Place Light tool with Directional Light selected.


  • Place Sky Opening — Opens the Place Light tool with Sky Opening selected.


Edit Solar Path


Lets you graphically manipulate the solar position within a view. When you click the icon, the Solar Position tab automatically displays for you to choose the settings.
Define North


Lets you define North for the model. You do this by entering two data points, defining first a reference point and then the direction for North.
Choose Selected Lights


Selects the lights in Light Manager (tree view display) that are currently selected in the view.
Highlight


When on, selects the lights in the view as the light names are selected in the Light Manager (tree view).
Center


Centers the view to the origin of the light selected for single selection and centers to the average of the origins of the lights for multi select of lights in the Light Manager.
Show IES Detailed Text


If on, for an IES light source, a text window opens to display the Photometric Data File Information for the IES light source.
Show IES Webs


If on, for an IES light source, then the photometric characteristics for the IES light source are displayed graphically.
File > New Setup Performs the same function as the New Setup icon.
File > Copy Setup Performs the same function as the Copy Setup icon.
File > Rename Setup Lets you rename the selected light setup.
File > Delete Setup Performs the same function as the Delete Setup icon.
Lights > On Turns on the selected light.
Lights > Off Turns off the selected light.
Lights > Toggle Changes the on/off state of all selected lights.
Edit > Select All Selects all lighting in the Light Name list.
Edit > Select None Deselects any lighting in the Light Name list.
Edit > Invert Selection Deselects currently selected lights and selects currently unselected lights in the Light Name list.
Edit > Delete Light (Source lighting only) Deletes the selected light(s).
Edit > Rename (Source lighting only) Lets you rename the selected light. To rename multiple source lights at once, select the lights to be renamed; then right-click on the top or bottom light of the selected lights. The light name highlights. Rename the light and press <Enter>. All the selected lights are renamed. For example, if you rename a light to "Test", the remaining lights will be renamed as "Test (1)", "Test (2)", "Test (3)", and so on.
Light Setups Displays the light setups list, from which you can select a saved lighting setup.
Light Name List displaying Brightness, the Global Lighting options, plus any source lighting that has been added to the model.
Properties Displays the properties, for the selected brightness or light source, any of which may be edited if they are enabled. Properties vary for the available options, which can be:
Key-in: DIALOG LIGHTMANAGER