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ConstructSim i-model Publisher 

Overview
The ConstructSim i-model Publisher allows you to create an iModel of the Virtual Construction Model (VCM)
using ConstructSim Executive. You can then open this iModel in Bentley Navigator.
An iModel is a container for multi-discipline information published from known sources in a known state at a
certain point in time. The iModel combines all the graphics and business data intelligence, as defined by the
design application, into a single deliverable container for distribution. Because an iModel optimizes the business
data, the result is decreased file size and easier navigation. An iModel created using ConstructSim i-model
Publisher has an .IMODEL extension.
The iModel can be published from ConstructSim Executive using the Publish model for Bentley Navigator
node. You can publish an iModel without performing the complete End-to-End Data Run.

Software Requirements
In order to create an .imodel file, you need to install ConstructSim Executive and be a Data Processing
Administrator with permission to execute Managed Commands in ConstructSim Executive.
In order to open an .imodel file published by ConstructSim i-model Publisher, you need to install Bentley
Navigator.
In order to create an .imodel file, you also need to have ConstructSim i-model Publisher installed on the Data
Processing Server machine.

Software Downloads

To download the installers, go to https://connect.bentley.com/ and click the Software Download tile.
Download (https://softwaredownloads.bentley.com/en/ProductDetails/2590) and install ConstructSim i-model
Publisher 06.01.04.04 on the data processing machine.
On the client machine, download (https://softwaredownloads.bentley.com/en/ProductDetails/2545) and install
desktop Navigator10 10.02.01.124.
• If the Navigator installer requires install KB2999226, download it from https://support.microsoft.com/en-

us/help/2999226/update-for-universal-c-runtime-in-windows.
• If you get the error below, install .NET 4.6.1 from https://www.microsoft.com/en-us/download/

details.aspx?id=49981.

ConstructSim i-model Publisher 3

https://connect.bentley.com/
https://softwaredownloads.bentley.com/en/ProductDetails/2590
https://softwaredownloads.bentley.com/en/ProductDetails/2545
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows
https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows
https://www.microsoft.com/en-us/download/details.aspx?id=49981
https://www.microsoft.com/en-us/download/details.aspx?id=49981


Publishing iModels
The Data Processing Administrator uses ConstructSim Executive to set up the iModel publishing workflow
configuration.

To Save Your Work

Before publishing an iModel, users must save their work by synchronizing their changes to the server.
1. In ConstructSim Planner, from the ConstructSim menu, select Synchronization > Synchronize changes .

To Publish the iModel Using the End-to-End Data Run

1. On the Data Processing Administrator machine, open the ConstructSim Executive Client.
2. From the menu bar, open your project.
3. In the Workflows panel, go to ConstructSim Project > End-to-End Data Run > Phase 4 - Upload New VCM

to Server > Publish model for Bentley Navigator and expand the node.
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4. Enable the Publish .i.dgn, Publish .imodel and Publish iModel to Project Share commands.
5. Right-click the End-to-End Data Run node and select Run.

At the completion of the End-To-End Data Run, the iModel is created and published in the Project Share.
6. Open the iModel with Bentley Navigator Update 10 from Project Share.

To Publish the iModel Using the Intra-Week Workflow

1. On the Data Processing Administrator machine, open the ConstructSim Executive Client.
2. From the menu bar, open your project.
3. In the Workflows panel, go to ConstructSim Project > Publish model for Bentley Navigator.
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4. Enable the Publish model for Bentley Navigator node.
5. Right-click Publish model for Bentley Navigator and select Run.

The iModel (.imodel) is created and published in the Project Share.
6. Open the iModel with Bentley Navigator Update 10 from Project Share.

Opening iModels
You can open a published iModel with Bentley Navigator through Project Share.

To Open the iModel with Bentley Navigator in Project Share

1. In Bentley Navigator, open the CONNECT project.
2. In the left pane, select ProjectWise Share.

A list of the published iModels displays.
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3. Click the iModel you want to download.
The iModel opens in Bentley Navigator.

TBD: remove or not? To Open the iModel Using the ConstructSim Work Package
Server

1. From the ConstructSim Work Package Server Home Page's Project info panel, click Published models.
A list of files display.
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2. Click the *.imodel file you want to open.
You are asked if you want to open or save the file.

3. Click Open.
If Bentley Navigator is installed, the iModel opens in Bentley Navigator.

Troubleshooting Licensing Issues
Note: These licensing issues refer to the Data Processing Server system.
The DPExporter.exe log file is used to diagnose problems in the ConstructSim i-model Publisher. This file can be
found in the %AppData%\Bentley\Logs folder. This log file is created automatically and logs any licensing
issues that occur. If there are licensing issues, ConstructSim Executive will not be able to publish the iModel.
A sample of the file is as follows:
2016-10-06 07:14:14,517 FATAL [0x00002910] FATAL ConstructSim.DP.Exporter - ERROR: Failed to obtain
proper license for ConstructSim i-model Publisher. Please run either the Activation Wizard to enter your license
server information or the License Management Tool to check your license status.
Follow the instructions in the log file to correct the problem. See the Activating ConstructSim i-model Publisher
(on page 8) section for more information on licensing and activating the product.

Activating ConstructSim i-model Publisher
Note: This information on Activating ConstructSim i-model Publisher refers only to the Data Processing Server
system.
Product activation is achieved by connecting to a SELECTserver, receiving verification that your SELECTserver
Name and Activation Key are correct, and successfully posting usage logs. Product activation is not the same as
checking out a license. After initial configuration, ConstructSim i-model Publisher automatically and
transparently tries to activate each time it runs, and runs unconstrained for a period of seven days after its last
successful activation.
Note: If the workstation on which ConstructSim i-model Publisher is running does not have regular network
access for periodic activation (at least every seven days), then consider utilizing a checked-out license. Checked-
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out licenses are considered to be in full-time use and ConstructSim i-model Publisher will not attempt to post
usage for the duration of the license term.
The License Management Tool dialog is used to check out licenses. The Using the Product Activation Wizard (on
page 12) is designed to step you through the product activation process.
To open the License Management Tool dialog, go to the Start menu, search for "license," and click the SELECT
License Tool.
To open the Product Activation Wizard, in the License Management Tool dialog, select Tools > Product
Activation Wizard.

License Management Tool Dialog

Used to check out application and program licenses that are under concurrent license control of the
SELECTserver License Manager to systems that are not continually connected to a network with access to
SELECTserver, such as workstations, laptops, and portables. This enables users dependent on the SELECTserver
License Manager (LM) concurrent licensing feature to use LM-managed application licenses on remote systems
for extended periods of time.
The remotely used application can reside on the remote system continually, even when its license is not active.
The only physical requirement for use is that the remote system is connected to a network with access to
SELECTserver during the time that the license is being requested and transferred from the License Management
Tool utility.
Once the license is checked out, the system can be disconnected from the network, and the application for which
the license was checked out can be operated at anytime during the valid checkout period. After the checkout
period has expired, the application will no longer operate until a new license for that application is checked out.
If the application is no longer needed, either temporarily or permanently, the license can be checked in, making
it available to other users who can use the license either within the network or remotely. Once the license
checkout period expires, the License Management Tool utility automatically “checks in” the license and makes it
available to other users.

Checking out the License
Go to the Start menu, search for "license," and click the SELECT License Tool to open the License Management
Tool dialog.
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In the License Management Tool dialog, go to the License Checkout tab and select ConstructSim i-model
Publisher and click CheckOut. The Checkout Settings dialog opens.
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Enter your email address, select the version you want and click OK. The Checkout Results dialog opens
displaying the status of the check out. Status column should show Success.
Click the Activation Status tab and see that your license is checked out.
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Click Activate.

Using the Product Activation Wizard

The Product Activation Wizard is designed to step you through the product activation process. After a product is
installed, you must obtain a license and then activate that license. Obtaining the license alone is not enough to
complete the process. This wizard eliminates the confusion and makes it clear that obtaining a license and
activating a product are two essential steps.
To open the Product Activation Wizard, go to the Start menu, search for "license," and open the SELECT License
Tool. In the License Management Tool dialog that opens, select Tools > Product Activation Wizard.
The Product Activation Wizard opens and the first screen offers these product activation options:
• SELECT subscriber activating against a hosted (Bentley) SELECTserver
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• SELECT subscriber with a deployed (local) SELECTserver
• NON-SELECT or Node Locked user
• Evaluation Only - No license information
The wizard steps you through the activation process based on the options selected.

SELECT Subscriber Activating Against a Hosted (Bentley) SELECTserver
If you are activating against a hosted (Bentley) SELECTserver, the Server Name is pre-populated but you must
provide the proper Activation Key - see http://www.bentley.com/activate for more information regarding this.
1. Select SELECT subscriber activating against a hosted (Bentley) SELECTserver and click Next.

The Activating against a SELECTserver page opens.
2. Enter the site activation key in the Site Activation Key field.
3. If you are using HTTPS, turn on HTTPS (SSL).
4. If you are using a proxy server to connect to the SELECTserver, click the Proxy button and fill in the Proxy

Server information, then click OK.
5. Click Test Connection to verify the connection to the SELECTserver.
6. Click Next.
7. On the Country of Use page, select the country where you will be using this product and click Next.

The Wizard Selections page displays the information provided on the previous pages.
8. Review the information and click Finish to activate the product.

SELECT Subscriber with a Deployed (local) SELECTserver
If you are activating against a local SELECTserver, you must provide the proper Server Name and Activation Key.
The Server Name and Activation Key, along with any proxy configuration information, can be obtained from your
Site Administrator.
1. Select SELECT subscribers with a deployed (local) SELECTserver and click Next.

The Activating against a SELECTserver page opens.
2. Enter the name of the server in the Server Name field.
3. Enter the site activation key in the Site Activation Key field.
4. If you are using HTTPS, turn on HTTPS (SSL).
5. If you are using a proxy server to connect to the SELECTserver, click the Proxy button and fill in the Proxy

Server information, then click OK.
6. Click Test Connection to verify the connection to the SELECTserver.
7. Click Next.
8. On the Country of Use page, select the country where you will be using this product and click Next.

The Wizard Selections page displays the information provided on the previous pages.
9. Review the information and click Finish to activate the product.

NON-SELECT or Node Locked User
If you are not a Bentley SELECT subscriber and you are activating your product, you are presented with three
options:
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I have a license file ready to import
1. Enter the path to your license file (or Browse to the location of your license file) in the License File field.
2. Click Next.

The Wizard Selections page displays the information provided on the previous pages.
3. Review the information and click Finish to activate the product.

I have an activation key
1. Enter the site activation key in the Site Activation Key field.
2. If you are using HTTPS, turn on HTTPS (SSL).
3. If you are using a proxy server to connect to the SELECTserver, click the Proxy button and fill in the Proxy

Server information, then click OK.
4. Click Test Connection to verify the connection to the SELECTserver.
5. Click Next.

The Check out license now? page displays.
6. Enter your email address in the Email Address field.
7. Select the product to be activated (if not pre-populated) in the Product Name field.
8. Enter the product version number (XXX.XXX.XXX.XXX, if not pre-populated) in the Product Version field.
9. Click Next.

10. On the Country of Use page, select the country where you will be using this product and click Next.
The Wizard Selections page displays the information provided on the previous pages.

11. Review the information and click Finish to activate the product.

I do not have any license information
1. The product will run in evaluation mode.
2. Click Go To Bentley.com to request activation information.

Evaluation Only - No License Information
1. The product will run in evaluation mode.
2. Click Go To Bentley.com to request activation information.

Copyright
Copyright (c) 2020, Bentley Systems, Incorporated. All Rights Reserved.
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