# Table of Contents

## Chapter 1: Network, Hardware and Software Architecture ................................................................. 4
- Applications Installations ......................................................................................................................... 4
- Setup Prerequisites ........................................................................................................................................ 4
- Hardware and Software Architecture .......................................................................................................... 7
- Role Permissions ........................................................................................................................................... 10

## Chapter 2: Pre-Configuring the Environment ......................................................................................... 12
- To Register a Project ................................................................................................................................. 12

## Chapter 3: WPS Database Pre-Configuration .......................................................................................... 15
- To Set the Microsoft SQL Server Properties ............................................................................................... 15
- To Create a Database ..................................................................................................................................... 16
- To Modify the Database to Support SNAPSHOT_ISOLATION ................................................................... 17

## Chapter 4: Configuring the ConstructSim Work Package Server Application Server ......................... 18
- To Pre-Configure the ConstructSim Work Package Server Application Server ........................................ 18
- To Change User Account Control Settings ................................................................................................. 19
- To Configure the ConstructSim Work Package Server Application Server ............................................. 19
- To Create a Datasource ................................................................................................................................ 20
- To Create a Community ............................................................................................................................... 25
- To Create a Storage Device ......................................................................................................................... 27
- To Create a Repository ............................................................................................................................... 29
- To Configure the Work Queue Service ......................................................................................................... 30
- To Configure a Secure Connection in the eB Application Server ................................................................ 31
- To Register the Engines ............................................................................................................................. 32
- To Configure Mail Distribution .................................................................................................................... 32
- To Turn off Audit for the Document and Tag .............................................................................................. 33
- To Add a Certificate to the App Server ........................................................................................................ 34
- To Check the Domain of eB Services ........................................................................................................... 35
- To Change/Update the Administrator Account Password ........................................................................... 35

## Chapter 5: Configuring the Web Server .................................................................................................. 37
- To Pre-configure the Web Server ................................................................................................................ 37
- To Configure the SQL Server Reporting Services Component on the Web Server .................................. 38
- To Configure the ConstructSim Work Package Server ............................................................................ 39
- To Register the Domain and URL for IMS ................................................................................................... 42
- To Register a Product to the IMS Environment .......................................................................................... 43
- To Configure the Default Web Site for Permissions .................................................................................. 43
- To Set Security Updates for SSRS Support ................................................................................................. 44
- To Configure the Web Server for a Secure Connection ............................................................................ 44
- To Configure the SQL Reporting Server ..................................................................................................... 46
- To Set Up Site Settings Security ................................................................................................................... 46
- To Set Up to View Progress Reports ......................................................................................................... 47
- To Set Full Permissions for SSRS User ........................................................................................................ 49
Network, Hardware and Software Architecture

Applications Installations

The ConstructSim product suite is comprised of three separate application installations. These application installations operate together based on whether the target computer is intended for use by the Data Processing Administrator or Workface Planner. In addition, a Virtual Construction Model (VCM) database is deployed onto a server class machine to provide a work-sharing environment for the collective team of administrative and field users.

General Requirements

A CD drive or access to the Internet is required for product installation.

ConstructSim products require machines running the Windows 8.1 (64-bit) or Windows 10 (64-bit) operating system.

Applications Installations

The set of application installations include:

- ConstructSim Planner: Desktop application for interaction in a Virtual Construction Model.
- ConstructSim Executive Client: Workflow execution engine and associated utilities for generating and updating a Virtual Construction Model.
- ConstructSim i-model Mapper: Desktop application to map i.dgn schema with ConstructSim BIM schema.

Internet Access

The ConstructSim Work Package Server is a web-based interface that follows the complete life cycle of a work package and stores the engineering data and information modeling for a project. You need Internet access to launch this web site.

Setup Prerequisites

Database Prerequisites

1. SQL Server 2014/2016
2. (eB database only) Turn on Snapshot_Isolation.
3. In the SQL Server Configuration Manager, turn on Named Pipes.
**Application Server Prerequisites**

1. Install .NET Framework 3.5.
2. Install .NET Framework 4.5 or higher.
3. Turn off UAC.
4. Install Microsoft Sync Framework 2.1 Redistributable Package in the following order:
   - Synchronization-v2.1-x64-ENU
   - Synchronization-v2.1-x86-ENU
   - ProviderServices-v2.1-x64-ENU
   - DatabaseProviders-v3.1-x64-ENU
   - Windows Identity Foundation (Windows6.1-KB974405-x64.msu)
5. Install CLR Types on Application server for SQL Server support of database and data processing machines:
   - SQL CLR Types 2008
   - SQL CLR Types 2012
   - SQL CLR Types 2014
   - SQL CLR Types 2016
6. Enable **Log on as a service** for your user.

**Web Server Prerequisites**

1. Install Microsoft Sync Framework 2.1 Redistributable Package in the following order:
   - Synchronization-v2.1-x64-ENU
   - Synchronization-v2.1-x86-ENU
   - ProviderServices-v2.1-x64-ENU
   - DatabaseProviders-v3.1-x64-ENU
   - Windows Identity Foundation (Windows6.1-KB974405-x64.msu)
2. Install .NET Framework 4.5 or higher.
3. Install IIS with these roles:
   a. **Web Server**
      a. Common HTTP Features
      b. Static Content
      c. Default Document
      d. HTTP Errors
   b. **Application Development**
      a. ASP.NET
      b. .NET Extensibility
      c. ISAPI Extensions
      d. ISAPI Filters
   c. **Health and Diagnostics**
      a. HTTP Logging (recommended, but not required)
   d. **Security**
      a. Windows Authentication (required for eB users to log in with Windows accounts)
Data Processing Prerequisites

1. Install IIS with these roles:
   a. Web Server
      a. Common HTTP Features
      b. Static Content
      c. Default Document
      d. HTTP Errors
   b. Application Development
      a. ASP.NET
      b. .NET Extensibility
      c. ISAPI Extensions
      d. ISAPI Filters
   c. Health and Diagnostics
      a. HTTP Logging (recommended, but not required)
   d. Security
      a. Windows Authentication (required for eB users to log in with Windows accounts)
   e. Management Tools
      a. IIS Management Console

2. Install VC++ 2015 redistributable [(64x) and (86x)].
3. Install Microsoft Sync Framework 2.1 Redistributable Package in the following order:
   • Synchronization-v2.1-x64-ENU
   • Synchronization-v2.1-x86-ENU
   • ProviderServices-v2.1-x64-ENU
   • DatabaseProviders-v3.1-x64-ENU
   • Windows Identity Foundation (Windows6.1-KB974405-x64.msu)
4. Make sure that Default Web Site protocol is running and port :443 (use 54595 if your setup is on a single machine) has a SSL certificate assigned.
5. Install Microsoft ODBC Driver 13 for SQL Server.
6. Install SQLCMDTools.
7. Install .NET Framework 4.7.2 or higher. Restart the computer.

Client Machine Prerequisites

1. SQL Server Express 2014/2016
2. VC++ 2015 redistributable
3. Install Microsoft ODBC Driver 13 for SQL Server.
4. Install Microsoft Sync Framework 2.1 Redistributable Package in the following order:
   - Synchronization-v2.1-x64-ENU
   - Synchronization-v2.1-x86-ENU
   - ProviderServices-v2.1-x64-ENU
   - DatabaseProviders-v3.1-x64-ENU
   - Windows Identity Foundation (Windows6.1-KB974405-x64.msu)

5. Office 2016 (Optional)

Hardware and Software Architecture

Recommended hardware and software requirements for the ConstructSim Planner product suite and the ConstructSim Work Package Server are listed below.

**Note:** If you are using Windows 8 or Windows 10, Windows Identity Foundation is already installed on your system but you need to turn it on. To do this, from the Start menu, go to Program and Features. Click **Turn Windows features on or off**. In the dialog, turn on Windows Identity Foundation.

**File Server**

This is optional if you want to use UNC path for your Application server's file repository. If you use the Distributed File Server replication for file backups, you should set up this server.

- Microsoft Windows Server 2016
- 64 bit, 4 cores
- 16 GB RAM or better
- 500 GB or better

**Application Server Database (1 VM)**

- Microsoft SQL Server 2016 SP1 Standard Edition
- Microsoft Windows Server 2016
- CPU: 64 bit, 4 cores
- 56 GB RAM
- Disk drives:
  - <local drive>: 128 GB
  - <drive>: 500 GB (SSD) — database data files*
  - <drive>: 500 GB (SSD) — database log files*
  - <drive>: 1022 GB — database backups

* If you are creating a large number of projects, you may need 1022 GB.

**Data Processing Database Server**

Two Database Servers: one for the Application Server, and other for the Data Processing Server; two VMs

- Microsoft SQL Server Express 2014 SP1/2016 SP1/2017 (English)
- Microsoft Windows Server 2016
Network, Hardware and Software Architecture

Hardware and Software Architecture

- CPU: 64 bit, 4 cores
- 56 GB RAM
- Disk drives:
  - <local drive>: system 128 GB
  - <drive>: 500 GB (SSD) — database data files*
  - <drive>: 500 GB (SSD) — database log files*
  - <drive>: 1022 GB — database backups

* If you are creating a large number of projects, you may need 1022 GB.

**Note:** For more information on disk partition sizes for SQL Servers, see [Disk Partition Alignment Best Practices for SQL Server](https://docs.microsoft.com/en-us/sql/database-engine/database-file-management/disks) on the Microsoft website.

Web Server (1 VM)

- ConstructSim Work Package Server Web Application
- Internet Information Services (IIS) 7.0 or better
- Windows Identity Foundation
- Microsoft Windows Server 2016
- Microsoft SQL Server 2016 with Reporting Services
- WPS Extensions for SSRS
- Web Services Gateway (WSG) (optional)
- CPU: 64 bit, 4 cores
- 16 GB RAM
- 128 GB
- web browser (Microsoft Internet Explorer is the recommended browser)

**Note:**
If you are using Internet Explorer as your browser, go to **Tools > Compatibility View settings** and make sure the two options, *Display intranet sites in Compatibility View* and *Display all websites in Compatibility View* are off.

Also in the Compatibility View Settings dialog, with the web server address in the **Add this website:** field, click **Add** and make sure the web server address appears in the **Websites you've added to Compatibility View:** list.

Application Server

You can have up to five communities and one project on each.

- Microsoft SQL Server System CLR Types
- Microsoft Sync Framework 2.1 Redistributable Package
- ConstructSim Work Package Server Application Server (eB System Management Console)
- ConstructSim Work Package Server Engines (Excel and Status Visualization)
- Microsoft Windows Server 2016
- 64 bit, 4 cores
- 32 GB RAM
- 500 GB
Data Processing Server (1 VM)

- Command line Utilities for SQL Server 2016
- ConstructSim Planner
- ConstructSim i-model Mapper
- ConstructSim Executive Server
- Internet Information Services (IIS) 7.0 or better
- Microsoft Windows Server 2016
- CPU: 64 bit, 4 cores
- 56 GB RAM
- Disk drives:
  - <local drive>: system 128 GB
  - <drive>: 500 GB (large enough to hold the project files) *

* If you are creating a large number of projects, you may need 1022 GB.

Workface Planner System Requirements

This system is typically a desktop used by the Workface Planner.

- Windows Identity Foundation
- Microsoft SQL Express 2014 SP2 (English) / 2016 SP1 (English)
- Visual C++ Redistributable for Visual Studio 2015
- Microsoft Sync Framework 2.1 Redistributable Package
- ConstructSim Planner
- Windows 8.1 x64 or Windows 10 x64
- 64 bit, 4 cores
- 32 GB RAM
- 256 GB (Solid State Drive)

Data Processing Administrator System Requirements

The administrator system is typically a desktop used by the Data Processing Administrator.

- Windows Identity Foundation
- Microsoft SQL Server Express 2014 SP1/2016 SP1/2017 (English)
- Visual C++ Redistributable for Visual Studio 2015
- Microsoft Sync Framework 2.1 Redistributable Package
- ConstructSim Planner
- ConstructSim Executive Client
- ConstructSim i-model Mapper
- Windows 8.1 x64 or Windows 10 x64
- 64 bit, 4 cores
- 32 GB RAM
- 256 GB (Solid State Drive)
Field User System Requirements

The field system can be a desktop, laptop or tablet used by the ConstructSim Work Package Server web user.

- iOS 10.3, Safari
- Android 6.0.1, Chrome
- Windows 8.1 x64 or Windows 10 x64, Internet Explorer 11 or better
- Microsoft Office 2016 64 bit or Office 365 (optional)

Role Permissions

The minimum required role permissions for the ConstructSim Work Package Server Architecture is as follows:

Application Database Server Permissions
Admin permissions:

- Login Properties > Server Roles > public
- Login Properties > Server Roles > dbcreator
- Login Properties > Server Roles > sysadmin

Data Processing Database Server Permissions

Primary admin (for example, ConstructSim project creator):

- Login Properties > Server Roles > public
- Login Properties > Securables > permissions for <your server> > Create any database

Creator is the owner of the database. Also, creator automatically gets the db_owner fixed role for that database.

In order to support multiple data processing admin personas:

Second admin (for example, anyone who is not ConstructSim project creator):

- Login Properties > Server Roles > public
- Login Properties > User Mappings > select <your database> > db_owner
- Login Properties > Server Roles > dbcreator

Client Systems(s) Permissions (ConstructSim Workstation)

ConstructSim Planner (Local SQLExpress permissions):

- Login Properties > Server Roles > public
- Login Properties > Securables > permissions for <local machine instance> > Create any database
You need to register a CONNECT Project.

To Register a Project

1. Sign in to Bentley CONNECT. The Sign In screen opens.
2. Type your email address (if not automatically populated) and password and click Sign In. The Bentley Cloud Services window opens.
3. Click the Projects tab and click the Register a Project button. The Register a Project page opens.
Pre-Configuring the Environment
To Register a Project

Register a Project
* The number, name, and asset fields are required.

Project Number *

Project Name *

Asset *

Industry *

Type *

Use Location  Use Latitude/Longitude

Engineering Location

Time Zone

Data Center Location

Billing Country *

Status

Active  Inactive

Team Member Management

Allow External Team Members

Register  Cancel
4. Complete the fields based on these descriptions:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Number</td>
<td>Project ID used in the organization for tracking the project internally (for example, the EAP ID, like DMO-063 VP 778)</td>
</tr>
<tr>
<td>Project Name</td>
<td>Common name for the project within the organization (for example, I-565 Interchange at County Line Road)</td>
</tr>
<tr>
<td>Asset</td>
<td>The AssetWise instance; once connected, AssetWise is accessible directly from the CONNECTION Center</td>
</tr>
<tr>
<td>Industry</td>
<td>The industry to which the project belongs such as, Roads and Highways, Rail and Transit, Buildings and Facilities, etc.</td>
</tr>
<tr>
<td>Type</td>
<td>Based on the Industry chosen</td>
</tr>
<tr>
<td>Use Location or Latitude/Longitude</td>
<td>For location, enter the location name in the field below</td>
</tr>
<tr>
<td>Engineering Location</td>
<td>Location of the project</td>
</tr>
<tr>
<td>Time Zone</td>
<td>Time zone of the project location</td>
</tr>
<tr>
<td>Data Center Location</td>
<td>If the project will be used for any of the CONNECT Services, you will need to select the location. Upon selection an information dialog opens that explains the locations of the different data centers and how they relate to each service</td>
</tr>
<tr>
<td>Billing Country</td>
<td>Location of the billing organization</td>
</tr>
<tr>
<td>Status</td>
<td>Active/Inactive</td>
</tr>
<tr>
<td><strong>Note:</strong> Setting a Project to Inactive hides it from view. If you wish to locate it at a later time, turn on &quot;Include Inactive&quot; when searching projects</td>
<td></td>
</tr>
<tr>
<td>Team Member Management</td>
<td>When Allow External Team Members is on, you can invite team members outside of your organization as long as their organization is known to Bentley Systems.</td>
</tr>
</tbody>
</table>

5. When all fields are defined, click **Save**. After saving, you are taken to the portal of your newly-created project.
To set up the configuration for the WPS database, install Microsoft SQL Server 2016 Standard Edition or better. Then you need to set the SQL server properties and create a database.

To Set the Microsoft SQL Server Properties

2. In the Object Explorer pane, select the server, right-click and select Properties. The Server Properties dialog opens.
3. In the Select a page pane, click Security.
4. In the Server authentication section, turn on SQL Server and Windows Authentication mode.
5. Click OK to exit the Server Properties dialog.
6. From the Control Panel, select Administrative Tools > Component Services.
7. In the left pane of the Component Services window, select the Services (Local).
8. From the list of Services in the middle pane, select SQL Server (MSSQLSERVER).
9. From the Actions pane, expand More Actions.
10. Click Restart.
11. When the SQL Server starts again, close the Component Services window.

To Create a Database

1. Connect to your eB database machine.
WPS Database Pre-Configuration
To Modify the Database to Support SNAPSHOT_ISOLATION

2. Open SQL Server Management Studio.
3. Create a database with logical name (examples: wpsbuild872, wpsfullbgr).
4. Run the script To Modify the Database to Support SNAPSHOT_ISOLATION (on page 17) to support SNAPSHOT_ISOLATION.

To Modify the Database to Support SNAPSHOT_ISOLATION

1. Go to the Start menu > All Programs > Microsoft SQL Server 2016 > SQL Server Management Studio and in the dialog that opens, connect to the server.
2. In the Object Explorer pane, right-click Databases and from the pop-up menu, select New Database.
   The New Database dialog opens.
3. In the Database name, enter a logical name for the new database.
4. Click OK to create the new database.
   The new database is created and is located under the Databases node in the Object Explorer.
5. Select the new database you created and from the toolbar, click New Query.
6. In the new query window, enter the command: ALTER DATABASE [new database name] SET ALLOW_SNAPSHOT_ISOLATION ON.
7. Click Execute to run the query.
   The "Command(s) completed successfully" message appears. The database now supports SNAPSHOT_ISOLATION.
8. Go to Security and right click on Logins. Enter Bentley\ and the user name, which you will use for future setups. You can use your Bentley login or default. Regarding the default login, talk to the Administrator of the environment you are using. If you setup a local project, it is in your account.
Configuring the ConstructSim Work Package Server Application Server

To Pre-Configure the ConstructSim Work Package Server Application Server

Microsoft .NET Framework 4.5 or higher should be installed.

1. To Change User Account Control Settings (on page 19).
2. Turn on Remote Connection for Domain Users. (Go to Control Panel > System > Remote settings to open the System Properties dialog. Open the Remote tab and in the Remote Desktop section, turn on Allow remote connections to this computer and click OK.)
3. Configure Windows Firewall. Your on-site IT group should handle this setup.
4. Add your domain user to Administrator group on your machine. (Go to Control Panel > Administrative Tools > Computer Management. In the Computer Management dialog, expand Local Users and Groups and select Groups. In the middle pane, double-click Administrators. In the Administrators Properties dialog, click Add to add your domain user and then click OK.)
5. From the Microsoft website, install Microsoft Sync Framework 2.1 Redistributable Package in the following order:
   1. Synchronization-v2.1-x64-ENU
   2. Synchronization-v2.1-x86-ENU
   3. ProviderServices-v2.1-x64-ENU
   4. DatabaseProviders-v3.1-x64-ENU
   5. Windows Identity Foundation (Windows6.1-KB974405-x64.msu):
      • Microsoft Windows Server 2012 - install through the Windows Server Roles and Features wizard.

<table>
<thead>
<tr>
<th>Version</th>
<th>Go To</th>
</tr>
</thead>
</table>
To Change User Account Control Settings

This procedure only applies to the Data Processing Server(s).

1. Select Control Panel > All Control Panel Items > User Accounts > Change User Account Control Settings to open the Change User Account Control Settings dialog.
2. Change the setting to Never Notify.
3. Click OK to accept the changes.
4. Restart the computer to apply the changes, if required.

To Configure the ConstructSim Work Package Server Application Server

1. Install the CLR Types.
2. Install the ConstructSim Work Package Server Application Server.
Use the default options. This also installs the eB System Management Console. Use the eB Domain username and password when prompted during installation.

3. Install the ConstructSim Work Package Server Engines:
   1. Excel Import Engine
   2. Work Package Publish Engine
   3. Status Visualization Processing Engine

4. Install eB Director.

5. To limit direct log in to the Application Server Database and eB Application Server machines, it is recommended that all access be done from the Data Processing Server. The eB System Management Console is used to set up the following components for the ConstructSim Work Package Server:
   - datasource
   - community
   - storage
   - repository
   - work queue services
   - engines

   This console is installed on the eB App Server and Data Processing Server (through the Engines install).

You will use the eB Application Server, the one not set to [local], for all subsequent actions.

6. Use the eB System Management Console to set up the following components of the ConstructSim Work Package Server. To open the eB System Management Console, select Start > All Programs > Bentley > eB > eB System Management Console.
   1. create a datasource
   2. create a community
   3. create storage
   4. create a repository
   5. configure work queue services
   6. register engines

To Create a Datasource

1. Open eB System Management Console (Start > Bentley > eB System Management Console).
2. In the Explorer pane, under the Servers node, expand your server.
3. Right-click the Data Sources node and select Add DataSource.
   ![Image of Add DataSource dialog]
4. When Datasource Wizard opens, click Next.
5. On the **Select Database Type** page, select the **Microsoft SQL Server** driver and click **Next**.
Configuring the ConstructSim Work Package Server Application Server
To Create a Datasource

6. On the Select Server page, in the Database Server field, enter the eB Data Processing machine’s name, or you can select (Local), if the server is on your local machine or you can pick from the drop-down list or enter the server domain.

7. On the Login Information page, enter the user name and password of the database account used to log in to the selected SQL Server instance, or if database account is a Windows account select Use Windows Authentication, and click Next.

   **Note:** It is recommended that you use the public DNS name of the App Server Database.

8. On the Select Database page, select the database you created for eB and click Next.

9. On the eB Data Source Name page, enter a name for the new eB datasource and click Next.

![Datasource Wizard](image)

The name of the selected database is automatically supplied as the default name for the datasource. You can keep these names the same, or you can enter a new name for the datasource.

   **Note:** It is recommended that you only use letters and numbers in the datasource name, and that you do not use any special characters. While it is best to avoid all special characters, these characters in particular are known to cause problems:

   % . _ < >

11. On the **Finished** page, click **Close**.

The new datasource is added under the **Data Sources** node.
12. Select the new datasource.

A dialog opens to inform you that the database used by this datasource needs to be updated.

13. Click Yes.

The datasource expands in the Explorer pane with the Database Scripts item already selected.

In the content pane, the Core database package is already selected.

14. In the content pane, in the Update Status section, click the link, Click to Start the Database Update.

15. When the database update is complete, click OK.

Note: The database update creates a log file which you can review by expanding your datasource in the Explorer pane and selecting Database Logs. There should be no error messages in the log file. If upgrading, error
messages may be expected due to the nature of the upgrade. If you are not sure what the error message means, file a service ticket at http://selectservices.bentley.com/.

**Note:** You can select a datasource and click the Test Connection icon on the toolbar to verify the connection to the database. If the system fails to connect to the datasource, double-check that you are using the correct server name, database name, user name and password. If not, return to step 1 of this procedure and redo this process.

### To Create a Community

1. Open eB System Management Console (Start > All Programs > Bentley > eB > eB System Management Console).
2. In the Explorer pane, expand Servers > your_server.
3. Right-click Communities and select Add Community.

The New Community Properties dialog opens.
4. From the **Application Server** list, enter or select the name of the computer on which Application Server is installed.

5. From the **Datasource** list, select the name of a datasource running on the server selected in the **Application Server** field.

6. From the **Site** list, select the name of the ConstructSim Work Package Server website running on the server selected in the **Application Server** field, usually it is Main.

7. Click **OK**.
   The Community Login dialog opens for you to log in to the selected datasource.
8. Enter the credentials of the default eB administrator account (ADMIN / ADMIN) and click **OK**. The new community is added under the Communities node.

**Note:** After you finish working in eB System Management Console, it is recommended that you change the password for the default administrator account in eB Director. After changing this password, you will need to return to eB System Management Console, change the saved password for this community, and restart the Service Manager.

---

**To Create a Storage Device**

1. In the eB System Management Console (**Start > Bentley > eB System Management Console**) Explorer pane, click the + sign next to the server name to expand the contents.
2. Click **Storage** to show the list of storage devices and the communities served by the devices.
3. From the main menu, click **Storage > Add Device**.
   The New Device Properties dialog opens.
4. In the Name field, enter a logical name.
   The Description field is optional.
5. From the Driver drop-down list, select **Windows File Driver**.
6. From the Speed drop-down list, select **Fast**.
7. In the Root Access field, type the root location.
8. Click OK to exit the New Device Properties dialog.

**Note:** If the checkbox is not already checked, turn on the Community that will be using the storage devices in the Communities Served section. If prompted, enter the credentials of the default eB administrator account (ADMIN / ADMIN) and click OK. The storage device is now added to the Community.

---

**To Create a Repository**

1. Select the storage device that you created.
   This shows the repositories that are being used on the device.
2. Right click the newly-created storage and select Add Repository.
   The New Repository Properties dialog opens.
To Configure the Work Queue Service

1. In the Explorer pane, expand **Servers > your server**.
2. Select the **Work Queue** node.
3. In the Communities Served list, check the check box next to your community.
4. Log in to the community if prompted use ADMIN / ADMIN.
   The Properties dialog opens.
5. Turn on Generic, Bulk Transaction, Asynchronous Automation, External File Copy, and Copy Object.
To Configure a Secure Connection in the eB Application Server

1. In the eB System Management Console Explorer panel, expand **Communities**.
2. Select the Community you created.
   - The Main Site schema displays in the right side window.
3. Select the Connection arrow (red arrow) from the schema, right click and from the menu select **Properties**.
4. In the **Connection info** field, enter the WPS Application server Bentley certificated domain:
   - If using HTTPS as the SSL required proper name; for IMS use: DNS + domain.com.
   - If using HTTP connect and the eB login, then enter DNS.
5. Click OK.
6. Follow the same steps for the Publish Engine Data Processing machine connection.
To Register the Engines

1. Open the eB System Management Console (Start > All apps > Bentley > eB System Management Console) and expand your server’s node.
2. In the Explorer tree, expand Communities, and then expand your project node.
3. Click Engines. A list of engines displays in the top right pane.
4. Select the Excel Import Engine and then click the Manage Server Registration icon or select Engines > Manage Server Registration.
5. In the Engine <name of engine> servers dialog that opens, click Add and select the server from the list. Click OK and Close.
6. (Optional) If you will use Status Visualization, repeat steps 4 and 5 for the Status Viz Processing Engine.
7. (Optional) If you plan to publish work packages, repeat steps 4 and 5 for the Work Package Publish Engine.

To Configure Mail Distribution

1. Open the eB System Management Console (Start > All Programs > Bentley > eB > eB System Management Console) and expand your server’s node.
2. In the Explorer tree, click Mail Distribution.
3. In the Communities Served list, turn on the check box next to your community.
To Turn off Audit for the Document and Tag

1. Open the eB System Management Console (Start > All Programs > Bentley > eB > eB System Management Console) and expand your server’s node.
2. In the Explorer tree, expand Communities, and then expand your project node.
3. Click Audit Trail.
4. Select Document and uncheck Changed, Deleted, Purged. Save the changes.
5. Select Tag and uncheck Changed, Deleted, Purged. Save the changes.

To Add a Certificate to the App Server

1. Open the eB System Management Console and in the Explorer pane, navigate to **Servers > your server > Service Manager**.
2. In the right pane, click the **Ssl** tab.
   
   The certificate that is configured for the SSL port (443) displays.
3. If no certificate is currently configured for the SSL port (443), click **Configure Ssl**. A list of available certificates displays.
4. Select a SSL certificate for port 443 and click OK.

**To Check the Domain of eB Services**

All eB Services should be running under a domain account, not a local account.

Use the following procedure to make sure that all eB Services are running under a domain account.

1. Open eB System Management Console (**Start** > **All Programs** > **Bentley** > **eB** > **eB System Management Console**).
2. In the Explorer pane, expand **Servers > <your server>** and click **Service Manager**. The Services tab shows a list of all the eB Services.
3. Make sure that the Log On as column shows a domain account (and not a local account).
4. If the password for the Service user changes, make sure to change the password for the eB services also.

**To Change/Update the Administrator Account Password**

1. To **change the administrator account password**, open eB System Management Console (**Start** > **All Programs** > **Bentley** > **eB** > **eB System Management Console**).
2. In the Explorer pane, expand **Servers > <your server>** and select the Communities node.
3. In the Communities list, right-click your community and select Properties.
4. In the Community Login Information section, change the password and click OK.
5. In the Explorer pane, select the Service Manager node and restart eB Service Manager.
You can also restart the eB Service Manager by going to Start > Control Panel > Administrative Tools > Services. Right-click eB Service Manager and from the menu select Restart.

6. Log in to eB Director to confirm the password change was made.

7. To update the administrator account password, restart the eB Service Manager by going to Start > Control Panel > Administrative Tools > Services. Right-click eB Service Manager and from the menu select Restart.
Configuring the Web Server

To Pre-configure the Web Server

1. Install Microsoft Sync Framework 2.1 Redistributable Package feature:
   - Synchronization-v2.1-x64-ENU
   - DatabaseProviders-v3.1-x64-ENU
2. Turn on Remote Connection for Domain users.
3. Make sure that Default Web Site protocol is Started. To do this, go to Control Panel > Administrative Tools and double-click Internet Information Services (IIS) Manager. The Internet Information Services (IIS) Manager window opens.
4. In the Connections pane, under the ConstructSim Work Package Server Web Server name, expand the list.
5. Expand the Sites list.
6. Start the Default Web Site protocol:
   - Right-click on Default Web Site and from the right-click menu, Manage Web Site > Start.
   - or
   - Select the Start command at the right side panel in the Manage Web Site pane.
To Configure the SQL Server Reporting Services Component on the Web Server

SQL Server Reporting Services requires that IIS APPPOOLDefaultAppPool have additional privileges. If this is not configured, you get this error when you select any hosted report:

*The permissions granted to user 'IIS APPPOOLDefaultAppPool' are insufficient for performing this operation. (rsAccessDenied)*

1. From the Start menu, open the Internet Information Services (IIS) Manager.
2. In the Connections pane, click **Application Pools**.
3. In the Application Pools pane (right), double-click **DefaultAppPool**.
   The Edit Application Pool dialog opens. The Name field is not editable.
4. Set the following fields as below:

<table>
<thead>
<tr>
<th>.NET Framework version</th>
<th>.NET Framework V2.0.50727</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managed pipeline mode</td>
<td>Integrated</td>
</tr>
<tr>
<td>Start application pool immediately</td>
<td>On (the default)</td>
</tr>
</tbody>
</table>

5. Click **OK** to close the Edit Application Pool dialog.
6. In the Application Pools pane, right-click DefaultAppPool and select **Advanced Settings**.
   The Advanced Settings dialog opens.
7. In the Process Model section, click the drop down button in the Load User Profile field and set this option to True.
8. In the same section, click the browse button on the Identity field. The Application Pool Identity dialog opens.
9. Select Custom account and click Set. The Set Credentials dialog opens.
10. Add the User name and password and confirm the password. The custom account information displays in the Identify field of the Process Model section.
11. Click OK to close the Advanced Settings dialog.

To Configure the ConstructSim Work Package Server

Before setting up the ConstructSim Work Package Server, open the Server Manager and navigate to Manage > Add Roles and features > Server Roles > Web Server (IIS). Scroll down to the Role Services and check if the following roles are installed:

- Web Server
  - Common HTTP Features
    - Static Content
    - Default Document
    - HTTP Errors
  - Application Development
    - ASP.NET
    - .NET Extensibility
    - ISAPI Extensions
    - ISAPI Filters
  - Health and Diagnostics
    - HTTP Logging (recommended, but not required)
  - Security
    - Windows Authentication (required for eB users to log in with Windows accounts)
  - Management Tools
    - IIS Management Console

1. Install WPS Extensions for SSRS (x64).
2. If the instance name (Administrators Tools> Services SQL Server (<instance name> ) is NOT the default (MSSQLSERVER), install WPS Extensions for SSRS (x64) using the command prompt with optional parameter.
   1. Open the command prompt and enter: msiexec /I "optional\path\to\WPS Extensions for SSRS (x64) (x??).msi" EB_REPORTINGSERVICES_INSTANCENAME=SQLInstanceName. For example, msiexec /I "C:\Users\Administrator\Desktop\WPS Extensions for SSRS (x64).msi " EB_REPORTINGSERVICES_INSTANCENAME=WPSSQL2012SP1
   2. Run the command.
   3. Complete the steps in the Setup Wizard.
3. Install the ConstructSim Work Package Server Web application.
4. Click Start > All Programs > Bentley > eB > eB Web Manager.
5. In the eB Web Application Manager dialog, select File > New Web to create a new web interface.

The Edit Web dialog opens.
6. In the Application Server field of the eB Server tab, enter certificated domain (APP machine) and click Connect.
7. Go to the Application tab and enter the following:

- In the Name field, enter the site name.
Configuring the Web Server
To Configure the ConstructSim Work Package Server

**Note:** Site address should be certified for IMS.

- In the Folder location field, enter `c:\inetpub\wwwroot`.
- From Application pool drop-down select DefaultAppPool.

8. Open the Authentication tab.

   - From the Authentication Provider drop-down, select Bentley IMS.
   - Enter the Realm URI; this is your WPS website URL.
   - Add the Audience URIs (enter your website URL).

9. Click the Functionality tab and turn on Work Packaging Services and eB Document Manager.
10. At the bottom of the dialog, click the **Ready to install (click here to start)** link. When finished, an alert tells you that deployment is complete.

11. If you are using Internet Explorer as your browser, do the following:
   - In Internet Explorer, go to Tools > Compatibility View settings.
   - Make sure the two options, **Display intranet sites in Compatibility View** and **Display all websites in Compatibility View** are on.
   - **Compatibility View** is off. (The Display all websites in Compatibility View option is not present in Internet Explorer version 11).

### To Register the Domain and URL for IMS

1. Follow the instructions in the procedure [To Register a Product to the IMS Environment](on page 43).
2. Log a help ticket to Bentley to register your domain and URL in IMS.
3. Make sure your internal authentication supports IMS.
4. Make sure you register all the URLs that you will use to connect to WPS Web.
5. Make sure to register all domains, which users would be using (see example).

---

You are originally from **Company1**. Your domain is company1.com.

Your active users would be from a couple of companies, who have their own company’s credentials:

User1@Company1.com, user2@company2.net and user3@company3.com

You want them to have permission to your WPSConstructSim Work Package Server Web and work with ConstructSim Planner.

You have two options:
1. Create accounts for user2 and user3 in your company1.com domain, then you do not need to register the other two domains.
2. Register all three domains in the Bentley IMS system.

To Register a Product to the IMS Environment

Registration

To register the product, follow these steps:

1. File a help request. ConstructSim Work Package Server (CWPS) needs to be registered to either the qa environment or the production environment for Relying Party identification.
2. Prepare a spreadsheet with required information and add it to help request. You should list all web sites you want to register to IMS and also URLs for desktops or mobile clients. See this example (change just the yellow entries).

   **Note:** URLs listed in this spreadsheet are already registered to the qa environment and production environment.

3. After registration you should:
   - create an eB user with your email
   - ensure that you can login to the registered WPS Web via the qa environment or production environment (depends on where you registered)
   - add your URL to registered URLs sheet.

Additional Information

Go to the Bentley site for more information about registration. See the „Relying Parties in IMS“ excel file and „Terminology and Examples“ sheet.

To Configure the Default Web Site for Permissions

1. From the Internet Information Services (IIS) Manager Connections pane, expand Default Web Site and then the project folder.
2. Right-click on App_Data.
3. From the pop-up menu, select Edit Permissions.
4. In the App-Data Properties dialog, open the Security Tab.
5. Click Edit.
   The Permissions for App_Data dialog opens.
6. Highlight the IIS_IUSRS account.
7. From the Permissions window, turn on the Write option.
8. Repeat these steps for any additional WPS Web Sites / Virtual directories.
To Set Security Updates for SSRS Support

1. Launch Windows Explorer and go to C:\Windows\System32\inetsrv\config.
2. In the Config folder, right-click and select properties.
3. Select the Security Tab, than select Edit.
4. Select Add and type the NETWORK SERVICE account and select check name.
5. Once the NETWORK SERVICE account has been added, change the security settings.
6. Toggle on all available permissions.
7. Apply permissions and exit accepting thr changes.

**Note:** There may be warning/error dialogs stating that certain files or folders cannot be modified. Dismiss the dialogs.

To Configure the Web Server for a Secure Connection

To configure the Web Server for a Secure Connection, you need to add a HTTPS certificate through the Internet Information Services (IIS) Manager.

1. From the Start menu, open the Internet Information Services (IIS) Manager.
2. In the Connections panel, navigate to the server name > Sites > Default Web Site.
3. Right-click and from the pop-up menu, select Edit Bindings. The Site Bindings dialog opens.
4. In the Site Bindings dialog, click **Add**. The Add Site Binding dialog opens.
If the https binding already exists, click Edit and verify if the certificate is correct and has no errors by pressing the View button.

5. In the Add Site Binding dialog, change Type to https.

6. Leave the default IP address to All Unassigned.

7. From the drop-down menu, select the SSL certificate.
   If you want to see the certificate, click View.

8. Click OK to close the Add Site Binding dialog.

9. If you get a warning message about overriding the current binding, click Yes.

10. Close the Site Bindings dialog.

11. Check the Authentication option in the Default Web Site. Only Anonymous Authentication should be Enabled.

12. In Internet Information Services (IIS) Manager, click SSL Settings.

13. Turn on Require SSL.

You now have a secure connection for your web server.
To Configure the SQL Reporting Server

1. From the Start menu, navigate to Microsoft SQL Server 2016 > Configuration Tools > Reporting Services Configuration Manager.
2. In the Reporting Services Configuration Connection dialog, verify the Server Name and select the Report Server Instance.
3. Click Connect to connect to your server.
4. Additional security is defined through the SQL Server Reporting Services Site Settings. Make sure the service account is NETWORK SERVICES in SERVICE ACCOUNT.
   
   **Note:** When changing a service account, the system asks you to create an encryption key. Make sure to save it and check password requirements. An example for a password: Q!w2e3r4.

5. In the left-hand pane, select Report Manager URL. The Report Manager URL page displays for HTTP and HTTPS. If not, add URLs through Advanced settings. Make sure the URL displays the correct server DNS. The same applies to the Web Service URL tab.
   
   **Note:** These links can be used when setting up the ConstructSim project to enable reporting services.

6. Navigate to the Database tab and verify that the SQL Server name is correct. If needed, change the database.
7. Make sure that all links works. If something is wrong, verify that the Web server is working correctly.
8. Navigate to the Execution Account tab and specify the user which you are using for the ConstructSim Executive Client.

To Set Up Site Settings Security

Additional security is defined through the SQL Server Reporting Services Site Settings.

2. From the top right corner of the SQL Server Reporting Services Home page, click Settings > Site Settings.
3. From the left pane of the Site Settings window, click Security.
4. To add folder security for specified users, in the menu bar, click Add group or user.
5. In the New System Role Assignment window, type in the group or user name.
6. Select a role(s) for the group or user and click OK. The Site Settings window displays the new group or user and the role assigned.
7. Return to the Home page and add the same users/groups to Folder Settings > Security.
8. Exit the SQL Server Reporting Services window.

To Set Up to View Progress Reports

Once you have set up a person, project and permissions for a Windows-authenticated user, you can set up the SQL Server Reporting Services Configuration Manager to view progress reports in the ConstructSim Work Package Server.

1. Go to Start > All Programs > Microsoft SQL Server 2016 > Configuration Tools > Reporting Services Configuration Manager.
   The Reporting Services Configuration Connection and Reporting Services Configuration Manager dialogs open.
2. In the Reporting Services Configuration Connection dialog, type the Server Name (if not already displayed) and from the Report Server Instance drop-down, select the report server. Click Connect.
3. In the Reporting Services Configuration Manager dialog's Connect pane, click Report Manager URL. Two URLs display.
   4. Click the second URL. The SQL Server Reporting Services Home page opens in your browser.
5. On the home page, click the datasource you created. Engineering Quantities, Project Scorecards, Work Packaging, and your Community display on the home page.
7. In the Credentials section, turn on Using the following credentials and enter Admin/Admin.
8. Click Apply.
9. Repeat the same for the -DP datasource.
10. Close the browser window.
11. Close the Reporting Services Configuration Manager.
    You are now able to view progress reports in the ConstructSim Work Package Server.

To Set Full Permissions for SSRS User

1. Go to C:\Windows\System32\inetsrv.
2. Right-click on **Config > Properties > Security > Edit > Add**.
3. Type the user who is running SSRS.
4. Turn on Full Control.
5. Save.
WPS Data Processing Server Pre-Configuration

1. IIS is installed with these roles:
   - Web Server
     1. Common HTTP Features
     2. Static Content
     3. Default Document
     4. HTTP Errors
   - Application Development
     1. ASP.NET
     2. .NET Extensibility
     3. ISAPI Extensions
     4. ISAPI Filters
   - Health and Diagnostics
     1. HTTP Logging (recommended, but not required)
   - Security
     1. Windows Authentication (required for eB users to log in with Windows accounts)
   - Management Tools
     1. IIS Management Console

2. Install VC++ 2015 redistributable [(64x) and (86x)].

3. Install Microsoft Sync Framework 2.1 Redistributable Package in the following order:
   a. Synchronization-v2.1-x64-ENU
   b. Synchronization-v2.1-x86-ENU
   c. ProviderServices-v2.1-x64-ENU
   d. DatabaseProviders-v3.1-x64-ENU
   e. Windows Identity Foundation (Windows6.1-KB974405-x64.msu)

4. Make sure Default Web Site protocol is running and port :443 (use 54595 if your setup is on a single machine) has SSL certificate assigned.

5. Install Microsoft ODBC Driver 13 for SQL Server.

6. Install SQLCMDTools.

7. Install .NET Framework 4.7.2 or higher.

8. Restart the computer.
To get started, download and install the following products:

1. ConstructSim Executive Server
2. ConstructSim Planner

**ConstructSim Executive Server Installation**

1. Double-click the server installer to open the ConstructSim Executive Server Setup Wizard.
WPS Data Processing Server Configuration
ConstructSim Planner Installation

2. Click Next and specify the server installation location.
3. Click Next and choose the ConstructSim Work Package Server installation location.
4. Click Next and enter User credentials on which the service will be run, then click Next.
5. Insert the WPS API port that the Server will use (usually 443).
6. Insert the name of the server and WPS API database name, where the WPS API database will be stored.
7. Click Install.

ConstructSim Planner Installation

From the Bentley Software Fulfillment Center, download the latest version of ConstructSim Planner. Double-click the installer. Check the box to accept the End User License Agreement and click Install. Follow the Setup Wizard instructions.

ConstructSim Planner installs Connection Client version 10.00.14.18.

To Set Up the Licensing Server

1. Open the Connection Client and update it to the latest version (at least 10.00.17.10 or higher).
2. Launch a command line.
3. Go to the location where the licensing service is installed, for example: C:\Program Files\Common Files \Bentley Shared\CONNECTION Client\LicService.
   If you want to specify ports use [-port1:port1number] [-port2:port2number], if not they will be selected automatically.
5. Log in with your IMS user and close the log-in window.
6. Go to the Bentley Activation Wizard.
7. Select Register Server and click Next.
8. In the Machine Name field, enter the Data Processing server name.
9. Select United States in Country field and click Next.
10. Add Product ConstructSim Executive to the list and click Next.
11. Click Close.

To Run EncryptWebConfig.ps1 PowerShell Script

The script should be run in Administrator mode with following arguments:

<table>
<thead>
<tr>
<th>Argument</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>path</td>
<td>directory of web.config file to encrypt. Directory is checked recursively for all web.config files.</td>
</tr>
<tr>
<td>settingsFile</td>
<td>(optional) path to deployment scripts settings file. CertificateName property must be defined for the script to find the machine certificate for encrypting. Either settingsFile or certificateName property must be passed.</td>
</tr>
<tr>
<td>userToEncrypt</td>
<td>(optional) user name to encrypt. If not passed, takes RBACUser node from web.config file. Should be passed in plaintext (either as a parameter or in web.config file).</td>
</tr>
</tbody>
</table>
passToEncrypt | (optional) password to encrypt. If not passed, takes RBACPassword node from web.config file. Should be passed in plaintext (either as a parameter or in web.config file).

certificateName | (optional) certificate name to encrypt with. To check your machine’s certificate name, see Finding machine’s certificate name.

Example of running the script:

```powershell
& \EncryptWebConfig.ps1 -path "C:\inetpub\ConstructSim Executive Server" -settingsFile ..\settings.txt -userToEncrypt "CSIM-ServiceIdentity-Qa@bentley.com" -passToEncrypt "LxmH_kyhwB4Q?DaD"
```

The script goes through every web.config file in the given directory, and sets RBACUser and RBACPassword nodes to the encrypted values.

Known issues/errors:

1. Invalid settings file — Make sure the settings file is in the given path.
2. Settings file’s certificateName property is null or empty — Make sure the settings file has a certificateName property set.
3. RBACUser or RBACPassword node not found in <path> — Make sure web.config file has RBACUser and RBACPassword nodes defined. In case the file should not have the nodes, it will be skipped.
4. Unable to save web config in <path> — Make sure you have write access to the web.config file (Administrator mode is advised).
5. Failed to get certificate. Certificate is not found or expired — Open the local machine certificate store and check if a certificate with the name of the certificateName property in settings.txt file is under Personal/Certificates and has not expired.
6. Passed string is null or empty — Make sure that the userToEncrypt and passToEncrypt parameters are passed as parameters or defined as plain text in web.config file.

To Find System Certificate Names

1. **To Make the System Certificate Accessible on the Current User** (on page 53).
2. Go to **Personal > Certificates**.
   You should see a Server/Client Authentication certificate issued by Bentley-Internal-CA. Its “Issued to” name is used in the encryption scripts.

   **Note:** Passed names should not contain regex escape characters such as ‘\’, ‘\*’, ‘\?’ in case the actual certificate name contains the characters (for example, “*@bentley.com”), a substring without the characters should be passed (for example, “.bentley.com”).

To Make the System Certificate Accessible on the Current User

You need to open the local machine certificate store.

1. Open the Local machine certificate store:
   - by typing **Manage computer certificates** in the search bar
or
by using mmc snap-in

2. If using mmc snap-in, do the following
   1. Execute Microsoft Management Console (mmc.exe).
   2. Click File > Add/Remove Snap-in (<Ctrl+M>).
   3. From the available snap-ins list, select Certificates and click Add.
   4. From the Certificates snap-in dialog, select Computer account and click Next.
   5. Select Local computer and click Finish.
   6. Click OK.

To Add the Current User to The Certificate User Group

1. Open Certificates (Local Computer) > Personal > Certificates menu.
2. In the right pane, right-click on the machine certificate and select All Tasks > Manage Private Keys.
3. In the Group or user names panel, click Add.
4. In the Enter the object names to select field, type in the account that is running WPS.API site and click Check Names.
5. After the account has been found, click OK.
6. Click OK.

To Configure the ConstructSim Executive Server for Secure Connection

To configure the Web Server for a Secure Connection, you need to add a HTTPS certificate through the Internet Information Services (IIS) Manager.

1. From the Start menu, open the Internet Information Services (IIS) Manager.
2. In the Connections panel, navigate to Server name > Sites > Bentley.WPS.Api.
3. Right-click and from the pop-up menu, select Edit Bindings.
   The Site Bindings dialog opens.
4. In the Site Bindings dialog, click Add.
   The Add Site Binding dialog opens.
5. If HTTPS binding already exists, click Edit and verify if the certificate is correct and has no errors by pressing the View button.
6. In the Add Site Binding dialog, change Type to https.
7. Leave the default IP address to All Unassigned.
8. From the drop-down menu, select the SSL certificate.
9. To see the certificate, click View.
10. Use port 443 (unless you setup WPS Web on the same machine, then use port 54595).
11. Click OK to close the Add Site Binding dialog.
12. If you get a warning message about overriding the current binding, click Yes.
13. Close the Site Bindings dialog.
14. Check the Authentication option in the Default Web Site. Only Anonymous Authentication should be Enabled.
15. In Internet Information Services (IIS) Manager, click SSL Settings.
16. Turn on Require SSL.
WPS Data Processing Server Configuration
To Configure the ConstructSim Executive Server for Secure Connection

You now have a secure connection for your web server.
Client Machine Pre-requisites and Configuration

Prerequisite: Visual C++ Redistributable for Visual Studio 2015

Install the following applications:

- ConstructSim i-model Mapper CONNECT Edition
- ConstructSim Planner CONNECT Edition Update 3
- ConstructSim Executive Client

To Install the ConstructSim Executive Client

1. Double-click the installer to open ConstructSim Executive Client installer window and click Next.

2. Accept the terms of the End-User License Agreement and click Next.
3. Select the location where to install the CONNECTION client and click Install. (This window only displays if CONNECTION Client is not already installed on the machine.)
4. Select the location for the Executive Client and click Next.
5. In the Ready to install ConstructSim Executive Client window, click Install.

6. When the installation finishes, close the installer window. The installation is complete.
Client Machine Pre-requisites and Configuration
To Install the ConstructSim Executive Client

7. Launch the Connection Client and login with your account information.
8. Launch the ConstructSim Executive Client.

- If CONNECTION Client is running and the user is logged in there, then login to ConstructSim Executive Client happens automatically and you will see your username next to Logged in as.

- If CONNECTION Client is running and the user is not logged in there, then the ConstructSim Executive Client Login dialog appears.
To Create a Stored Procedure

2. Add the query that you want to get executed and any parameters, if needed.
3. On Data Processing SQL Server, select `WantedDb-DP` and execute the stored procedure so that it is created.
4. Verify that the stored procedure is created in the Data Processing database.
To Run a Stored Procedure

1. In ConstructSim Executive, open the project.
2. Right-click the desired node and select Add Command.
3. Select the Managed Command **Run SQL-DP Stored Procedure** and click OK.
4. Rename the Managed Command (for example: Run SQL-DP Stored Procedure - sp_Example_Stored_Procedure).
5. Expand the Properties section and in the SPNAME field, add the name of the stored procedure in brackets, for example: [sp_Example_Stored_Procedure].
6. Click OK to save the modified custom Managed Command.
To Create a ConstructSim Executive Project

1. From the Client machine, open ConstructSim Executive. In order to create a project, you need to launch it with a CMD with the parameter /ProjectSetup. Login is handled by the Connect Client. Notice when Connect
Client is being launched and log in there. If Connect client is running and the user is logged in there, login to the Client admin happens automatically and you will see your username in the upper right corner of the ConstructSim Executive window.

2. In the Project dialog, click Create.

3. Complete the Project Setup Wizard's Project, WPS and SSRS sections.

4. Under Project section, complete the following:

<table>
<thead>
<tr>
<th>WPS Application server</th>
<th>FQDN of the Application server</th>
</tr>
</thead>
<tbody>
<tr>
<td>Community</td>
<td>Community name for the new project. Drop-down is disabled if there is only one community on the eB Server</td>
</tr>
<tr>
<td>Project Name</td>
<td>The name you would like for your project</td>
</tr>
<tr>
<td>WP Mode</td>
<td>Choose the work package handling mode: CWP-IWP or IWP Only</td>
</tr>
<tr>
<td>Project Template</td>
<td>Standard Template from the drop down list</td>
</tr>
<tr>
<td>eB Credentials</td>
<td>admin/admin – this user will be used by the server for data processing</td>
</tr>
</tbody>
</table>

5. Under WPS section, complete the following:

<table>
<thead>
<tr>
<th>WPS Website</th>
<th>web address of your WPS website</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server and WPS Database</td>
<td>fields are populated and hardcoded</td>
</tr>
<tr>
<td>SQL Server Mirror</td>
<td>optional</td>
</tr>
<tr>
<td>Use Windows Authentication</td>
<td>Check everywhere in the Project Setup Wizard</td>
</tr>
<tr>
<td>DP SQL Server</td>
<td>machine's name where Data Processing SQL database is located</td>
</tr>
</tbody>
</table>

6. Under SSRS section, complete the following:

| WPS SSRS SQL Server, DP SSRS SQL Server | web address of your report server, for example: https://constrtest85.bentley.com/ReportServer |

7. Click Finish.
A project and an eB user associated with that project is created.
Index

A
App Server certificate 34

C
community creation 25
configure
eB Work Queue Service 30
create
community 25
datasource 20
repository 29
storage device 27
create stored procedure 61

D
datasource
creation 20

E
eB Work Queue Service
configuration 30

H
hardware requirements 7–10

I
installation 52

M
mail distribution configuration 32
Microsoft SQL Server Properties 15

N
network requirements 7–10

R
register engines 32
register project 12
repository
creation 29
requirements
hardware 7–10
network 7–10
software 7–10
run stored procedure 62

S
secure connection 44
set up
view progress reports 47
settings
User Account Control 19
setup prerequisites 4–6
SNAPSHOT_ISOLATION 17
software requirements 7–10
storage device 27

U
User Account Control
settings 19

V
view progress reports 47