Bentley View CONNECT Edition Help

File Open Dialog (formerly MicroStation Manager)

Used to open and manage DGN files.

The default dialog to open DGN files is the Windows File Open dialog. To use the MicroStation Manager-type File Open dialog, from the Preferences dialog Look and Feel category ( File > Settings > User > Preferences ), turn off Use Windows file open.

Opens when the application is started without a DGN file specification or when Exit is chosen from the File tab .



A thumbnail image is stored in each DGN file that can be seen in File Open dialogs as well as Windows Explorer (the latter in versions of Windows that support this functionality).

For procedures related to using the default File Open dialog, see Using Windows File Open Dialog.

Note: By default, File Protection encrypts a file's thumbnail image and summary properties.
Note: If the preference Use Windows file open is on (the default) in the Look and Feel category of the Preferences dialog ( File > Settings > User > Preferences ), the File, Edit, Directory, and Help menus are not present, but most of the functions provided in those menus can be performed using the icon bar.
SettingDescription
Files Shows the name of the file that is selected in the list box or you can key in a filename.
Note: If the preference Use Windows file open is on, this control is labeled “File name.”
List Box Lists files for selection. The files listed reside in the directory chosen from the Drives option menu, filtered according to the file type chosen in the List Files of Type option menu. Double-clicking a filename in the list box selects the file.
List Files of Type Sets the type of file format.
Note: If the preference Use Windows file open is on, this control is labeled “Files of type.”
Show File Icons Displays icons next to the filenames in the Files list box above.

There are unique icons for the following types of files:

  • V8
  • V7
  • DWG

Glyphs at the corners of icons indicate certain file properties:

  • folded upper right corner - 2D (the file contains only 2D models)
  • ribbon on upper right corner - digitally signed (applicable to V8 DGN files only)
  • lock on lower right corner - protected (applicable to V8 DGN files only)
Note: If the preference Use Windows file open is on, this control is not present.
Drives Lists the drives and directories (listed above the drop-down menu) for selection.
Note: If the preference Use Windows file open is on, this control is labeled “Look in.”
OK

Opens the selected file.

Note: If the preference Use Windows file open is on, this control is labeled “Open.”
WorkSpace Selects the WorkSpace within which you want to select the WorkSet.
WorkSet Sets the location and names of data files associated with a specific WorkSet.
File Menu > Copy… Opens the Copy File dialog, which is used to make a copy of a file. This menu item is dimmed if a file is not selected in the Files list box.
  • Current Directory — Identifies the default directory for the destination file.
  • From — Identifies the source file to be copied — by default, the file selected in the File Open dialog.
  • To — Sets the name of the destination file to be created as a copy of the file identified in the From field. By default, the destination file has the same name as the source file with the suffix “.bak” appended or substituted.

    If the suffix “.bak” is used, after the file is copied the original file is still selected for opening in the File Open's File list box. If another suffix is used, the copy of the original file is selected for opening in File Open's File list box.

  • OK — Creates the destination file by copying the source file.
  • Cancel — Closes the dialog without copying a file.
File Menu > Rename… Opens the Rename File dialog, which is used to change the name of a file.

This menu item is dimmed if a file is not selected in the Files list box.

  • Current Directory — Identifies the directory in which the file selected in the File Open dialog resides.
  • From — Identifies the file to be renamed — by default, the file selected in the File Open dialog.
  • To — Sets the new name.
  • OK — Renames the file.
  • Cancel — Closes the dialog without renaming a file.
File Menu > Delete… Deletes the file that is selected in the Files list box.

An alert box opens, asking if you really want to delete the file. To delete the file, click OK.

This menu item is dimmed if a file is not selected in the Files list box.

File Menu > <DGN_file> If files have been opened previously, lists up to the last ten DGN files that were most recently opened.

The desired DGN file can be chosen from the menu.

Directory Menu > Select Configuration Variable Opens the Select Configuration Variable dialog. Use this dialog to change the directory of files listed in the list box by selecting a configuration variable whose definition points to a different directory.


  • List box lists the path and directory configuration variables for selection.
  • OK accepts the selected configuration variable and closes the dialog. The directory whose files are listed in the Files list box in the Open dialog changes to the directory specified in the configuration variable definition.
  • Cancel closes the dialog without changing the directory.

Directory Menu > Current Work Directory Changes the Open dialog's current directory to the operating system's current directory.